none
Internet Explorer 10,11 tab functionality being corrupted? RRS feed

  • Question

  • Long story short, I consult for a business that has over 100 pc's all Windows 7, mostly 64 bit, a few older 32 bit. I've got a handful of pc's (and the number seems to be growing) where IE, be it 10 or 11, has a tab problem.

    Everything I've googled that actually fits the same symptoms never has a resolution. The problem is as follows:

    When in IE there are actually 2 problems but both seem related to tabs being broken somehow.

    1. If you are on a page and right click and select open in new tab it will hang/freeze for 15 to 30 seconds, then open in a new window. This also occurs if a website link is set up to open in a new tab by default whether you select it or not. Some sites are this way and display this behavior on the working pc's as well as on the trouble pc's in other browsers, such as chrome and firefox.

    2. If you open IE and click the little new tab button next to your current tab it will not open a new tab, but instead will put the cursor in the url of the current tab. If you try to then type a url, you can type it out but it will not go to the url. No matter what you type it will just sit there and you have to close and reopen IE to get the url bar to work again on the original tab.

    Has anyone seen this behavior or can point me in the direction of what might be causing it? I've run some scripts that seems to fix it but I'll go back to those computers the next day and they display the same symptoms with broken tabs.

    Thanks for any help.

    Monday, April 3, 2017 3:06 PM

All replies

  • Hi,

    1.

    Are these intranet sites? or external internet sites?

    can you provide some examples please. eg.... internet.... from site xxz.com/about.htm ctrl click link to 'Help' at the bottom of the page.

    What type of links? to web pages or to pdf documents.

    Tools>Internet Options>General tab, 'Tabs' button. has the settings relating to tab/window process creation. Scripted window outcomes (links can be hyperlinks or scripted links) depend upon which IE security zone a domain is mapped to, IE's popup blocker settings, and any thirdparty browser Addons that have a popup blocking features (eg. google toolbar, yahoo toolbar, spyswat toolbar).

    Which proxy software are you using? SQUID? You could try bypassing it with fiddler for a test.

    2. The first step in trouble-shooting web browser issues is to test in noAddons mode.

    Start>Run>iexplore.exe -extoff [url]

    "If you open IE and click the little new tab button next to your current tab it will not open a new tab, but instead will put the cursor in the url of the current tab. "

    I have never seen the described symptoms....In the tabs section of Internet Options, what is the setting for the new tabs page? s.b 'The new tab page'.

    What scripts have you run to try to fix the issue?

    You should first troubleshoot from a client workstation or a test machine that is configured with your userProfile(s).

    Regards.


    Rob^_^

    Monday, April 3, 2017 7:26 PM
  • If you are on a page and right click and select open in new tab it will hang/freeze for 15 to 30 seconds, then open in a new window.

    Use Developer Tools to check the Console tab; enable the all Console messages option (in Options, Advanced tab) to maximize what this may show.  E.g. it sounds like a tab is crashing and recovering the tab in a new window.  ProcMon might assist if this is reproducible.

    No matter what you type it will just sit there and you have to close and reopen IE to get the url bar to work again on the original tab. 

    This sounds like a page script is preventing normal use of the Address bar.  So, what about Alt-Enter with what you typed?  Or what about using a Favorite or something that does not involve typing; e.g. my Home page is About:Blank so I would try clicking on the Home button to try to force the current page to be abandoned, so I could start over in that new environment (avoiding your current drastic workaround). 

    FWIW I'm not sure what would be the best tool to try to diagnose either of these symptoms yet.  I would keep trying to find the best workarounds and thus refining the symptom description with what those facts might imply.

     

    HTH



    Robert Aldwinckle
    ---

    Monday, April 3, 2017 10:01 PM
    Answerer
  • Hi,

    As Internet Explorer 11 has been released for almost 4 years and has a stable, favorable performance. I would recommend you to update all of your devices to latest Interne Explorer 11.0.9600.18617

    Try to run Windows build-in troubshooting tool to detect the issue in Control Panel\All Control Panel Items\Troubleshooting\All Categories\IE performance troubleshooter

    “I've got a handful of pc's (and the number seems to be growing) where IE”
    The symptom is not likely a normal issue, I suspect your devices might be attacked by virus or malware, try to update Antivirus software and  perform a complete system scan.

    We also could try to check the symptom in No Add-on mode as IECustomizer said.
    If the issue still persists, try to reset the Internet Explorer and tick “Delete personal settings” in Tools\Internet Options\Advanced\Reset.

    Best regards,
    Joy.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, April 4, 2017 10:55 AM
    Moderator
  • Thanks for the responses.  The PC that was giving me these issues that I had pulled to work on is now just working perfectly fine out of the blue.  I'll have to get another one I can swap out and test and I'll get back as soon as I am able to do so.  I'll post all my findings.  Thanks again.
    Tuesday, April 4, 2017 2:50 PM
  • Hi,

    Anyway, your device could be working perfectly is a news worth celebrating.

    Looking forward to your updates.

    Bests,

    Joy


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, April 5, 2017 2:02 AM
    Moderator