none
Turning Off Domain Firewall on Windows 2019 RRS feed

  • Question

  • I have a legacy SQL application that requires the firewall to be turned off on the server for compatibility. When I try to turn it off in the interface, it says For your security, some settings are managed by your system administrator. I am the system administrator and find this annoying.

    I found some articles that show how to turn off the firewall by command prompt or PowerShell, but when I use those commands, it will turn off the firewall for private networks and guest or private networks. The domain firewall remains on which is the one I need to have turned off.

    How do I turn off the domain firewall on the server?

    Thursday, November 7, 2019 5:02 PM

All replies

  • Hi,

    This is likely due to your server having group policies applied that controls the Windows Firewall profiles.

    You can change the Windows Firewall Domain Profile settings over here:


    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, November 7, 2019 5:20 PM
  • I was in these settings last night. I tried changing the firewall domain profile to off and not configured and then running gpupdate /force. Unfortunately, there is no difference in the Windows Defender Firewall settings. I still cannot turn the domain firewall off.

    Thursday, November 7, 2019 7:16 PM
  • So, for some reason it looks like even though Control Panel -> Firewall shows the domain profile is on, the group policy says it is turned off and it is off. This case can be closed, although I think there is a bug somewhere in Windows due to it showing a discrepancy. The legacy app was able to start without any problem.
    Thursday, November 7, 2019 7:42 PM
  • You can mark helpful replies as answer, this is a way of "closing" the thread.

    Blog: https://thesystemcenterblog.com LinkedIn:

    Thursday, November 7, 2019 7:48 PM
  • Hello,

    Thank you for posting in our forum.

    We can try to change policies"Windows Defender Firewall: Protect all network connections".

    Open the “Group Policy Management” console, create a new GPO, find>> Computer Configuration->Policies->Administrative Templates: Policy …->Network->Network Connections->Windows Firewall->Domain Profile.



    Hope the information can be helpful and if there is anything else we can do for you, please feel free to post in the forum.

    Best regards,
    Cynthia

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, November 8, 2019 8:03 AM
  • Hi,

     

    Just checking in to see if the information provided was helpful. Please let us know if you would like further assistance.

     

    Best Regards,

    Cynthia


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 13, 2019 6:26 AM
  • Hi,

     

    Just want to confirm the current situations.

     

    Please feel free to let us know if you need further assistance.

     

    Best Regards,

    Cynthia


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 15, 2019 9:51 AM