none
Visio 2016 Search Stopped Working RRS feed

  • Question

  • Hello,

    I'm hoping someone has a fix - I'm running Windows 7 w/Visio Professional 2016 32bit and out of the blue the shape search feature stopped working.

    I've rebooted, tried doing a repair, I made sure 'My Shapes' was indexed by Windows Search - still no search for me! Not sure if it's related but I recently uninstalled Visio 2013 as well as added a couple file system locations to my search index.

    Thanks for the help,

    Marshall


    Monday, February 20, 2017 7:00 PM

All replies

  • Hi Marshall,

    By "the shape search feature stopped working", do you mean the shape search pane disappears or the it cannot bring up the expected results?
    Is there any error message when the problem occurs?

    Please go to File > Options > Advanced, scroll down to the very bottom, confirm the check box of Show Shape Search pane is selected. Then click File Location and check if the file path for My Shapes is set properly:

    Please feel free to post back with any findings.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, February 21, 2017 8:12 AM
    Moderator
  • Thanks Yuki, By stopped working, I mean the search feature no longer returns results. Marshall
    Tuesday, February 21, 2017 1:54 PM
  • Try this. it worked for me

    Вернигора Андрей, http://eosfor.blogspot.com
    Используйте Problem Steps Recorder
    MCP, MCDBA, MCSA, MCSE

    Monday, April 10, 2017 8:50 PM
  • Another option to look at is this this. It seems like language of the document and on the stencils somehow influence Visio behavior.

    Вернигора Андрей, http://eosfor.blogspot.com
    Используйте Problem Steps Recorder
    MCP, MCDBA, MCSA, MCSE

    Tuesday, January 30, 2018 2:52 PM
  • Hi Marshall - did you ever get this working? What was the fix? Thx Jim
    Wednesday, March 14, 2018 2:04 PM
  • The mistake many make, as I did, is turning off Windows indexing for the Visio folders where stencils and templates are.  I did this in an effort to reduce the amount of time it took to search for files. The main folder for Visio 2016 Professional stencils is:

    C:\Program Files (x86)\Microsoft Office\root\Office16\Visio Content\1033

    You should also include your local shapes folder, such as:

    C:\Users\<username>\Documents\My Shapes

    Those folders must be included in the Indexing function.  As soon I checked the boxes for them, my Visio shapes started showing up in the results.

    I hope this helps someone!

    • Proposed as answer by jamesemannMVP Wednesday, August 8, 2018 11:17 AM
    Friday, May 4, 2018 8:17 PM
  • @Greengecko09 Thank you! This has been driving me nuts!!!
    Wednesday, August 8, 2018 11:17 AM
  • One additional root cause that has not been mentioned:

    Stencils are created in Metric or US Units. Visio search DOES NOT search for stencils that use different units than the drawing that is opened. Don't know if this behaviour can/should be changed.

    Quick way to test this: create a new blank drawing and choose the unit that you normally wouldn't choose, and try if search works. If you get results, then stencils are indexed but they are in wrong units. Don't know if its possible to convert stencils to another unit system, as I just discovered that this was causing my search issues.

    • Proposed as answer by Steve - SA Thursday, July 4, 2019 11:58 PM
    Monday, October 1, 2018 12:57 PM
  • Anybody managed to find a solid solution? The proposed links above did not work for me. 

    Seems that Microsoft never really managed to get around solving this issue till the time of writing, as I am having this terrible problem with Visio Professional 2019. 

    Tuesday, June 25, 2019 9:35 PM
  • I'm also seeing this problem when searching shapes in Visio 2019. Clean install on Windows 10 1903.
    Friday, October 18, 2019 5:24 AM
  • Recently purchased Visio 2019 Professional, same Problem. No solution. Please help :) Links did not work for me, too.
    Wednesday, November 6, 2019 3:18 PM