locked
Remote Desktop Connection Windows 10 not accepting Microsoft Account email sign on RRS feed

  • Question

  • When trying to establish a remote connection to a windows 10 client, I am only able to use the Microsoft account email sign on with the primary user of the computer.

    All other accounts require me to use the shortened system user name that gets generated by windows.

    These shortened usernames a generally the first 5 characters of your Microsoft Account email address and can be found either in the user listing "Name" field in computer management console, or by navigating to c:\users to see the folder names which will match the system user account.

    It is strange why the installation user works fine with the email as username but the others do not.

    Anyone know how to allow all users to RDP using their Microsoft account credentials.

    The connections are all on a local network, there are no servers or domains in use, it is simply client to client connections between windows 10 pro operation systems.

    Thanks in advance.

    Sunday, June 26, 2016 2:23 AM

All replies

  • Hi Regan Colville,

    As far as I know, we could control who could remote to the machine by configuring it here.

    Or try to add it to the "Remote Desktop" group(lusrmgr.msc).

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Tuesday, June 28, 2016 6:26 AM
  • Hi MeipoXu,

    Thank you for the reply.

    I am ok with how to configure the system to allow remote sessions and also how to assign users to the correct group in order for them to connect.

    What I couldn't work out is why the user was only able to make a connection using thier shortened username as per the internal user that windows created automatically when the hotmail profile was created.

    As an example say my hotmail account was called "johncitizen@hotmail.com"  and password "mypassword" if i tried to RDP using username  "johncitizen@hotmail.com" and password "mypassword" I would received a username and passsword could not be authenticated error in the remote desktop connection dialog.

    However if I was to username "johnc" and password "mypassword" then it would autheticate and connect me fine as it can recognise the shortened system generated username in the file sytem.

    Hopefully this example makes sense and is clear on what I am trying to achieve.

    I am not sure why the RDP can not authenticate the hotmail credentials that must be stored somewhere against the account? As it has no issue using these credentials when logging in to the machine locally.

    Monday, July 4, 2016 1:14 PM
  • I wonder if you ever got this to work? In order for it to work for me, I have to tell the computer that I want to log in with a local account instead. Is this the only option?

    Lucho1970

    Friday, June 19, 2020 4:12 PM
  • I run across this thread in the search of the answer and the following worked for me.

    1. I enabled the Remote Desktop Access on my Windows 10 Pro machine while logged in as Microsoft Account (MSA) user. The machine was setup to use MSA from start, there is no specially created local user except the "administrator" that gets created during initial setup. 

    2. I verified that my user (me) is in the Remote Desktop Users group (this gets setup automatically in step 1). To verify run user manager: Start + R: lusrmgr.msc. Note the local user name for yourself. In my case my email user1@hotmail.com mapped to user1. I have observed that other users with longer names like username@hotmail.com are truncated to usern local user as the above post describes.

    3. [The step that fixed it for me]: Logout from local machine and then log back in using password for your MSA (not PIN, fingerprint or anything else)

    4. After this I was able to login from Remote Desktop client on a Mac using the following: User: MACHINE_NAME\user1, Password: your_MSA_password

    Some possible explanation for this:

    1. When I setup the machine I immediately setup login PIN during initial process and have been using it ever since instead of password. This would be the same case if you use Windows Hello, Fingerprint reader or other similar device

    2. This type of setup (PIN from start) does not create a password hash which I assume is what RDP client uses to authenticate you in a remote session, so the step 3 (log out and log back in with a password) is what fixes it on the local machine and then remote client can send your password hash which matches the one stored locally on the machine. 

    In any case, this should be in the docs for Remote Desktop Access - Microsoft PMs I hope you monitoring recent replies and are able to fix this in future Windows updates (add docs, and detection for this case).

    HTH other people who run into this post while searching. Upvote if it does. 

    Thanks,
    Boris.


    Boris Baryshnikov, Azure Compute/Linux/OSS

    • Proposed as answer by pryank rohilla Saturday, June 27, 2020 9:28 PM
    Friday, June 26, 2020 2:34 AM
  • thanks. you saved a lot of hassle for me!

    Pryank Rohilla MCTS, MCAD

    Saturday, June 27, 2020 9:29 PM