none
This ftp site cannot be viewed in windows explorer (8)

    Question

  • I mistakenly installed google chrome (thinking i was getting google earth) and then uninstalled it. It corrupted IE8 so that i cannot use windows explorer to view our ftp site. (which means that i cannot use our site). Google chrome also corrupted windows outlook but i used a Microsoft fix to cure that.

    When i am at our ftp site and i go to "page" and then go to "Open ftp site in windows explorer" i get the error message "This site cannot be opened in windows explorer" I'm using IE8.

    Any thoughts?

    Thanks.

    Wednesday, July 20, 2011 4:28 PM

Answers

  • It turns out to be a registry issue.  I fixed it by exporting the HKEY_CLASSES_ROOT\ftp key from a computer that works fine and importing it into the broken one.  Make sure to back up the registry on the broken computer first and that you only do the ftp key.
    • Proposed as answer by MSRoach Wednesday, July 20, 2011 9:14 PM
    • Marked as answer by Miya YaoModerator Friday, July 22, 2011 7:34 AM
    Wednesday, July 20, 2011 9:14 PM

All replies

  • hi,

    Chrome is an open source application, it cannot corrupt any windows components, the only thing changed is the behavior and functionality which can be overtaken by chrome

    Wednesday, July 20, 2011 6:54 PM
  • hi,

    Chrome is an open source application, it cannot corrupt any windows components, the only thing changed is the behavior and functionality which can be overtaken by chrome


    Ok, so how do i correct the behavior and functionality that has been "overtaken" even though chrome has been uninstalled? IE8 and Outlook worked fine until Chrome was installed. (Once it became apparent that Chrome had "overtaken" IE8, it was uninstalled)

    mh


    mh
    Wednesday, July 20, 2011 6:59 PM
  • FTP behaviour:

    When you try to access an FTP site such as ftp://username:password@myftpsite/ IE will try to display the FTP site in an HTML view.

    go to IE8 options > advanced >  Enable FTP folder view (outside of Internet Explorer)  enable

    From within Windows Explorer you may need to do the following.  Click on File, select Login As:"...."

    Wednesday, July 20, 2011 7:07 PM
  • FTP behaviour:

    When you try to access an FTP site such as ftp://username:password@myftpsite/ IE will try to display the FTP site in an HTML view.

    go to IE8 options > advanced >  Enable FTP folder view (outside of Internet Explorer)  enable

    From within Windows Explorer you may need to do the following.  Click on File, select Login As:"...."


    It is already enabled. If it was not enabled, i would not have the option of going to  "Open ftp site in windows explorer" as i stated in the opening of my post.

    Any other thoughts?

    mh


    mh
    Wednesday, July 20, 2011 8:19 PM
  • can you please tell me what have you done, except the above? reseting etc...
    Wednesday, July 20, 2011 8:25 PM
  • can you please tell me what have you done, except the above? reseting etc...


    At some point, after i started getting the error messages, i went to IE8s security settings and had it reset to default. This accomplished nothing. Since then, besides fixing outlook with a microsft downloaded fix, i have done nothing to get rid ot the error message... besides doing exhaustive google searches for threads pertaining to this error. All the threads of the past are for IE7 not IE8 and i have found that they don't apply.

    So, to answer your question, what have i done? nothing for IE8. Our IT guru is at a loss here as much as i am.

    mh


    mh
    Wednesday, July 20, 2011 8:36 PM
  • It's amazing that I just found this thread.  One of my users is having the same issue with IE8.  I have completely reset IE8 on the Advanced tab (Delete Personal Settings was checked) and nothing changes.  If I manually type the ftp address into the address bar of Windows Explorer it opens up the site in IE.

    I have had so many issues with Chrome that I have gone to the extreme of completely blocking it from being installed.  I don't particularly mind it taking over all the associations when it installs, but I would appreciate it if it set them back to they way it found them when uninstalled.  As of now, it just drops the associations and leaves the user to figure everything out.  Very annoying.  Done with my rant, sorry.

    Wednesday, July 20, 2011 8:47 PM
  •  

    can you check that:

    User Key: [HKEY_CURRENT_USER\Software\Microsoft\Ftp]
    Value Name: Use Web Based FTP
    Data Type: REG_SZ (String Value)
    Value Data: Yes or No

     

    System Key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\URL\
    Prefixes]
    Value Name: ftp
    Data Type: REG_SZ (String Value)
    Value Data: ftp://
    Wednesday, July 20, 2011 8:56 PM
  • It turns out to be a registry issue.  I fixed it by exporting the HKEY_CLASSES_ROOT\ftp key from a computer that works fine and importing it into the broken one.  Make sure to back up the registry on the broken computer first and that you only do the ftp key.
    • Proposed as answer by MSRoach Wednesday, July 20, 2011 9:14 PM
    • Marked as answer by Miya YaoModerator Friday, July 22, 2011 7:34 AM
    Wednesday, July 20, 2011 9:14 PM
  • It turns out to be a registry issue.  I fixed it by exporting the HKEY_CLASSES_ROOT\ftp key from a computer that works fine and importing it into the broken one.  Make sure to back up the registry on the broken computer first and that you only do the ftp key.


    Worked perfectly. Thank you very much.

    mh


    mh
    Thursday, July 21, 2011 7:56 PM
  • Hi what do I do if I don't have another pc to export the key from?

    I am running windows 7 ultimate

    Friday, August 19, 2011 6:21 AM
  • Saturday, August 20, 2011 11:54 AM
  • Thanks for your response Don, In the meantime I was able to get the key exported from another win 7 pc and imported it into mine - this seems to have sorted the problem
    Sunday, August 21, 2011 11:38 PM
  • Ha Ha - "Chrome is an open source application, it cannot corrupt any windows components" - that is funny.

    But when I installed Chrome it did corrupt my Windows system and now I cannot open FTP sites !

    And Microsoft Word no longer follows its intenal hyperlinks.

    So, open source applications can have bugs and those bugs can damage your system - not so funny huh !

    Of course I am not suggesting that Google deliberately damages Windows - why would they want to do that ?

    Nevertheless, my advice is to never install Chrome on Windows - it damages your Windows configuraiton - and even uninstalling Chrome does not fix it.

    JCL

    Monday, August 22, 2011 1:22 PM
  • This worked for me as well.  The specific line missing was:

    [HKEY_CLASSES_ROOT\ftp\Extensions]
    ".IVF"="{C69E8F40-D5C8-11D0-A520-145405C10000}"

    WinXP, IE8

    Friday, September 30, 2011 1:56 PM
  • PLEASE PLEASE PLEASE tell me how to do this. I need to be able to open my ftp in windows explorer for work and can no longer do so. I am getting no help from the IT and this is the closest I have found to an answer but just can't find "[HKEY_CLASSES_ROOT\ftp\Extensions]" and I don't know how to import what I need from another computer.  Could you please send me a more detailed description of how to do it. I am sorry I'm not as computer savvy but would REALLY appreciate the help.  Thanks so much for your expertise and patience!
    Monday, October 24, 2011 4:57 PM
  • On my Windows 7 - AFTER uninstall of Chrome - this ftp key was missing it's values:

     

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\ftp]
    @="URL:File Transfer Protocol"
    "AppUserModelID"="Microsoft.InternetExplorer.Default"
    "EditFlags"=dword:00000002
    "FriendlyTypeName"="@C:\\Windows\\system32\\ieframe.dll,-905"
    "ShellFolder"="{63da6ec0-2e98-11cf-8d82-444553540000}"
    "Source Filter"="{E436EBB6-524F-11CE-9F53-0020AF0BA770}"
    "URL Protocol"=""

    [HKEY_CLASSES_ROOT\ftp\DefaultIcon]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
      00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,75,00,72,00,\
      6c,00,2e,00,64,00,6c,00,6c,00,2c,00,30,00,00,00

    [HKEY_CLASSES_ROOT\ftp\shell]
    @="open"

    [HKEY_CLASSES_ROOT\ftp\shell\open]

     

    This file can be saved as fpt.reg and imported simply by a double click on the file. Don't know if it will also fix Vista, XP etc.

    • Proposed as answer by PepperZzzz Tuesday, January 31, 2012 12:01 AM
    Wednesday, November 09, 2011 5:56 AM
  • Easy...Open windows exployer and put the address in at the top of the window.
    Thursday, November 10, 2011 10:46 PM
  • Well here it is months later... THANKS for the reg patch above.

    Chrome began acting strange (tho I do like it)... would not get to web (IE9, Opra, Safari all worked fine).  Then I noticed my FTP folders for various web sites were generic icons and went nowhere and IE9 would not allow viewing by Win Explorer.

    I searched for days on a fix.

    Then, a Microsoft tech browsing the WIn forum pointed me here.

    In less than 30 seconds, FIXED.

    Thanks Microsoft Tech Anoop P K,  Support Engineer

    Anoop P K
    Community Star

     and special thanks to TERKILDHOLST for the patch



    • Edited by CaptainGuy Saturday, February 25, 2012 4:21 PM
    Saturday, February 25, 2012 4:17 PM
  • I had the very same problem after installing google chrome.  It took me hours to find the above fix.  it worked perfectly.  copy it to notepad, call the file ftp.reg.  double click, and it works.  Thanks for the help
    Monday, February 27, 2012 4:21 AM
  • Thank you so much! I was having issues after uninstalling chrome, and this worked perfectly!

    Thursday, May 17, 2012 7:53 PM
  • Can you tell what are the values I need to create? Thanks in advance.
    Wednesday, June 06, 2012 9:07 PM
  • see previous answers.     [.]_[.]

    On my Windows 7 - AFTER uninstall of Chrome - this ftp key was missing it's values:

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\ftp]
    @="URL:File Transfer Protocol"
    "AppUserModelID"="Microsoft.InternetExplorer.Default"
    "EditFlags"=dword:00000002
    "FriendlyTypeName"="@C:\\Windows\\system32\\ieframe.dll,-905"
    "ShellFolder"="{63da6ec0-2e98-11cf-8d82-444553540000}"
    "Source Filter"="{E436EBB6-524F-11CE-9F53-0020AF0BA770}"
    "URL Protocol"=""

    [HKEY_CLASSES_ROOT\ftp\DefaultIcon]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
      00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,75,00,72,00,\
      6c,00,2e,00,64,00,6c,00,6c,00,2c,00,30,00,00,00

    [HKEY_CLASSES_ROOT\ftp\shell]
    @="open"

    [HKEY_CLASSES_ROOT\ftp\shell\open]

    This file can be saved as fpt.reg and imported simply by a double click on the file. Don't know if it will also fix Vista, XP etc.


    Rob^_^

    • Proposed as answer by OlaJohnson Wednesday, August 14, 2013 4:47 PM
    Wednesday, June 06, 2012 9:27 PM
  • There are some registry files missing. I found the missing registry values. download the file in the link below and run it to fix this issue. If you suspect the file, you can check it in notepad.
    http://www.sevenforums.com/attachments/network-sharing/193681d1326842538-ftp-sites-automatically-open-browser-instead-windows-explorer-ftp_key.reg
    • Proposed as answer by prapunpong Tuesday, January 29, 2013 4:12 AM
    Wednesday, June 06, 2012 9:46 PM
  • It worked fine for Vista Home Premium. Thanks for the fix. This issue is deplorable and I agree with those blaming Chrome. I even asked Google NOT to install it when installing Google Earth. It defiled Outlook and IE9/Windows Explorer by altering the registry on install and not returning it to the preinstall state afterwards. It is a poor software development practice, regardless of it being Open Source or commercial.
    Thursday, June 14, 2012 8:32 AM
  • Save the text below as a .reg file.  Double click to change to registry.  This is for Windows XP, IE 8.  Guaranteed to work.  I fixed my FTP sites after accidentally installing then uninstalling Google Chrome.

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\ftp]
    @="URL:File Transfer Protocol"
    "EditFlags"=dword:00000002
    "ShellFolder"="{63da6ec0-2e98-11cf-8d82-444553540000}"
    "Source Filter"="{E436EBB6-524F-11CE-9F53-0020AF0BA770}"
    "FriendlyTypeName"="@C:\\WINDOWS\\system32\\ieframe.dll.mui,-905"
    "URL Protocol"=""

    [HKEY_CLASSES_ROOT\ftp\DefaultIcon]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
      00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,75,00,72,00,\
      6c,00,2e,00,64,00,6c,00,6c,00,2c,00,30,00,00,00

    [HKEY_CLASSES_ROOT\ftp\Extensions]
    ".IVF"="{C69E8F40-D5C8-11D0-A520-145405C10000}"

    [HKEY_CLASSES_ROOT\ftp\shell]
    @="open"

    [HKEY_CLASSES_ROOT\ftp\shell\open]

    [HKEY_CLASSES_ROOT\ftp\shell\open\command]
    @="\"C:\\Program Files\\Internet Explorer\\IEXPLORE.EXE\" %1"

    [HKEY_CLASSES_ROOT\ftp\shell\open\ddeexec]
    @="\"%1\",,-1,0,,,,"
    "NoActivateHandler"=""

    [HKEY_CLASSES_ROOT\ftp\shell\open\ddeexec\Application]
    @="IExplore"

    [HKEY_CLASSES_ROOT\ftp\shell\open\ddeexec\ifExec]
    @="*"

    [HKEY_CLASSES_ROOT\ftp\shell\open\ddeexec\Topic]
    @="WWW_OpenURL"

     

    • Proposed as answer by Jaws007 Thursday, July 05, 2012 7:34 AM
    Thursday, July 05, 2012 7:34 AM
  • Thank u very much TerkildHolst, FTP was the only possible way i could take the backup of our VPN Router... & was facing problems in folder view... It got fixed as soon as I added"ShellFolder" string with its appropriate value...
    Wednesday, August 15, 2012 9:00 AM
  • Thank you very very much ... :) It works absolutely fine........... :D
    • Proposed as answer by phrai Tuesday, September 25, 2012 12:12 PM
    • Unproposed as answer by phrai Tuesday, September 25, 2012 12:12 PM
    Tuesday, August 28, 2012 1:08 PM
  • And I thank you all  Anoop P K , TERKILDHOLST & CaptainGuy :D
    Tuesday, August 28, 2012 1:09 PM
  • Just wanted to say thanks for this, if you've never been told that this has saved someone (a novice at the PC) the headache of trying to understand something which takes hours and in fact, something which I don't really want to understand, let me say so now, and thanks once again, very much appreciated. Keep making it simple and straightforward!
    Sunday, September 16, 2012 8:34 AM
  • I copied and pasted the registry entry and ran it as indicated. However I still can't see my files in the windows explorer. I had someone else log in to the ftp with their credentials and they could see everything. Anybody have an idea?
    Friday, September 21, 2012 4:19 PM
  • I know this site is listed as being for IT professionals - but I see that I am not the only "semi-experienced novice" checking out your fixes. 

    I am having the same problem - cannot view my website or my ftp site on this computer.  Have tried all the fixes that I can figure out with no change.  I am a bit afraid to try the registry fix - although I did finally find where it was:)

    I have uninstalled Chrome, added the ports suggested on another site, checked internet options and modified them, rebooted several times, opened in SAFE mode to see if I could load my website there.  Nothing.

    Any other suggestions would be greatly appreciated.  I'm thinking of copying everything in the registry and saving it - then putting in the suggestions above - may be my last resort.

    Thanks

    momfiend

    Saturday, September 29, 2012 7:22 PM
  • I was getting same error message: "This ftp site cannot be viewed in Windows Explorer" (Window 7 64-bit IE8)


    The ftp site I wanted to open was named "ftp://MyCompany.com/Logfiles/2012-10-12.txt" (a plain text file)

    When I changed the link above to point only to the folder: "ftp://MyCompany.com/Logfiles/" Windows Explorer opens the folder and lists all files as expected when clicking on "Open FTP site in Windows Explorer".

    Here my question:
    Why is option "Open FTP site in Windows Explorer" working when using URL: "ftp://MyCompany.com/Logfiles/" but not when using URL: "ftp://MyCompany.com/Logfiles/2012-10-12.txt"?

    Monday, October 22, 2012 12:39 PM
  • Thanks you SO much for this amazing help! Who knew that many months of anguish could be solved so simply and easily!
    Monday, October 22, 2012 5:05 PM
  • Yes, this is the answer!  Thanks for helping me resolve a thorny issue for my user.
    Wednesday, January 02, 2013 6:20 PM
  • Lucky guys, if this is the answer for you. For me, it seems to be a bug of Windows Explorer. And I hope that someone from Microsoft is recognizing that here.
    Thursday, January 10, 2013 10:12 AM
  • Because a plain text file is not an ftp site. You also can't open a plain text file with Windows Explorer from your local hard drive - you use notepad to open plain text files.

    Network and Systems Manager

    Friday, January 25, 2013 6:55 PM
  • Because a plain text file is not an ftp site. You also can't open a plain text file with Windows Explorer from your local hard drive - you use notepad to open plain text files.

    Network and Systems Manager

    In the past at times of IE 6 it was possible to open text files via ftp and Windows Explorer, which is not working today.
    I think a lot of users are not aware of Microsofts definition for an ftp site.
    If you select option "open this site in Windows Explorer" (ftp://mysite.com/logfile.txt) the message appears:
    "This ftp site cannot be opened in Windows Explorer."

    In this error message the word "this" is related to the URL shown in the address bar: "ftp://mysite.com/logfile.txt". Which implicates that the text file is an ftp site. A better error/warning message would be: It is not possible to open ftp files with Windows Explorer. But don't be surprised if you go the two step way: First open the ftp folder and then click the file. Now it is possible to open the file via Windows Explorer.

    Tuesday, January 29, 2013 12:50 PM
  • This worked great, thanks for the tip!

    Friday, February 15, 2013 2:44 PM
  • For the unfortunate savages, like myself, that are not use to modifying our XP Pro registers, I found that the file that was affected by Google Chrome, was the file mentioned above,  HKEY_CLASSES_ROOT\ftp. I suspect that I had the same problem as others, in trying to find this file, as it is NOT among the .ft? (note the dot) sub file listings directly under the aforementioned file. It IS shown as an "ftp" file further down the listings, among the all caps extensions. There are a total of 9 sub files in the ftp file, and Google Chrome removes 7. I copied the ftp file from another computer, and using the regedit editor, pasted it to the bad unit registry, by "highlighting" the existing bad ftp file, and utilizing the appropriate regedit editor command. I am using IE8, so I can't guarantee that this will work for any of the other operating software or IE versions. If you do NOT have another computer with the unmodified IE8 version, have a friend copy the file and email it to you. I have a web site with over 400 pages, and was at a loss in getting to my files until this correction. I downloaded an ftp web access program, but it was more work than it's worth.  Shame on Google for attaching the Chrome software to so many useful downloads. Worse yet, is the inability to remove this software without restoring the registry to its former format. BACK UP your registry before making ANY changes! Good Luck.


    • Edited by bobcan Saturday, March 09, 2013 11:50 PM
    Saturday, March 09, 2013 11:43 PM
  • Your solution worked beautifully.  My registry was missing the ftp key, so I followed your solution and imported one that was working on another computer.  Thanks!!!
    Saturday, May 18, 2013 4:30 AM
  • Thank you for this. You're a genius. It just worked like magic on my XP. phew, I was beginning to think I had a virus-ed chrome

    Wednesday, August 14, 2013 4:45 PM
  • THANK YOU
    Sunday, September 29, 2013 7:04 PM
  • MSRoach,

    You are a beast!! So simple but so effective. Worked perfectly for me, after an end user has installed chrome.

    Thanks again and much appreciated. (even if it is 2 years after your post :))


    • Edited by Irishtyrant Tuesday, November 12, 2013 2:06 PM
    Tuesday, November 12, 2013 2:05 PM
  • Does that also work on Windows 8?
    Tuesday, November 12, 2013 10:20 PM
  • Thank you very much. It is so easy for saving it as fpt.reg and importing by a double click on the file.
    Monday, March 10, 2014 10:56 AM
  • Thanks for your solution.

    That's work.


    • Edited by S.Ebra Monday, April 07, 2014 8:25 AM
    Monday, April 07, 2014 8:24 AM
  • On my Windows 7 - AFTER uninstall of Chrome - this ftp key was missing it's values:

     

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\ftp]
    @="URL : File Transfer Protocol"
    "AppUserModelID"="Microsoft.InternetExplorer.Default"
    "EditFlags"=dword:00000002
    "FriendlyTypeName"="@C:\\Windows\\system32\\ieframe.dll,-905"
    "ShellFolder"="{63da6ec0-2e98-11cf-8d82-444553540000}"
    "Source Filter"="{E436EBB6-524F-11CE-9F53-0020AF0BA770}"
    "URL Protocol"=""

    [HKEY_CLASSES_ROOT\ftp\DefaultIcon]
    @=hex(2):25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,00,6f,00,6f,00,74,00,25,\
      00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,75,00,72,00,\
      6c,00,2e,00,64,00,6c,00,6c,00,2c,00,30,00,00,00

    [HKEY_CLASSES_ROOT\ftp\shell]
    @="open"

    [HKEY_CLASSES_ROOT\ftp\shell\open]

     

    This file can be saved as fpt.reg and imported simply by a double click on the file. Don't know if it will also fix Vista, XP etc.

    This solution also works for Windows 8.1 x64 Update.

    Sunday, April 13, 2014 8:25 AM
  • Does that also work on Windows 8?
      Works on Windows 8.1 x64 Update.
    Sunday, April 13, 2014 8:29 AM