none
Website is opening in Enterprise Mode in IE 11. RRS feed

  • Question

  • Hi, 

    Our one of the website is opening in enterprise mode in IE 11. Even if we turn off the Enterprise mode from the Tools menu, the web page is still in compatibility view. In developer tool(F12) -> Emulation, if we change browser profile to "Desktop" then only page is rendered properly. 

    There is no website present in Tools -> "Compatibility View Setting". Even unchecked "Display intranet site in compatibility view".

    Please let me know why this particular website opening in "Enterprise Mode" and why it is not responding if we turn off "Enterprise mode".

    Thanks

    Previn S

    Thursday, May 4, 2017 8:09 AM

All replies

  • Hi,

    you manage Enterprise Site mode lists with the Enterprise Site Mode lists manager. The tools menu option for Enterprise mode does not update the sites.xml file....but to a log file instead (if logging has been turned on). You should review the MSDN documentation for EMSL.

    https://technet.microsoft.com/en-us/itpro/internet-explorer/ie11-deploy-guide/enterprise-mode-overview-for-ie11

    https://technet.microsoft.com/en-us/itpro/internet-explorer/ie11-faq/faq-for-it-pros-ie11

    https://technet.microsoft.com/en-us/itpro/internet-explorer/ie11-deploy-guide/manage-ie11-overview

    If you use the Emulation tab of the dev tool to change the emulation mode, and then close the dev tool, the current web page will revert back to its original emulation mode as specified in the sites.xml file.

    The easiest way to implement EMSL(assuming that you are migrating from a predominantly XP environment) is to catalog your intranet assets (by domain or IP), and then add those sites using the EMSL manager, setting 'Enterprise Mode' as the emulation mode for those domains. You then have to export that list (from the EMSL manager's Export menu) to your sites.xml file that you have set up on a network location. Each time a client workstation starts IE it will check for updates to that sites.xml file


    Rob^_^

    Friday, May 5, 2017 4:35 AM
  • Hi,

    Have you tried to turn off enterprise mode by GP? If not, please try it.

    1.Press Windows Key + R combination, type put gpedit.msc in Run dialog box and hit Enter to open the Local Group Policy Editor.

    2.In the left pane, navigate here:

    Computer Configuration -> Administrative Templates -> Windows Components -> Internet Explorer

    3.In the right pane of the above shown window, look for the setting named Let users turn on and use Enterprise Mode from the Tools menu and double click it.

    4.Clicking Disabled in order to turn off the Enterprise mode feature for your Internet Explorer.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, May 5, 2017 6:39 AM
    Moderator