none
cannot uninstall Remote Server Administration Tools for Windows 10

    Question

    1. On the desktop, click Start, click All Apps, click Windows System, and then click Control Panel.
    2. Under Programs, click Uninstall a program.
    3. Click View installed updates.
    4. Right-click Update for Microsoft Windows (KB2693643), and then click Uninstall.
    5. When you are asked if you are sure you want to uninstall the update, click Yes.

    But I get Error "An error has occurred. Not all of the updates were successfully uninstalled"

    I am a domain Admin.

    My computer was upgraded from Win 8.1 (with RSAT installed)

    I am having issues with Server Manager not working correctly (why I am trying to uninstall)

    Thursday, June 02, 2016 3:26 PM

All replies

  • Hi gsc73,

    Please refer to the following steps to remove the RSAT tool.
    1.Open Control Panel. Double-click Programs and Features. In the Tasks list, click Turn Windows features on or off. When the Server Manager console opens, click Remove features in the Features section of the home page.
    2.On the Select Features page of the Remove Features Wizard, select Remote Server Administration Tools Pack.
    3.Select remote administration tools that you want to remove from the local computer. Click Next.
    4.On the Confirm Removal Options page, click Remove.
    5.When removal is complete, exit the wizard.

    Or try to use the command line:
    dism /online /get-features
    dism /online /disable-feature /featurename:

    If the issue persists, please check the cbs(C:\Windows\Logs\cbs) log for more information to troubleshoot this issue. If you have troubles in analyzing the log, please upload the log to OneDrive and paste the link here.

    For Windows 10 RSAT tool, we could try to download it here.
    Remote Server Administration Tools for Windows 10
    https://www.microsoft.com/en-sg/download/details.aspx?id=45520

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, June 03, 2016 5:59 AM
    Moderator
  • I tried steps 1-5, unsuccessful.

    I am at my reserve training, and will try again when I return on June 27th.

    If unsuccessful, I may just re-install Windows 10 from scratch....what I always suggest...it seems upgrades never work "completely"

    Tuesday, June 14, 2016 4:52 PM
  • I am also having the same problem and still on the search for an accurate solution; using the latest RSAT for Windows 10 (WindowsTH-RSAT_TP5-x64.msu).

    I've spent several hours/days all over the net to find solutions from deleting orphaned user objects out of the registry (I have none), DISM, WUSA, reinstalling, removing from Programs and Features, subinacl.msi, stopping/restarting Windows Updates and dependencies (BITS, etc.), Safe Mode, cmd in Recovery, and so on.

    None of the prescribed solutions have worked. I am suspecting it may have to do with the 4.5.2/4.6 .NET framework; I could be completely wrong though. I've run into severe issues when 4.5.2 first came out; it crippled a TS server and a number of other things.

    It would be useful to know what the actual fix is as I believe it is effecting PowerShell for me. I am nearing a reinstall myself.

    Tuesday, June 14, 2016 6:34 PM
  • I have deleted items from registry...and I no longer get errors when I open server manager...but some items in server manager do not work correctly or populate info correctly.

    I really dont not want to re-image, as I have a lot of software to re-install.  

    It seems I may not have a choice.

     

     

    Tuesday, June 14, 2016 11:56 PM
  • Hi gsc73,

    Have you tried the command line? Have you checked the cbs.log?

    Try to reinstall the language package and try to install rsat again.

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Wednesday, June 15, 2016 3:16 AM
    Moderator
  • I have tried the folllowing command line:

    dism /online /get-features

    *I received the text "the operation completed successfully"


    dism /online /disable-feature /featurename:

    After the above I received "Error: 87"

    "The /featurename: option is missing a required argument.

    Here is link to cbs log

    https://tssgis-my.sharepoint.com/personal/gcarson_tss_tssgis_com/_layouts/15/guestaccess.aspx?guestaccesstoken=Y3P6PN4RotKaKgNMNBS3yBtyKASSBcMD0qwS3vNOPGw%3d&docid=14c861a1e9ad94d2da24c2d6bf49d8f82


    • Edited by gsc73 Wednesday, June 29, 2016 2:00 PM
    Wednesday, June 29, 2016 1:59 PM
  • Hi gsc73,

    I would make an apology for the wrong command line. The previous command line is used to disable the rsat not uninstall them.

    To remove the packages completely, please try the following steps.
    dism /online /Get-Packages
    In the command results, look for the package name that contains the text RemoteServerAdministrationTools.
    dism /online /Remove-Package /PackageName:<Name>
    Here is a link for reference:
    Installing or Removing Remote Server Administration Tools for Windows 7 (The steps should be applied to the latest version)
    https://technet.microsoft.com/en-us/library/ee449483(v=ws.10).aspx


    According to the log, it seems that there is something wrong with the registry key.
     "Error                 CSI    0000016a (F) STATUS_CANNOT_DELETE #655551# from Windows::Rtl::SystemImplementation::CBufferedRegistryProvider::SysDeleteKey(flags = 2, key =  ("[l:151]"\Registry\MACHINE\SOFTWARE\Microsoft\Fusion\PublisherPolicy\Default\v4.0_Policy.3.1.Microsoft.UpdateServices.Administration__31bf3856ad364e35\1\4.0.0.0""), disp = 2695355532 (0xa0a7dc8c))[gle=0xd0000121]
    2016-06-29 09:47:29, Error                 CSI    0000016b@2016/6/29:13:47:29.919 (F) base\wcp\sil\reg_buffered.cpp(695): Error STATUS_CANNOT_DELETE originated in function Windows::Rtl::SystemImplementation::CBufferedRegistryProvider::SysDeleteKey expression: (null)"
    Try to delete the registry key manually to have a test.

    "Exec: Processing complete.  Session: 30528012_3026490541, Package: Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~31bf3856ad364e35~amd64~~10.0.14300.1000 [HRESULT = 0x80070005 - E_ACCESSDENIED]"
    It seems that there is something wrong with the permission. Please try to login with the built-in administrator account to uninstall the package. Try to uninstall it in safe mode, too.
    If the issue persists, we could refer to the following link to have a troubleshoot.
    Using Process Monitor to solve any problem, including DebugDiag
    https://blogs.msdn.microsoft.com/benjaminperkins/2013/05/03/using-process-monitor-to-solve-any-problem-including-debugdiag/

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com






    Monday, July 04, 2016 6:23 AM
    Moderator
  • CMD prompt was "Run as Administrator".

    See error below and dism log file below.

    https://tssgis-my.sharepoint.com/personal/gcarson_tss_tssgis_com/_layouts/15/guestaccess.aspx?guestaccesstoken=MvCqjJN5nPMQjcVt00XFe5pAS2JUglHqW6D%2fz0Tj7%2bk%3d&docid=198eb26766bdc45219c313b3a103b1c81

    C:\WINDOWS\system32>dism /online /Remove-Package /PackageName:Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~31bf3856ad364e35~amd64~~10.0.14300.1000

    Deployment Image Servicing and Management tool
    Version: 10.0.10586.0

    Image Version: 10.0.10586.0

    Processing 1 of 1 - Removing package Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~31bf3856ad364e35~amd64~~10.0.14300.1000
    [==========================100.0%==========================]
    An error occurred - Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel Error: 0x80070005

    Error: 5

    Access is denied.

    The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log

    C:\WINDOWS\system32>

    Thursday, July 07, 2016 1:01 PM
  • Hi gsc73,

    Have you tried to delete the registry key I pointed out before manually? Have you tried to refer to the link and use Process monitor to troubleshoot the "Access is denied" issue?

    Best regards


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, July 08, 2016 2:08 AM
    Moderator
  • I have decided to re-load windows.  Too much time has been invested for further research.
    Tuesday, July 12, 2016 4:21 PM
  • Oh my gosh! I'm having the same issue as you! Glad it's not only me.

    You've done heaps more in diagnosing it. Did you find a solution?

    I'm also thinking of just starting again...

    Friday, August 05, 2016 6:44 AM
  • I have not re-loaded yet.

    I did just install the new Windows 1607 build (came out on Aug 2nd)

    I actually had to re-load RSAT after the update.

    I first wanted to re-load RSAT due to issues with Server Manger and my RDWEB setup.  I thought it was my PC, but its a problem with Winidows 10.  (Build 1607 has fixed my issue, with RSAT and my RDWEB setup)

    See issue below about RDWEB issue that 1607 build also fixed.

    https://social.technet.microsoft.com/Forums/windows/en-US/c8e1620b-7b81-47ae-ba90-5cb524758352/server-manager-does-not-populate-remote-desktop-services-overview-correctly-windows-10-pro?forum=win10itprogeneral#c8e1620b-7b81-47ae-ba90-5cb524758352


    • Edited by gsc73 Wednesday, September 07, 2016 8:11 PM
    Friday, August 05, 2016 1:27 PM
  • Removing the Registry Key resolved the issue for me and I could finally remove the RSAT-Tools. Thank you!
    Wednesday, August 10, 2016 2:39 PM
  • .. me also, step by step:

    in admin command prompt..
    dism /online /get-packages

    (look for Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~...... )

    then

    dism /online /remove-package /packagename:Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~....

    look in C:\Windows\Logs\CBS\CBS.log for STATUS_CANNOT_DELETE and \REGISTRY\MACHINE\SOFTWARE\Microsoft on the same line.

    Note the reg.. (in my case.. \REGISTRY\MACHINE\SOFTWARE\Microsoft\Fusion\PublisherPolicy\Default\v4.0_Policy.3.1.Microsoft.UpdateServices.Administration__31bf3856ad364e35)

    Delete it from registry.. (usual regedit caveats!)

    Re-run remove-package.

    Monday, August 22, 2016 11:24 AM
  • Thanks, that worked! Thanks for step by step ....

    K.

    Monday, October 23, 2017 6:55 AM
  • Sadly...over a year later...this is still the correct process to resolve the issue

    Friday, December 01, 2017 5:52 PM
  • This is what worked for me. I couldn't view the "manage user" tab options in AD and RSAT was alltogether fubard.

     

    I tried to:

    Delete the registry keys and then remove the windows feature and rsat

    Remove via wusa

    Remove via DISM

    Remove via Programs and Features > Add/Remove Windows Features

    The only way I could remove KB2693643 and the RSAT windows features are as follows:

    Just like Xtcne's response!

    1. Open command prompt as administrator

    2. run DISM /Online /Get-Packages

            2a. Copy and paste the output into a txt document such as notepad

    3. Run DISM /Online /Remove-Package /PackageName:<INSERTDATAHERE>

     

    In step 3 above, the <INSERTDATAHERE> should be the package name you copied from the Get-Packages list. You will need to run this each time, for each package that starts with "Microsoft-Windows-RemoteServerAdministrationTools...."

     

    So my step 3 looked like this:

    DISM /Online /Remove-Package /PackageName:Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~31bf3856ad364e35~amd64~~10.0.10585.0

    (selected "no" to restart)


    DISM /Online /Remove-Package /PackageName:Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~31bf3856ad364e35~amd64~~*AnotherVersion*

    (selected "yes" to restart after this 2nd command)

    Friday, January 26, 2018 5:19 PM
  • .. me also, step by step:

    in admin command prompt..
    dism /online /get-packages

    (look for Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~...... )

    then

    dism /online /remove-package /packagename:Microsoft-Windows-RemoteServerAdministrationTools-Client-Package-TopLevel~....

    look in C:\Windows\Logs\CBS\CBS.log for STATUS_CANNOT_DELETE and \REGISTRY\MACHINE\SOFTWARE\Microsoft on the same line.

    Note the reg.. (in my case.. \REGISTRY\MACHINE\SOFTWARE\Microsoft\Fusion\PublisherPolicy\Default\v4.0_Policy.3.1.Microsoft.UpdateServices.Administration__31bf3856ad364e35)

    Delete it from registry.. (usual regedit caveats!)

    Re-run remove-package.


    Awesome.  This worked on mine too.
    Tuesday, January 30, 2018 2:18 PM
  • powershell way

    cls
    
    Get-WindowsPackage -Online | Where-Object {$_.PackageName -like "*Microsoft-Windows-RemoteServerAdministrationTools-Client-Package*"} | Remove-WindowsPackage -Online -NoRestart
    if ($? -eq $false) {
        Clear-Host
        $CBSlog = Get-Content -Path "C:\Windows\Logs\CBS\CBS.log"
        foreach ($e in $CBSlog) {
            if ($e -like "*STATUS_CANNOT_DELETE*" -AND $e -like "*\Registry\Machine\Software*") {$Last = $e}
        }
        if ($Last) {
            $RegPath = (($Last -split "'")[1]) -replace "\\Registry\\Machine", ""
            $RegPath = "HKLM:" + $RegPath
            if (Test-Path -Path $RegPath) {
                Write-Output "postoji RegKey $RegPath -continue"
                Remove-Item -Path $RegPath -Recurse -Force
                Get-WindowsPackage -Online | Where-Object {$_.PackageName -like "*Microsoft-Windows-RemoteServerAdministrationTools-Client-Package*"} | Remove-WindowsPackage -Online -NoRestart
            }
            else {
                Write-Warning "ne postoji tražen RegKey - exit"
            }
        }
        else {
            Write-Warning "nije pronađen RegKey - exit"
        }
    }
    else {
        Write-Output "uspešno - done"
    }
    

    Sunday, March 11, 2018 3:19 PM