locked
Why are Outlook 2010 default fonts reset on first launch? RRS feed

  • Question

  • Hi there,

    I'm responsible for deploying Win 7 and Office 2010 to 5000+ machines and need to apply a default font style, colour and size to Microsoft Outlook and Word. I've achieved this with MS Word by deploying a custom Normal.dotm and NormalOld.dotm, know all about the registry keys I need to deploy to achieve the same in Outlook (the various binary values in HKCU\Software\Software\Office\14.0\Common\MailSettings) and have successfully deployed these using Group Policy too. However, upon first launching MS Outlook (as a brand new user), the values in the aforementioned key are deleted (if I look at the contents of the key, all the values are there until I launch Outlook for the first time). Can someone please tell me why and how I stop this?! It's also worth mentioning that I've also deployed the 'ImportPRF' value to automatically configure Outlook upon first use, but there doesn't appear to be anything in the PRF that would cause the issue. If I log out and back in to my test machine, sure enough my MailSettings values are replaced by GP and my font sizes are exactly as I want, but I want it all to happen first time round.

    HELP!


    Benji
    Tuesday, July 12, 2011 3:28 PM

Answers

  • Hi,

    I have the same issue for the default Outlook 2010 fonts, I ended up calling Microsoft for this.

    By design, Outlook will reset the settings to default values (deleting the registry keys) on first launch when a specific language infromation is not set in the registry.

    To prevent this behavior, set the HKCU\Software\Microsoft\Office\14.0\Common\LanguageResources\OutlookChangeInstallLanguage to YES (string value).

    It works for me.

    Patrick

    • Marked as answer by BenGmuN Tuesday, October 18, 2011 2:30 PM
    Thursday, July 28, 2011 5:19 PM

All replies

  • Hi

     

    Thank you for using Microsoft Office for IT Professionals Forums.

     

    From your description, this problem might occur if Office reverting default Global Template (Normal.dotm) on first launch.

     

    Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

    322756  How to back up and restore the registry in Windows

     

    I copied some information from this similar thread: http://social.technet.microsoft.com/Forums/en-US/officesetupdeploy/thread/7bce038e-a165-4195-ad5d-6be0905a98a2/

     

    Adding the following registry key and value can be done to prevent Word 2010 from renaming existing (or custom) Normal.dotm files:

     

    [HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Word\Options]

     "MigrateNormalOnFirstBoot"=dword:00000001

     

    This registry key can be added via a custom MSP file created with the Office Customization Tool - see the Additional content / Add registry entries section of the tool

     

    Please take your time to try the suggestions and let me know the results at your earliest convenience. If anything is unclear or if there is anything I can do for you, please feel free to let me know.

     

    Hope that helps.

     

    Sincerely

    William Zhou

    --------------------------------------------------------------------------------

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    • Marked as answer by William Zhou CHN Tuesday, July 19, 2011 9:21 AM
    • Unmarked as answer by BenGmuN Tuesday, October 18, 2011 2:30 PM
    Monday, July 18, 2011 6:53 AM
  • Hi,

    I have the same issue for the default Outlook 2010 fonts, I ended up calling Microsoft for this.

    By design, Outlook will reset the settings to default values (deleting the registry keys) on first launch when a specific language infromation is not set in the registry.

    To prevent this behavior, set the HKCU\Software\Microsoft\Office\14.0\Common\LanguageResources\OutlookChangeInstallLanguage to YES (string value).

    It works for me.

    Patrick

    • Marked as answer by BenGmuN Tuesday, October 18, 2011 2:30 PM
    Thursday, July 28, 2011 5:19 PM
  • Thank you, Patrick! Worked like a charm.

    William - my problem did not exist within Microsoft Word, it was Outlook that was in question. I was already successfully controlling the default fonts within Word 2010 using a 'normal.dotm' template downloaded at logon. Thanks for your response, regardless.


    Benji
    Tuesday, October 18, 2011 2:32 PM