none
Proxy “http://127.0.0.1” through Proxy Server in Edge, IE11 or IE10 RRS feed

  • Question

  • For some reason, I can push any domain through my internal proxy server, besides http://127.0.0.1 or http://localhost. Any other domain is proxied correctly. Making sure that "bypass proxy server for local domains" is unchecked doesn't really help.

    Reasoning: As many people may wonder why on earth would I like to do that: I have a bunch of modern.ie virtual machines for various versions of IE/Edge to test my projects on. Setting up a proxy like that would very easily allow me to test my local projects on these VMs without the need to hassle with creating host-only adapters and/or bridging the network and then trying to bind various applications to that interface (and re-configuring them to not use 127.0.0.1 in http redirects).

    Tuesday, December 12, 2017 9:52 AM

All replies

  • Hi,

    From Edge access the about:flags page to adjust you localhost loopback settings (including Flash loopback settings). You will need to close and restart Edge for the changes to take affect.

    Regards.

    Questions regarding Internet Explorer 8, 9 and 10 and Internet Explorer 11 for the IT Pro Audience. Topics covered are: Installation, Deployment, Configuration, Security, Group Policy, Management questions.


    Rob^_^

    Thursday, December 14, 2017 12:16 AM
  • Unfortunatelly, that does not do the trick. It looks like `localhost`, `::1`, and `127.0.0.1` are hardcoded deep into the .NET framework (and/or Edge/IE), as other tools (like fiddler) have the same exact problem.

    The only viable workaround is to use `localhost.` (with a dot at the end), which I outlined in my superuser thread: https://superuser.com/questions/1276382/proxy-http-127-0-0-1-through-proxy-server-in-edge-ie11-or-ie10/1276679#1276679

    This still requires some configuration on the app side, but I guess this is the point I can't go over.

    Monday, December 18, 2017 11:15 AM