locked
Sorry you dont have access to this page RRS feed

  • Question

  • I am currently experiencing a very unusual issue with a SharePoint 2013 on-premise. We have done performed a migration from SharePoint 2010 to SharePoint 2013 and when logged in as a user who is not a site collection administrator they are seeing the message "Sorry you don't have access to this page".

    We are currently finding however if you click black in the browser and navigate to the same page again then the users can access the page fine.

    We have give all users read permissions to the master page gallery and everything is checked in, published and approved.

    I have seen a few posts about user accounts not using claims authentication and we have run a script convert the user accounts however we are still seeing the same issue.

    Any help would be greatly appreciated.

    Thursday, February 11, 2016 12:51 PM

Answers

  • Hi Adam,

    Which script did you use to convert the user accounts to claims?

    Please try to run the following:

    $WebApp = Get-SPWebApplication "http://WebAppURL"
    $WebApp.MigrateUsers($true)

    After that, do an IISRESET.

    In addition, if you setup the accounts and give them permission via Web App Policy – you have to assign the account values using the Claims ID (i:0#.w|domain\user), NOT the (domain\user) NTLM ID.

    A similar thread for your reference:

    https://sharepointryan.com/2012/02/01/fix-access-denied-errors-for-claims-based-authentication-sites-for-users-with-permissions/

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Proposed as answer by Victoria Xia Monday, February 29, 2016 6:43 AM
    • Marked as answer by Victoria Xia Wednesday, March 2, 2016 7:52 AM
    Wednesday, February 24, 2016 8:55 AM