locked
How to increase the default file attachement size limit of 10240kb to 20480kb in Microsoft Exchange Server 2010 organization. RRS feed

  • Question

  • Hello.

    The Exchange Powershell  in exchange 2010  cmd let Get-TransportConfig indentify the following config

    [PS] C:\Windows\system32>Get-TransportConfig

    ClearCategories                                      : True
    DSNConversionMode                                    : UseExchangeDSNs
    ExternalDelayDsnEnabled                              : True
    ExternalDsnDefaultLanguage                           :
    ExternalDsnLanguageDetectionEnabled                  : True
    ExternalDsnMaxMessageAttachSize                      : 10 MB (10,485,760 bytes)
    ExternalDsnReportingAuthority                        :
    ExternalDsnSendHtml                                  : True
    ExternalPostmasterAddress                            :
    GenerateCopyOfDSNFor                                 : {5.4.8, 5.4.6, 5.4.4, 5.2.4, 5.2.0, 5.1.4}
    HygieneSuite                                         : Standard
    InternalDelayDsnEnabled                              : True
    InternalDsnDefaultLanguage                           :
    InternalDsnLanguageDetectionEnabled                  : True
    InternalDsnMaxMessageAttachSize                      : 10 MB (10,485,760 bytes)
    InternalDsnReportingAuthority                        :
    InternalDsnSendHtml                                  : True
    InternalSMTPServers                                  : {}
    JournalingReportNdrTo                                : <>
    MaxDumpsterSizePerDatabase                           : 18 MB (18,874,368 bytes)
    MaxDumpsterTime                                      : 7.00:00:00
    MaxReceiveSize                                       : 20 MB (20,971,520 bytes)
    MaxRecipientEnvelopeLimit                            : 5000
    MaxSendSize                                          : 10 MB (10,485,760 bytes)
    MigrationEnabled                                     : False
    OpenDomainRoutingEnabled                             : False
    Rfc2231EncodingEnabled                               : False
    ShadowHeartbeatRetryCount                            : 3
    ShadowHeartbeatTimeoutInterval                       : 00:05:00
    ShadowMessageAutoDiscardInterval                     : 2.00:00:00
    ShadowRedundancyEnabled                              : True
    OrganizationRelationshipForExternalOrganizationEmail :
    SupervisionTags                                      : {Reject, Allow}
    TLSReceiveDomainSecureList                           : {}
    TLSSendDomainSecureList                              : {}
    VerifySecureSubmitEnabled                            : False
    VoicemailJournalingEnabled                           : True
    HeaderPromotionModeSetting                           : NoCreate
    Xexch50Enabled                                       : True

     

    My question is the following:

    How do I How to increase the default file attachement size limit of 10240kb to 20480kb in  Microsoft Exchange Server 2010 organization for ingoing emails to all the email boxes and email mail stores on my single Microsoft Exchange Server 2010?

    I mean: what is the correct Exchange Powershell  in exchange 2010  cmd let Get-TransportConfig to increase this value?

     


    mvh Kenneth Knudsen MCSE 2003 HP ASE
    Thursday, May 6, 2010 4:20 PM

Answers

  • Sean has provided you with a link to the correct PowerShell syntax. You can also do this with the Exchange Management Console. Since this is a organization-wide setting, select

    * Organization Configuration
    * Hub Transport
    * Global Settings
    * Transport Settings

    Here you create a default value for all users for the send and receive message size. If you click Help or press Shift+F1, this help page will be displayed, which is quite informative:

    Configure Transport Settings Properties
    http://technet.microsoft.com/en-us/library/bb676532.aspx?v=14.0.694.0&t=exchgf1


    MCTS: Messaging | MCSE: S+M | Small Business Specialist
    • Proposed as answer by Alan.Gim Monday, May 10, 2010 7:33 AM
    • Marked as answer by Alan.Gim Thursday, May 13, 2010 5:36 AM
    Thursday, May 6, 2010 7:41 PM
  • You can use set-transportconfig http://technet.microsoft.com/en-us/library/bb124151.aspx

     


    Sean McNeill Microsoft Gold Partner http://staterainfrastructure.blogspot.com/
    • Proposed as answer by jader3rd Thursday, May 6, 2010 5:15 PM
    • Marked as answer by Alan.Gim Thursday, May 13, 2010 5:36 AM
    Thursday, May 6, 2010 4:36 PM

All replies

  • You can use set-transportconfig http://technet.microsoft.com/en-us/library/bb124151.aspx

     


    Sean McNeill Microsoft Gold Partner http://staterainfrastructure.blogspot.com/
    • Proposed as answer by jader3rd Thursday, May 6, 2010 5:15 PM
    • Marked as answer by Alan.Gim Thursday, May 13, 2010 5:36 AM
    Thursday, May 6, 2010 4:36 PM
  • Sean has provided you with a link to the correct PowerShell syntax. You can also do this with the Exchange Management Console. Since this is a organization-wide setting, select

    * Organization Configuration
    * Hub Transport
    * Global Settings
    * Transport Settings

    Here you create a default value for all users for the send and receive message size. If you click Help or press Shift+F1, this help page will be displayed, which is quite informative:

    Configure Transport Settings Properties
    http://technet.microsoft.com/en-us/library/bb676532.aspx?v=14.0.694.0&t=exchgf1


    MCTS: Messaging | MCSE: S+M | Small Business Specialist
    • Proposed as answer by Alan.Gim Monday, May 10, 2010 7:33 AM
    • Marked as answer by Alan.Gim Thursday, May 13, 2010 5:36 AM
    Thursday, May 6, 2010 7:41 PM
  • Unfortunately the Exchange Management Console does NOT expose the attachment size.  This must be done with the Exchange Management Shell using the command:

    set-transportconfig -ExternalDsnMaxMessageAttachSize xxxMB

    or

    set-transportconfig -InternalDsnMaxMessageAttachSize xxxMB

    Thursday, April 26, 2012 5:34 PM