none
Internet Explorer not opening links in new tabs properly

    Question

  • Hello.

    I recently rebuilt my laptop and installed Windows 7 SP1, and upgraded IE8 to IE9.  I'm not sure if this is something that was happening before I installed IE9, but when I click on a link and select either "Open in new tab" or "Open in new window" from the context menu, nothing happens.  This is only a minor irritation insofar as I can copy the link and open it manually in a new browser window, rather than having it opening itself.

     

    Is there a hotfix available, or something I need to uninstall perhaps?  I don't really want to move away from IE, but this is really starting to annoy.

     

    TIA

    Ian

    Sunday, May 29, 2011 11:36 AM

Answers

  • I tried both of those suggestions, and neither of them worked.


    Using No add-ons is just a quick way of checking whether you have some interfering software installed.  Unfortunately, some interferers don't get controlled that way.   So, the next quick test would be booting in safe mode and seeing if that prevented an interferer from starting.

    BTW a previously known cause of this symptom was some support software provided by nVidia.    That would obviously be something which would not be controlled by No Add-ons mode.  I don't know if it would be something which would not be started in safe mode.   If not whoever figured it out would have had to resort to some clean-boot troubleshooting, your next step if the simpler diagnostic procedures aren't successful.  ; )

     

    Good luck

    Robert Aldwinckle
    ---

    Wednesday, June 01, 2011 1:03 AM
    Answerer

All replies

  • Hi,

     

    According to your description, I suggest to perform these tests to troubleshoot the issue:

    1 Restore IE advanced settings:

    a.       Open Internet Explorer, click on Tools

    b.      Select Internet Options, In Internet Options box

    c.       Click on settings under Tabs

    d.      Click on Restore defaults and hit OK

     

    2 Run IE 9 in no add-ons mode:

    a. Click the Start button,

    b. Click All Programs,

    c. Click Accessories,

    d. Click System Tools, and then click Internet Explorer (No Add-ons).

     

    3 Use both IE 32bit and IE 64bit to see the result.

     

    Hope that helps.

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, May 31, 2011 3:05 AM
    Moderator
  • Hi Leo

    I tried both of those suggestions, and neither of them worked.  Any other suggestions?

    Tuesday, May 31, 2011 5:12 PM
  • I tried both of those suggestions, and neither of them worked.


    Using No add-ons is just a quick way of checking whether you have some interfering software installed.  Unfortunately, some interferers don't get controlled that way.   So, the next quick test would be booting in safe mode and seeing if that prevented an interferer from starting.

    BTW a previously known cause of this symptom was some support software provided by nVidia.    That would obviously be something which would not be controlled by No Add-ons mode.  I don't know if it would be something which would not be started in safe mode.   If not whoever figured it out would have had to resort to some clean-boot troubleshooting, your next step if the simpler diagnostic procedures aren't successful.  ; )

     

    Good luck

    Robert Aldwinckle
    ---

    Wednesday, June 01, 2011 1:03 AM
    Answerer