none
How to turn off Hyper-V permanently? RRS feed

  • Question

  • I've gone into Turn Windows features on or off. Clicked to turn off Hyper-V. Box is clear. This works well and I am able to run other conflicting apps like Virtualbox. But when I reboot, Hyper-V is back on and Virtualbox can't run. How do I disable Hyper-V permanently?
    Wednesday, September 28, 2016 6:58 AM

Answers

  • Hi Ben,

    That's odd. Based on my test, this feature won't be enable automatically after restart the computer.

    Please double check your operation:

    1. Press Windows key + X

    2. Click Programs and Features

    3. Click Turn Windows features on or off

    4. Expand Hyper-V, uncheck it.

    5. Click OK, restart if prompted.


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 29, 2016 8:50 AM
    Moderator

All replies

  • When you remove the feature and reboot, it is gone.  Removing the feature through add / remove programs uninstalls the hypervisor.

    Assuming that you are indeed removing Hyper-V the feature and not just the Management Tools.


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Wednesday, September 28, 2016 2:47 PM
  • Hi Ben,

    That's odd. Based on my test, this feature won't be enable automatically after restart the computer.

    Please double check your operation:

    1. Press Windows key + X

    2. Click Programs and Features

    3. Click Turn Windows features on or off

    4. Expand Hyper-V, uncheck it.

    5. Click OK, restart if prompted.


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 29, 2016 8:50 AM
    Moderator
  • Try this !!!

    Step 1 : Open CMD as administrator and type bcdedit /copy {current} /d "No Hyper-V" The entry was successfully copied to {ff-23-113-824e-5c5144ea}.

    copy the ID obtained in step 1. and use in 2nd step

    Step 2 : bcdedit /set {ff-23-113-824e-5c5144ea} hypervisorlaunchtype off The operation completed successfully.


    When you restart, you'll then just see a menu with two options...

    • Windows 10
    • No Hyper-V

    • Edited by Loser535 Monday, May 1, 2017 6:27 AM
    • Proposed as answer by PS_Namics Thursday, November 16, 2017 12:16 PM
    Monday, May 1, 2017 6:27 AM
  • How do you remove the options? I accidentally did the process twice and now I have to Hyper V off options but not hyper v on option

    THanks

    Monday, May 28, 2018 4:40 AM
  • This does not work on bewer builds like 1709
    Saturday, June 9, 2018 8:04 PM
  •  

    I have tried a load of thing to turn hyper-v off but every time I run VMware still say it running tied the two way in here also tried Powershell

    Disable-WindowsOptionalFeature -Online -FeatureName Microsoft-Hyper-V-All

    and tied cmd

    dism.exe /Online /Disable-Feature:Microsoft-Hyper-V-All


    • Edited by hopptop Monday, September 17, 2018 6:32 PM
    Monday, September 17, 2018 6:31 PM
  •  As explained in a previous post, you can run VMWare/VirtualBox on a machine with Hyper-V installed as long as the hypervisor does not load. You need two entries in the boot loader, one for Windows with the hypervisor and one for Windows without hypervisor. The entries are the same except for the value set for hypervisorlaunchtype. 

      If you are running one version you need to restart to load the other version.

      If you never want to run Hyper-V, simply set hypervisorlaunchtype to Off in your {current} config using bcdedit.


    Bill


    • Edited by Bill Grant Tuesday, September 18, 2018 2:04 AM
    Tuesday, September 18, 2018 1:07 AM
  • here my boot config say off but VMware still say it running

    Windows Boot Manager
    --------------------
    identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
    device                  partition=\Device\HarddiskVolume1
    description             Windows Boot Manager
    locale                  en-US
    inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
    default                 {aa8fab86-9445-11e8-a83c-bc370c1103fd}
    resumeobject            {aa8fab85-9445-11e8-a83c-bc370c1103fd}
    displayorder            {aa8fab86-9445-11e8-a83c-bc370c1103fd}
                            {ad5c4fb0-baa4-11e8-826e-38eaa789a55c}
    toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
    timeout                 30

    Windows Boot Loader
    -------------------
    identifier              {aa8fab86-9445-11e8-a83c-bc370c1103fd}
    device                  partition=C:
    path                    \WINDOWS\system32\winload.exe
    description             Windows 10
    locale                  en-US
    inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
    recoverysequence        {7db5cae3-93fa-11e8-823f-a9e1a57d45e8}
    displaymessageoverride  Recovery
    recoveryenabled         Yes
    allowedinmemorysettings 0x15000075
    osdevice                partition=C:
    systemroot              \WINDOWS
    resumeobject            {aa8fab85-9445-11e8-a83c-bc370c1103fd}
    nx                      OptIn
    bootmenupolicy          Standard
    hypervisorlaunchtype    Off

    Windows Boot Loader
    -------------------
    identifier              {ad5c4fb0-baa4-11e8-826e-38eaa789a55c}
    device                  partition=C:
    path                    \WINDOWS\system32\winload.exe
    description             No Hyper-V
    locale                  en-US
    inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
    recoverysequence        {7db5cae3-93fa-11e8-823f-a9e1a57d45e8}
    displaymessageoverride  Recovery
    recoveryenabled         Yes
    allowedinmemorysettings 0x15000075
    osdevice                partition=C:
    systemroot              \WINDOWS
    resumeobject            {aa8fab85-9445-11e8-a83c-bc370c1103fd}
    nx                      OptIn
    bootmenupolicy          Standard
    hypervisorlaunchtype    Off

    Tuesday, September 18, 2018 2:28 PM
  •   If that is the case, it is not Hyper-V which is causing your problem. There are lots of other things which use hardware virtualization. This includes some Windows processes such as Device Guard or Credential Guard, but also some anti-malware programs. There is no easy way to tell exactly what your problem is.

    See this discussion in this forum.

    https://social.technet.microsoft.com/Forums/en-US/8004c3bd-7d57-40ce-93de-0b1a6babd64c/how-i-can-disable-credential-guard?forum=win10itprovirt


    Bill

    Tuesday, September 18, 2018 11:27 PM
  • This worked for me given by Bluestacks. Tried every method found on web including one's given below but none of them prevented HyperV from running thus preventing Bluestacks and Logitech Webcam software. Their solution

    Please follow the steps given below and see if it works,

    - Hold down the Windows Key and press R on your keyboard.
    - The run dialog box will open. Type in the regedit and press OK.
     HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity and set the DWORD value to 0.  


    • Edited by Buddhu Friday, October 5, 2018 4:28 PM
    Friday, October 5, 2018 1:14 PM
  • amiduo said hyperv was running and genymotion said my cpu was not compatible /virtualization..  on my surface pro 3..  this fixed it.
    Saturday, October 6, 2018 3:15 PM
  • So I did these two steps and chose [No Hyper-V] on reboot. But still VMWare gives me the message "VMWare Player and Hyper-V are not compatible. Remove the Hyper-V role from the system before running VMWare Player.  In windows Features "Hyper-V" is not checked. I also unchecked "Windows Hypervisor Platform" and "Virtual Machine Platform." 
    Monday, April 22, 2019 5:28 PM
  • Not worked for me
    Sunday, November 24, 2019 7:47 AM
  • Has anyone gotten to the bottom of this yet? I have VMWare Workstation 15 and still I can't get it to start up without it saying Hyper-V is still installed when I have tried everything to remove it.

    Sunday, December 15, 2019 6:14 AM
  • If you are using CredentialGuard or DeviceGuard it will cause the system to use the virtualization hypervisor even if you aren't using Hyper-V.  You can see if this feature is enabled by running msinfo32 and scrolling down the right pane to look at the virtualization based security options.  Here's a screenshot from my PC that shows Virtualization based security is running and Credential Guard is using it.

    

    If you want to turn off virtualization based security first check to make sure your enterprise isn't forcing it on with group policy.  You can see that with gpresult /h output.html .  Alternately, if it's enabled via MDM (Intune or Airwatch) you can see that with the MDM settings report.  For either of those cases you won't be able to (easily) disable it locally.  If they aren't you can disable it by disabling virtualization based security using the following local group policy setting.

    Computer Configuration >> Administrative Templates >> System >> Device Guard >>> "Turn On Virtualization Based Security" set to disabled.

    VBS is not enabled by default, so there is a very good chance your enterprise has forced it.  Is there a reason you can't use Hyper-V, or do you have other virtualization images you'd prefer to use instead?

    Friday, December 20, 2019 4:37 PM