locked
Lost virtual machines after upgrade to Windows 10 1709 RRS feed

  • Question

  • I was successfully using my VMs (9 of them) yesterday in Windows 10 1703. I got the feature update to 1709 last night. I ran the update. Today, when I load Hyper-V Manager, I don't see all of the VMs that I had yesterday, only 6 of them. The three that are no longer listed are all on a different physical hard drive than the six that do appear (which are on the HD with the OS - drive C). The D: drive is physically there, I can access it, see the VM files, copy/delete, etc. 

    Is it possible to read the missing VMs without having to reimport them? I had made some changes in snapshots that had not been exported recently.

    Wednesday, November 15, 2017 9:25 PM

All replies

  • You should be able to just re-add them with import.  IIRC, you don't need to export them any longer to import them back in.
    Thursday, November 16, 2017 12:27 AM
  • Hi Wally Mead,

    Yes, I agree with essjae.

    Also the VM's still present in your data store, if so the long way round (depending how many VM's you have there) would simply be to re import them using the .vmx.

    Best regards,

    Carl


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, November 16, 2017 8:42 AM
  • Thanks for the suggestions guys. I just tried to reimport from the existing installed location, and get an error stating that it can't import due to already being registered. I took the default option to import with the existing ID. I have not Deleted them from the Hyper-V Management console yet, fearing that would remove some information.

    Should I delete them from the Hyper-V console, then import (if so, existing ID?)?

    I know that there is the option to import and copy, but the hard drive does not have enough space to do that for all three and actually only has enough space for the smallest one, the others are too big to fit in the remaining space if I import and copy. 

    As to the .vmx option, that I don't understand, but will see if I can find any information on it.

    Thanks again.

    Thursday, November 16, 2017 6:01 PM
  • Hi,

    To get the VMs back, first we move the VHDs of the disappearing VMs to another location.

    Then in Hyper-V manager, we add new VMs and select the VHD of the disappearing VM. 

    Best regards,

    Carl


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 17, 2017 11:33 AM
  • Thanks Carl. I am doing a copy of those three VMs right now to an external drive. I am guessing at some point it will tell me that I can't copy them as they are in use by the system. If I do get that, I then will stop the Hyper-V service.

    However, there are new developments here. I found that some of the remaining VMs (on my OS drive) would boot, but not communicate with each other. I saw online some references to issues with Hyper-V switches after the update to 1709. So given all these issues, I ended up reverting my laptop back to Windows 10 1703. After that, those VMs could communicate fine.

    And now those three missing VMs are back, however with a state of "Off-Critical". I'd seen that before, when my second hard drive came loose after a flight to a conference. When I got that previously, I just re-seated the drive, and all was good. Well, in this case, the drive is working fine (in fact, as mentioned above), copy those images, while still in Hyper-V, to an external drive.

    So now, what would you suggest? Is there any way to get the state of these changed back of "Off" so that they can boot? If so, I'd love to know the trick to doing that :-)

    If not, then would it work to:

    * Delete the VMs from Hyper-V Manager - I've seen that leaves a ton of files when I've done that for old VMs previously, but not sure if it deletes too much

    * Then add via New, Virtual Machine. Point to the existing folder on the hard drive.

    * Attach to the existing VHD file

    If that would work, would that also get all my snapshots back that had been created? That's my biggest concern. It looks like it had been a few months since I exported those images, so would have created some additional snapshots with new configurations.

    If that won't work, is there a way, or do I now need to blow them away (Delete from Hyper-V, physically delete from drive, then import my last exported backups, and recreate missing snapshots)?

    This is the first time that I've had any problems at all with Hyper-V. Been really pleased with it. And the first time in all the Windows 10 updates that I've seen any issues at all.

    Thanks again for the help.

    Friday, November 17, 2017 3:13 PM
  • Hi,

    Off-Critical indicates Hyper-V cannot find the XML configuration file for that virtual machine. Check if the file exists.

    If we delete VMs in Hyper-V manager, only the VHDx files would be kept. All the configuration files and snapshot files(including aVHDx files) would be deleted.

    If the VM is able to be exported, we may export the VMs to external drive. Check if the snapshot related files are also included, if not, I’m afraid the snapshot could not be restored. If yes, we could import and we got all the snapshots back.

    Best regards,

    Carl


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 20, 2017 7:13 AM
  • Thanks again for the response. 

    I can locate and open the xml file in this location: D:\VMs\ConfigMgr 2012 Domain Controller\Virtual Machines. That's where the VM points to. Same goes for all three of the Off-Critical virtual machines - there is an xml file for it in the Virtual Machines folder.

    I can't export the virtual machines while in this state - all I can do is Connect - but they won't start, giving an error of "The application encountered an error while attempting to change the state of 'ConfigMgr 2012 Domain Controller'". No more detail than that. The only other action I have for them is Delete, which obviously I don't want to do.

    Sounds like I have no much of a choice other than to go back to my previous export (a bit old), import them as new virtual machines (I'll have to delete them from Hyper-V Manager, as I don't have enough disk space to keep busted and imported), and recreate the missing snapshots.

    Monday, November 20, 2017 3:06 PM
  • Hi,

    Because there is a snapshot, you could merge the snapshot before importing

    I also suggest that you could import copied VM and test it out.

    Or manually merge to create a new virtual machine mount a merged virtual machine disk File.

    https://social.technet.microsoft.com/wiki/contents/articles/6257.manually-merge-avhd-to-vhd-in-hyper-v.aspx?PageIndex=2

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Eric0502 Tuesday, November 21, 2017 1:13 PM
    Tuesday, November 21, 2017 11:56 AM
  • Hi,

    Haven't received your message a few days, was your issue resolved?
    I am proposing previous helpful replies as "Answered". Please feel free to try it and let me know the result. If the reply is helpful, please remember to mark it as answer which can help other community members who have same questions and find the helpful reply quickly.
    Best regards,
    Carl


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, November 22, 2017 12:07 PM
  • The symbolic links under C:\ProgramData\Microsoft\Windows\Hyper-V\Virtual Machines are one of the issue.

    If you changed the default location where your virtual machines are located, the symbolic links will point to the original default location after the upgrade to 1709.

    First stop the Virtual Machine Management Service (Vmms.exe).

    Use PowerShell to recreate all the symbolic links to point to the right location.

    CD "C:\ProgramData\Microsoft\Windows\Hyper-V\Virtual Machines" 

    You can find were the actual symbolic link is pointing with:

    Get-ChildItem 4E899B2D-955E-4836-A295-D79B53301F7F.xml | fl *

    Recreate the symbolic link with:

    New-Item -ItemType SymbolicLink -Name 4E899B2D-955E-4836-A295-D79B53301F7F.xml -Target "V:\Hyper-V\Virtual Machines\4E899B2D-955E-4836-A295-D79B53301F7F.xml"

    Restart the Virtual Machine Management Service (Vmms.exe).

    All VMs will now be available under Hyper-V Manager.

    • Proposed as answer by kulmamies Thursday, January 25, 2018 1:27 PM
    Wednesday, December 27, 2017 12:00 AM
  • The above solution presented by gismaestro447 worked for me. Some notes: In my case, the symbolic links were corrupted so that they were otherwise correct but the drive letter was C when it should be D. The exact service name is "Hyper-V Virtual Machine Management". I did not use powershell but the Cmd instead and used del command to delete the old link and mklink to create a new one. The dir command shows also the target of the link.

    EDIT: But the snapshots (checkpoints) got lost :(

    EDIT2: Yes (see below), also snapshots came back after fixing the links in folder C:\ProgramData\Microsoft\Windows\Hyper-V\Snapshots

    • Edited by kulmamies Thursday, February 15, 2018 12:50 PM edit2
    Thursday, January 25, 2018 1:31 PM
  • Yes, deleting and restoring the VM file with 'mklink' worked for me as well.

    BTW @kulmamies, I think you could've kept your snapshots: I just restored mine (to the Snapshots folder, of course) in the same way as the VM files, and they are all working fine.

    Microsoft should really fix this - that sinking feeling when all your VMs disappear like that... not fun at all!

    Friday, January 26, 2018 7:08 AM
  • I managed to restore by deleting the symlinks and recreating them in 

    C:\ProgramData\Microsoft\Windows\Hyper-V\Virtual Machines

    and 

    C:\ProgramData\Microsoft\Windows\Hyper-V\Snapshots

    I installed and used Link shell extension...

    http://schinagl.priv.at/nt/hardlinkshellext/hardlinkshellext.html

    which allows you to just select the proper file, right click and then choose 'Pick Link Source' then go to the destination folder and right click before choosing 'Drop Symbolic Link' Restarting the Hyper V service shows everything up again.

    Monday, January 29, 2018 10:41 AM
  • Thanks so much. gismaestro447's fixed worked for me as well.

    I was freaking out yesterday after 1709 failed, all of my Storage Spaces were gone. So much for "resilient" storage... Magically after 1709 managed to install my Storage Spaces virtual drives were back. 

    https://social.technet.microsoft.com/Forums/en-US/a4e3723b-15de-4649-876e-2ce4630e16a8/storage-spaces-virtual-disks-disappeared-after-failed-windows-update-1709?forum=win10itprogeneral

    After this little scare, I'm going to move to Synology for data storage...


    Friday, February 16, 2018 8:54 PM
  • same desaster (developer Workstation Dual Xeon, 256GB RAM)

    20 VMs with old style (vmx) were lost

    Reimport not possible

    total caos on filesystem

    Windows tried to convert to new vm style?

    a lot of orphan vm files

    symlinks pointed to wrong direction

    6 vms:

    Cannot restore this virtual machine because the saved state data cannot be read. Delete the saved state data and then try to start the virtual machine.

    after deleting the 6 saced state data: one vm was gone! VMX was deleted

    4h to fix this

    OMG what a ...

    Conclusion: Win10 is not a Plattform for productive Hyper-V env.

    What a luck that I have exported all machines




    • Edited by Thoma Sunday, March 25, 2018 5:43 PM
    Sunday, March 25, 2018 5:40 PM
  • I lost most VM's on my main machines too. 
     
    Importing doesn't work as you say, and creating a new VM and attaching
    the old .vhdx requires reactivation if it's a Windows OS. 
     
    Not good as you say, not good at all.
     
    Sunday, March 25, 2018 10:05 PM