none
Opening .msg files with Outlook as default RRS feed

  • Question

  • Hi all, 

    I've been searching this all day to no avail. The situation we have is this 

    We use mail archiving with a browser interface (enterprise vault). when users double click an email in the browser search which is using IE it hands the .msg file to Internet explorer and begins an 'open or save?' routine. Clicking open will open in outlook. it does this EVERY time. 

    I want to default this behaviour so .msg files when opened in IE will call outlook automatically. I have searched high and low and found no result. The closest thing I've found 

    is by running 

    assoc .msg 

    this will give you the application that opens the file. then placing this at key 

    HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ Shell \ AttachmentExecute \ {0002DF01-0000-0000-C000-000000000046}

    as a binary value with no data. should solve the issue.

    I've found that this does NOT solve the issue. I cannot turn this behaviour off at all. Can anyone help? This is beyond irritating and is stopping the launch of a product. behaviour seems same in both IE9 and IE11 on windows 7 x64.

    Tuesday, December 1, 2015 11:45 AM

All replies

  • Hi,

    .msg files are considered unsafe, like .exe, .adbx, .docx etc and there is an IE security zone setting that determine what download options are displayed (open/save as) when a hyperlink on a web page to an 'unsafe' file type is clicked.

    Assuming that this is from an internal (intranet) website domain, that is mapped (automatically) to your client browser's Intranet zone, then a solution may be (untested by me) is to add the domain of your mail server to your browsers Intranet zone lists manually or with Group Policy....eg. mail.intranetdomain or *.intranetdomain

    or

    If you insist on using your web browser as a mail client, code your server code that displays the mail directory listing to use XMLHTTPRequests instead to return the .msg file as plain text instead of the .msg mime type.

    Regards.


    Rob^_^

    Tuesday, December 1, 2015 11:03 PM
  • Hi,

    .msg files are considered unsafe, like .exe, .adbx, .docx etc and there is an IE security zone setting that determine what download options are displayed (open/save as) when a hyperlink on a web page to an 'unsafe' file type is clicked.

    Assuming that this is from an internal (intranet) website domain, that is mapped (automatically) to your client browser's Intranet zone, then a solution may be (untested by me) is to add the domain of your mail server to your browsers Intranet zone lists manually or with Group Policy....eg. mail.intranetdomain or *.intranetdomain

    or

    If you insist on using your web browser as a mail client, code your server code that displays the mail directory listing to use XMLHTTPRequests instead to return the .msg file as plain text instead of the .msg mime type.

    Regards.


    Rob^_^

    Thanks Rob, 

    I knew the answer was going to be security based. it's annoying because we use Symantec Enterprise vault for mail archiving and this is the direction they've gone with email archive display.

    I can confirm that changing the intranet zone/trusted zone/whichever zone has already been tried and tested and this does not resolve my issue. I tried it just now again to confirm and no joy. 

    It's basically a webframe contained within the outlook window, so you browse the mail archive normally, and can preview mail, but when doubleclicking something to reply/forward etc, it passes the open operation direct to IE. I don't really 'insist' on using my web browser as a mail client, but we've certainly been forced to which is annoying.

    has the registry key details I outlined in my first post been deprecated? They certainly appear to no longer work.

    also, you mentioned

    .msg files are considered unsafe, like .exe, .adbx, .docx etc and there is an IE security zone setting that determine what download options are displayed (open/save as)

    is this list controllable and which setting is this specifically? I would like to test all options and present it to management with the relevant warnings etc.
    • Edited by dogfish Wednesday, December 2, 2015 5:54 AM
    Wednesday, December 2, 2015 5:37 AM
  • Hi,

    Would you want to set Outlook as default program when open .msg file?

    If so, you can open Control Panel\Programs\Default Programs\Set Associations, then select .msg and click Change Program to modify.

    The points that discuss above it the security for Internet Explorer, here's a link for details about enhanced security configuration: https://support.microsoft.com/en-us/kb/815141


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Wednesday, December 2, 2015 7:57 AM
  • Hi,

    Would you want to set Outlook as default program when open .msg file?

    If so, you can open Control Panel\Programs\Default Programs\Set Associations, then select .msg and click Change Program to modify.

    The points that discuss above it the security for Internet Explorer, here's a link for details about enhanced security configuration: https://support.microsoft.com/en-us/kb/815141


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    No outlook is the default and the mails will open correctly when you click 'open'. this is not a 'default application for extension' problem. It's specifically that when I am in a safe zone, I want the IE behaviour for .msg file being clicked to open outlook, not to prompt me for open or save. 

    enhanced security configuration is for servers. this is client side and not relevant. 

    Wednesday, December 2, 2015 8:00 AM
  • Hi,

    .msg files are considered unsafe, like .exe, .adbx, .docx etc and there is an IE security zone setting that determine what download options are displayed (open/save as) when a hyperlink on a web page to an 'unsafe' file type is clicked.

    Assuming that this is from an internal (intranet) website domain, that is mapped (automatically) to your client browser's Intranet zone, then a solution may be (untested by me) is to add the domain of your mail server to your browsers Intranet zone lists manually or with Group Policy....eg. mail.intranetdomain or *.intranetdomain

    or

    If you insist on using your web browser as a mail client, code your server code that displays the mail directory listing to use XMLHTTPRequests instead to return the .msg file as plain text instead of the .msg mime type.

    Regards.


    Rob^_^

    Thanks Rob, 

    I knew the answer was going to be security based. it's annoying because we use Symantec Enterprise vault for mail archiving and this is the direction they've gone with email archive display.

    I can confirm that changing the intranet zone/trusted zone/whichever zone has already been tried and tested and this does not resolve my issue. I tried it just now again to confirm and no joy. 

    It's basically a webframe contained within the outlook window, so you browse the mail archive normally, and can preview mail, but when doubleclicking something to reply/forward etc, it passes the open operation direct to IE. I don't really 'insist' on using my web browser as a mail client, but we've certainly been forced to which is annoying.

    has the registry key details I outlined in my first post been deprecated? They certainly appear to no longer work.

    also, you mentioned

    .msg files are considered unsafe, like .exe, .adbx, .docx etc and there is an IE security zone setting that determine what download options are displayed (open/save as)

    is this list controllable and which setting is this specifically? I would like to test all options and present it to management with the relevant warnings etc.

    Please see http://blogs.technet.com/b/askperf/archive/2007/11/27/managing-the-launching-applications-and-unsafe-files-setting.aspx

    the registry keys controlling this are undocumented, yes you can have additional white and black lists of other file types that you may wish to consider 'unsafe' in your environment. I am loathe to disclose undocumented security information in a public forum and I am unsure if they are still user definable in the latest versions of IE. With some research you should be able to find out for yourself.

    However, if I get the tenor of your question.. the solution lies in using an xmlhttprequest to open the .msg as text/plain and then rendering it in a webpage element, rather than the default mime-type handlers of outlook(desktop).

    "It's basically a webframe contained within the outlook window, so you browse the mail archive normally, and can preview mail, but when doubleclicking something to reply/forward etc, it passes the open operation direct to IE. I don't really 'insist' on using my web browser as a mail client, but we've certainly been forced to which is annoying."

    Unfortunately Outlook desktop uses an ieframe class window that defaults to IE7 emulation mode so you cannot use native XMLHTTPRequests to read the .msg file as text/plain, however you can use the MS XMLHTTPRequest active X control.....

    It is beyond the scope of this forum to provide coding recommendations or examples, however to get you started here is a mashup handler I use to populate an iframe with text/plain content from otherwise 'unsafe' files.

            function loadtext(url, ifr) {
                ifr.src = 'about:blank';
                var oReq = new XMLHttpRequest();
                oReq.addEventListener('readystatechange', function (evt) {
                    var req = evt.target;
                    if (req.readyState == 4 && req.status == 200) {
                        var doc = document.getElementById('ifrtarget').contentDocument;
    
                        var txt = req.responseText;
                        var mu = '<!doctype html><head>';
                        mu += '<meta name=\"viewport\" content=\"width=device-width, minimum-scale=0.1\">';
                        mu += '<style type=\"text/css\">';
                        //mu += 'html, body {margin:0;padding:0;height:100%;-ms-content-zooming:zoom;-ms-content-zoom-limit-min: 10%;-ms-content-zoom-limit-max: 500%;}img {display:block;max-width:100%;max-height:100%;cursor:zoom-in; }input {display:none;}input:checked + label > img {max-width:none;max-height:none;cursor:zoom-out;}';
                        mu += '<\/style>';
                        var color = (ifr.getAttribute('allowtransparency') == 'true') ? 'transparent' : 'white';
                        mu += '<title><\/title><\/head><body style=\"margin:10px;background-color:' + color + ';\">';
                        mu += '<pre style=\"word-wrap: break-word; white-space: pre-wrap;\">' + htmlEscape(txt) + '<\/pre>';
                        mu += '<\/body><\/html>';
                        //mu='<pre>'+txt+'<\/pre>';
                        doc.open('text/html','replace');
                        doc.writeln(mu);
                        doc.close();
                    }
                }, false);
                oReq.open('get', url, true);
                oReq.send();
            }

    eg.

    <a href="echo.js" onclick="loadtext(this.href, document.getElementById('ifrtarget')); return false;"target="ifrtarget">js</a>

    As I said, I am pretty sure that outlook (desktop) uses IE7 emulation and so you will have to modify the above to use the MS XMLHTTPRequest ActiveX object instead of the native js object. Note that you need to escape the text to display it correctly in a pre element. You should also consider first stripping the SMP header from the top of the text.

    You may like to hop over to http://stackoverflow.com (filter by Internet Explorer) to find examples of calling the legacy XMLHTTPRequest AX object.

    Regards.


    Rob^_^



    Thursday, December 3, 2015 2:40 AM
  • Hi,

    Sorry for misunderstanding your concern.

    Here's an article about how to "Disable 'Do you want to open or save this file?' download prompt":
    http://9to5it.com/internet-explorer-disable-do-you-want-to-open-or-save-this-file-prompt/

    Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Thursday, December 3, 2015 3:31 AM
  • wow, thanks for the extremely detailed response. Unfortunately this is an off the shelf product though (symantec enteprise vault for email archiving) and their latest version uses the behaviour I describe. I've basically been given the impossible 'make users like it' requirement of which this is flagged by management as an unpleasant change for the users.

    In any case, I'll go through that link you supplied regarding the keys in depth though and thanks again.

    Thursday, December 3, 2015 8:16 AM
  • Hi,

    Sorry for misunderstanding your concern.

    Here's an article about how to "Disable 'Do you want to open or save this file?' download prompt":
    http://9to5it.com/internet-explorer-disable-do-you-want-to-open-or-save-this-file-prompt/

    Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    No trouble. Unfortunately that link you gave is the exact link instructions I followed before arriving here. See my original post for the attempt i made based off these instructions. I had a couple of other colleagues arrive at the same article (or similar) and try the same thing and the response was 'doesn't seem to work' from all of them. 

    It does feel like the keys mentioned are something that have been deprecated via updates or whatever. I'm beginning to think that this behavior is both by design AND unpreventable via config modifications. 

    Thursday, December 3, 2015 8:20 AM
  • Hi,

    Any updates about Rob provided above?


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Allen Wang
    TechNet Community Support

    Monday, December 7, 2015 1:38 AM
  • If you want to open your MSG file without Outlook, yes you can open MSG file without conversion in any other format. you need a third-party Software You can read this Blog: softaken.com/kb/open-msg-file-without-ms-outlook
    Friday, July 19, 2019 9:09 AM