none
Disconnected sessions not being logged off after timeout RRS feed

  • Question

  • Hi all,

    Confused with this.  We have a collection which is set to log disconnected sessions after 5 minutes.  This is also set in a group policy.  The brokers are server 2016, session hosts are a 50/50 split between 2016 and 2019 whilst we fully test 2019.  Happening on both 2016 and 2019.

    I'm looking at the list of users right now and can see two who have been disconnected an hour ago.

    any ideas?

    Thanks


    Wednesday, August 21, 2019 8:10 AM

All replies

  • Hi,

    Please confirm group policy configuration about “End a disconnected session” which are located in the following locations:
    1》
    Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    2》
    User Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Session Time Limits

    Besides, if you check all sessions via GUI on Connection Broker, please remember to click Refresh to update the session list in order to find real time status. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 21, 2019 9:29 AM
    Moderator
  • Thanks, I only set it under computer config not user.  That could be it!

    I'll try it now.

    Wednesday, August 21, 2019 9:56 AM
  • Hi,

    Please feel free to let us know if you have any update. 

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, August 22, 2019 6:49 AM
    Moderator
  • Hi,

    How things are going there on this issue?

    Please let me know if you would like further assistance.

    Best Regards,
    Eve Wang  

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, August 26, 2019 1:09 AM
    Moderator
  • Hi,

    Is there any update?

    Please click “Mark as answer” if any of above reply is helpful. It would make this reply to the top and easier to be found for other people who has the similar problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, August 27, 2019 9:20 AM
    Moderator
  • I've been monitoring it over the last few days and it does look to have worked

    Thanks!!

    Tuesday, August 27, 2019 9:23 AM
  • Hi,

    Thank you for your updating the result.

    Please remember to click “Mark as answer” if any of above reply is helpful. It would make this reply to the top and easier to be found for other people who has the similar problem.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, August 28, 2019 1:52 AM
    Moderator
  • Unfortunately this has not fixed the issue.  We have noticed lots of disconnected sessions after many hours.
    Wednesday, September 11, 2019 6:57 AM
  • Hi,

    Confirm that if there is any event has been logged:
    Event Viewer -> Applications and Services Logs -> Microsoft -> Windows -> TerminalServices and RemoteDesktopServices

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, September 11, 2019 9:19 AM
    Moderator