none
How to set default zoom level in IE9

    Question

  • Is it possible to set a default zoom level in IE9 other than at 100%?  I would like to set IE9 at 125% which would make reading web pages much easier for me. At present I start with my.msn.com at 125%, but on occasion new tabs will revert to 100%
    Wednesday, March 16, 2011 9:26 PM

Answers

  • 'Rattler',

    Rt Click on the GEAR (top-right corner), click on/check/enable Status Bar.  Now @ the bottom-right corner of the browser window you will see, initially, 100% w/ a + to its left & a scroll arrow to its right.  Hitting the + will increase the Zoom Level OR the desired level can be selected via the scroll arrow (menu).  Having made your choice, opening a new site/tab will be @ that same level.. I trust this helps you.

    Regards,
    Drew


    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Wednesday, March 16, 2011 11:57 PM

All replies

  • 'Rattler',

    Rt Click on the GEAR (top-right corner), click on/check/enable Status Bar.  Now @ the bottom-right corner of the browser window you will see, initially, 100% w/ a + to its left & a scroll arrow to its right.  Hitting the + will increase the Zoom Level OR the desired level can be selected via the scroll arrow (menu).  Having made your choice, opening a new site/tab will be @ that same level.. I trust this helps you.

    Regards,
    Drew


    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Wednesday, March 16, 2011 11:57 PM
  • Drew,

    Thanks for your reply to Rattle's question regarding re-setting the Zoom Level in IE 9. It was very helpful.

    Thanks again.

    Seendy

     


    • Edited by Seendy Monday, May 02, 2011 10:22 PM a typo
    Monday, May 02, 2011 10:19 PM
  • You're very welcome, my pleasure, glad to help.  And you expressing your "Thanks" is much appreciated.

    Regards,
    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Monday, May 02, 2011 10:46 PM
  • For me changing the zoom factor via the tools menu is only temporary in IE9 and relates only to the current tab. Restart reverts to 100%

    Found a post relating to a permanent solution which was to change a registry setting. For me at HKCU\Software\Microsoft\Internet Explorer\Zoom, changed my setting from 80000 (decimal) to 100000 (decimal). Now IE9 starts up by default at 125%

    Cheers.

     

    Tuesday, May 03, 2011 4:42 AM
  • Good info.  For some the Registry can be a bit intimidating & (having) to play in it can be daunting, especially for layman or novices.  But, if one does know exactly what to do there, then, cool :)

    Sure beats a looking through binoculars, lol.
    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Tuesday, May 03, 2011 5:15 AM
  • Looks like the setting only works when ResetZoomOnStartup2 is also 0
    Tuesday, May 03, 2011 1:16 PM
  • I just thought I would let you know...

    I normally run my browser @ 100%.  But, to experiment for y'all I set 1 of the IE9 sites I have Pinned to the Taskbar to 125% and did a Restart... of course, everything closes & the Reboot takes place.  Once it was 'back' I opened the site in question & it was, indeed, STILL set @ 125%; moreover it changed ALL & ANY sites loaded w/ IE9 to 125%, not just that 1 site, only.

    NO REG CHANGES NEEDED!

    Cheers,
    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com

    • Proposed as answer by Drew1903 Friday, May 06, 2011 7:12 PM
    Friday, May 06, 2011 7:11 PM
  • I believe the default behavior is to save the settings of the last window closed. So, if you open a tab and change the zoom to 125%, that will hold up through a restart. However, if you have other windows/instances of IE open at 100% and close them last, your next startup will be at 100%.

    If you truly want IE to always open at 125%, I think you will need to use the registry and possibly group policy to enforce it.

    Friday, May 06, 2011 11:00 PM
  • Drew,

     

    I have IE 9 and it does NOT work the way you state. If I change the zoom to 100% the way you describe, when I open a new window OR TAB it reverts back to 125%.... Did you not test it? I am running version 9.0.8112.16421

     

    Dan Schultz

    oh... I noticed there is a setting under Internet Options, Advanced, "Reset zoom level for new windows and tabs"... This setting does seem to allow new windows and tabs to stay at the level you were at.  I would like the CTRL-0 to go to 100% like it did before... Not 125%...
    Wednesday, May 18, 2011 7:35 PM
  • Drew, can you please put it to us minions an EASY way to keep the zoom size at 125% ? Or did MS just pooch this one on purpose ? I`m beginning to hate IE9 everytime I open up a page because I`m afraid of what will go haywire or the uncertainty of most places I have to pay bills at that dont support IE9. And frankly I cant blame them
    Saturday, May 21, 2011 3:11 PM
  • Same site. This browser seems to have a mind of its own and personally I like to have control of it within reason. I asked my Facebook friends what their favorite browser was and MS IE9 was winning last place hands down ! You also mentionsome web sites are not up to speed with IE9 and thats true, BUT, the same site one minute is 125 % and the next its back to 100%


    If this is the way its intended to operate then again, MS pooched it. They might as well just had a check box next to a "Random at will" in the zoom box
    Saturday, May 21, 2011 6:51 PM
  • I'm sorry, I cannot duplicate what you describe.
    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Sunday, May 22, 2011 3:19 AM
  • Well Drew I`m not saying you cant, but others as well as myself are having this issue and its a major annoyance. Hopefully someone from MS will pipe in on this issue as well as others who could possibly be experiencing the same thing and hopefully get it resolved
    Monday, May 23, 2011 3:21 AM
  • I hope IE 789 comes out soon. Maybe by then they will have a fix for this zoom sizing issue. Untill then I`m going back to IE 8. This just isnt worth it
    Thursday, June 02, 2011 3:05 AM
  • Too bad you would let such a thing drive you back to IE8... IE9 is far better in many ways, on many levels, for many reasons than its predecessor.

    Personally, & I'll go out on a limb & suggest I'm far from unique, I don't have any problem or issue & can't find anything wrong w/ or even troublesome about the zoom item

    Sorry you do.
    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Thursday, June 02, 2011 6:42 AM
  • Has anyone found a solution to the zooming problem using a custom DPI?  I run at 120 because it's the best for all my applications and not being able to zoom to 100$ in IE 9 is annoying to say the least.

    Thanks,

    Rich

     


    Thanks, Rich
    Thursday, June 09, 2011 12:48 AM
  • The problem goes away if you use IE8
    Saturday, June 11, 2011 4:39 PM
  • Ok but, I'm not sure how important or critical this 'problem' & if one eliminates the (so-called) 'problem' by going (back) to IE8 nowone has the 'problem' of not using a browser that is as good as IE9 nor has the abilities & functionality that 9 offers compared to 8.  & therein lies a dilema...

    Fortunately, for me personally, this doesn't present me w/ a 'problem' & I can quite happily stay w/ IE9... but, hey, that's just me...
    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Sunday, June 12, 2011 1:13 AM
  • I have no interest in going back to IE8.  I want to use the latest and greatest.  The problem is not the number 99 instead of 100, The problem is that this 1% causes the font size on the screen to be significantly smaller.  I'm not sure how IE determines font size from these percentages, but I can tell you that the font when IE is at 99% is much smaller than it is at 100%.  It's definitely not just 1% smaller and it's very difficult to read

    Rich

     


    Thanks, Rich
    Sunday, June 12, 2011 12:50 PM
  • I CAN'T set it at 100%.  That's what this whole conversation is about!  Selecting 100 actually sets it to 99% which makes the text too small. If I set it higher than 100%, the text gets too big. In other versions of IE, I could set it at any number I please, including 100.  In IE 9, I can't set it to 100.  I can't even set it to 125 or many other standard sizes.  It just won't let you. This is a bug plain and simple.

    Rich

     


    Thanks, Rich
    Sunday, June 12, 2011 7:16 PM
  • I am referring to that!  If you read my prior posts, my complaint is that I can't set the zoom to any standard setting WHEN USING CUSTOM DPI SETTINGS.  I didn't repeat the "custom DPI" part in my last post because all my other posts referred to that and I assumed it was implied.  Sorry about that.

    Rich

     


    Thanks, Rich
    Monday, June 13, 2011 5:44 PM
  • Yes, I know & recall the prior 'conversations' but, the issues are not there when not using Custom DPI settings (1st).  W/ just the Standard stuff, works fine.  & that's all I'm saying; not forgetting, ignoring or missing anything.  I accept there is a problem when using Custom DPIs... I also, accept there is not problem w/ Standard settings.  Wish they were good enough for everyone OR that the Custom settings glitch would be rectified.
    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Monday, June 13, 2011 6:46 PM
  • Agreed.  I wouldn't be as annoyed by this if IE7 and IE8 behaved the same way.  It's the fact that it changed that's bothering me. It may not be a "bug" in the true sense of the word, but it's certainly unexpected behavior.  It allows me to pick these settings, but then it doesn't obey my choice.

    Rich

     


    Thanks, Rich
    Monday, June 13, 2011 7:50 PM
  • Rich, all this being said (& agreed) all I can suggest @ this point is report the issue to Microsoft Tech Support or a query to them/there, see what results that may produce.


    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Monday, June 13, 2011 8:24 PM
    • To set a default zoom in IE9, ex: 125%, 150%, etc...:
    • Open Internet Options
    • -(Menu bar) Tools / Internet Options / Advanced tab / click Restore advanced settings / Apply / OK.
    • (or)
    • (Control Panel) / Network anh Internet / Internet Options / Advanced tab / click Restore advanced settings / Apply / OK.
    • Now, you can set the default zoom at your wish. It work well on my laptop (Win7/IE9).

    Tung18 (from VN)

    • Proposed as answer by wuttawut Tuesday, April 08, 2014 7:56 PM
    Friday, June 17, 2011 7:37 AM
  • I've done more research and the reason IE 9 sets itself to 99% when I choose 100% is because it is always using 1% less than what I pick. For example, if I pick 101%, it will set it to 100%. So, I CAN get 100% after all, but I need to pick "custom" and set it to 101. This seems to be a bug to me.

    Thanks,

    Richard

     


    Thanks, Rich
    Sunday, June 26, 2011 2:56 AM
  • Maybe (it is) but, can't you just go @ 100% in the 1st place & not bother w/ the 'Custom'?
    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Sunday, June 26, 2011 5:46 AM
  • I'm not sure what you're saying.  I can't pick 100% in IE 9, thats what this whole discussion is about.  And for the DPI setting, 100% is too small on my screen.  I'm using a laptop at 1080p (1920 x 1080) and 100% is too small to read the text.  125% is too big.  I want somewhere in between.  It seems pretty simple to me that this should be allowed.

    Rich

     


    Thanks, Rich
    Monday, June 27, 2011 2:04 PM
  • I tried what you suggested but it does not keep it at 125% it defaults back to 100% each time you open a window.  Is there a way you can get it to stay?  I was just reading your response to Rattler
    Friday, August 26, 2011 9:33 PM
  • LOL thanks Drew for this info!!! you know the picky guys that want things a certain way??? well me.  Again, thanks for your post :)

     

    Sunday, January 22, 2012 11:43 PM
  • You're welcome; glad appreciated.
    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com
    Monday, January 23, 2012 2:33 AM
  • Maybe I am dense but I really do not understand how this works. I have had to manually reset each page.

    Perhaps Windows should be aware that folks who use large screen monitors have this problem.

    Any chance for a MS fix?

    Thanks

    Thursday, February 16, 2012 4:15 PM
  • Thank you! This was very helpful to me as well!

    Tuesday, March 27, 2012 12:06 AM
  • You're welcome.  I trust you marked it as such, too :)

    Cheers,
    Drew

    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com

    Tuesday, March 27, 2012 12:07 AM
  • Method does not work permanently; every time I return a page previously zoomed to a lower setting, it reverts to 150%.

    Saturday, July 07, 2012 8:05 PM
  • Thanks so much.  Only had the problem recently but your fix has solved the problem.
    Tuesday, July 24, 2012 2:06 PM
  • You're welcome.  Please, if you care to, remember to mark as Helpful.

    Drew MS Partner / MS Beta Tester / Pres. Computer Issues Pres. Computer Issues www.drewsci.com

    Tuesday, July 24, 2012 3:32 PM
  • It is easy to reset it. Go to View. Go to Zoom Size. Select your chosen default zoom.

    Monday, June 17, 2013 9:54 PM