none
IE11 Opening in New Window/Tab Non-functional RRS feed

  • Question

  • Hi all,

    I have a deployment of IE11 that I'm pushing out in one of our Task Sequences. Everything goes smoothly, but I've noticed some very odd behaviour on certain computers which have had this build.

    When clicking a link that's set to open in a new tab, IE11 simply opens a blank page. The URL shows as blank, and the page never loads in. Additionally, functionality is completely lost on web front-end systems. This mainly impacts "buttons" on the site, which would ordinarily open a new window/tab.

    Having researched the problem I'm not sure if this is currently solvable, though any help would be appreciated.

    Thanks,

    Dusty.

    Thursday, March 9, 2017 8:37 AM

All replies

  • Having researched the problem

    Did you find this

    https://support.microsoft.com/en-us/help/2574731/the-functions-open-in-new-tab-or-open-in-new-window-do-not-work-as-expected-in-internet-explorer-8

    I'm amazed that for how often we have cited that one that it is still so hard to find.  You have to know that it exists and that it has regsvr32 commands in it, one of which is ieproxy.  Unbelievable.  Unfortunately the top hit for that same information does not include essential information such as this one mentions and includes in its procedure.



    Robert Aldwinckle
    ---

    Thursday, March 9, 2017 11:27 PM
    Answerer
  • Yes I've found that and it does not resolve the issue. Tested on multiple problem machines.
    Friday, March 10, 2017 8:11 AM
  • Hi,

    <quote>

    This mainly impacts "buttons" on the site, which would ordinarily open a new window/tab.

    </quote>

    buttons on web pages use scripting to open windows/tabs. MSIE browsers have security zone settings restrictions on how scripted windows should be opened.

    MSIE browsers have a built-in popup blocker, which affects outcomes of scripted windows.

    Some Addons have their own popup blocker (eg. google toolbar) and this can interfere with the built-in popup blocker.

    ActiveX Filtering in IE may prevent SOME websites from rendering properly (blank but with source).

    The File>Properties menu will tell you which IE security zone the site is mapped to.

    Internet Options>Security tab, click "Reset all zones to default"

    To test if an addon is responsible first run IE in noAddons mode (iexplorer.exe -extoff ). It is likely to be toolbar addon. Uninstall or disable the Addons popup blocking features.

    If possible include links to any website(s) you are having problems with your questions.

    To find out if a website content is being blocked by ActiveX filtering see https://blogs.msdn.microsoft.com/ie/2011/02/28/activex-filtering-for-consumers/

    If activex filtering is turn on for a website that displays a blank page, turn it off as described above and refresh the URL.


    Rob^_^


    workaround: ctrl+click on button or hyperlink elements.
    Friday, March 10, 2017 8:56 PM