Windows 7 fails to go into safe mode. Stuck at classpnp.sys


  • Hi, I wanted to go into safe mode on windows 7 but it kept stopping at classpnp.sys . After reading a few threads I read about using Msconfig and checking the safe mode option under "Boot". It still keeps staying at classpnp.sys and when I hit F8 and hit "Last Known Good Configuration (advanced)" it seems to be able to get trough and it says it's actually loading up safe mode but then it changes to a black screen and does not change from that screen. I would appreciate and information you guys have that could solve this problem. If any of you know a command I could type in cmd to bring up the msconfig while in repair mode I  could fix it because all I need to do is untick "Safe mode on startup"
    Tuesday, March 9, 2010 12:43 AM

All replies

  • Hello,

    Try the following resolution:

    1. Boot the computer to windows recovery mode.

    2. Click Commmad Prompt, type in:

    rename c:\windows\system32\drivers\classpnp.sys classpnp.old

    Note: I assume that your windows is installed on C drive. I have tested this step, it will not crash your system.

    Tuesday, March 9, 2010 8:48 AM
  • Hello


    I have tried your resolution with no luck. I got the blue screen of death and then the computer reset it self back to c:\windows\system32\drivers\classpnp.sys

    I put my comp in safe mode to install the second disc of Fallout 3. I had to do this for vista. The problem was exactly the same then. I am now running windows 7 home premium 32bit. last time while on vista the computer fixed it self and after about an hour of looping loged on under safe mode. however this time this is not happening.

    I get from pushing the power button till a black screen with a cursor on it. Then it starts all over again.


    I'm not sure what else to do. I do not have install discs for either vista or windows 7. The shop in new zealand where i brought it from says we do not need them.


    Any suggestions.

    Tuesday, March 9, 2010 9:14 AM
  • This happened to me because I tried to install Fallout 3 too. I tried doing the c:\windows\system32\drivers\classpnp.sys to classpnp.old but then it just stops at the one before and goes on to say windows is starting in safe mode but then it shuts off and restarts.
    • Proposed as answer by Ankitsagwekar Monday, June 25, 2012 5:18 PM
    Tuesday, March 9, 2010 11:25 PM
  • This happened to me because I tried to install Fallout 3 too. I tried doing the c:\windows\system32\drivers\classpnp.sys to classpnp.old but then it just stops at the one before and goes on to say windows is starting in safe mode but then it shuts off and restarts.
    Glad to hear tat Fallout 3 is still being played.
    Firstly there are a few things that I have discovered. Classpnp.sys causes a few problems with the system. As I don't know what your system or brand of computer you are using, I'm not sure exactly what advice to give. However it should work a little something like this. When you start your computer you will see the brand name of the company who built the system (ie. Acer, HP, Compaq etc) Press either alt  + F10 or alt + F11.
    This will bring you to a recovery type menu. From here you can do a system restore you will loose any un-backed up data. This trick will restore your systems factory defaults systems. I have not been able to try this myself yet.
    Also depending on your what OS you are using you could try and and get a hold of either the Vista or Windows 7 recovery disks.
    You can download them from here:
    You will need a burning software as recovery disks need to be on disk so you can boot it up during windows start up.
    Use this software: ImgBurn

    Its free and is very effective (I can see this having more use with other iso files of mine)
    Again I have been unable to try this myself.

    And the last option short of formatting the drive is to use another piece of software called Ubuntu 9.10 Desktop.
    This is freeware that needs to be downloaded ( and then burnt on to a disk using the ImgBurn mentioned above.

    Put the disk into the drive and but it up during windows start up.
    You also need to download a replacement classpnp.sys file. You get this from
    (I also haven't tested this file yet but there other options on the site)
    While using Ubuntu find the classpnp.sys (C:\windows\system32\drivers\classpnp.sys) rename this to classpnp.bak
    Copy the recently downloaded version of the classpnp.sys to replace the old one.
    Exit and restart. The computer may lag a bit but should eventually boot into safe mode.
    Sadly I haven't been able to try this yet either.

    Although none of this helps with getting fallout 3 to install any easier.

    I will post with my progress and with what works in the near future. Hope any else can do the same.

    Good luck.

    • Proposed as answer by dotComGirl Tuesday, April 10, 2012 5:37 PM
    Wednesday, March 10, 2010 12:39 AM
  • I have sort of fixed the issue on my computer. For further information check my thread Windows 7 and the classpnp.sys safe mode loop. @ Erik Soto, I am still unsure on how to install Fallout 3 Game of the year edition with out going into safe mode for the second disc. As I had to go through all I did to get this far in fixing my computer I am unwilling to try it again until I have other methods.
    Wednesday, March 10, 2010 6:35 AM
  • I will try some of the things you said soon. My computer is a Gateway
    Friday, March 12, 2010 12:27 AM
  • Hello,

    Try a in-place upgrade to repair the corrupted files:

    In-place Upgrade
    1. Insert the Windows 7 DVD in the computer's DVD drive.
    2. Click Start and choose Computer.
    3. Please find the "setup.exe" file in the DVD-ROM and double click it.
    4. Click Install now.
    5. When we are prompted to input the product key, please click Next without inputting any key. The setup wizard will prompt and ask if you agree to install Windows 7 without the key. Please choose to confirm.
    6. When you reach the "Which type of installation do you want" screen, click Upgrade to upgrade the system files of Windows Vista.
    Monday, March 15, 2010 1:55 AM
  • I cant get past the safe mode boot up. And to Limbix, I tried the Ubuntu thing but it gets stuck at the white Ubuntu sign.
    Tuesday, March 16, 2010 4:31 AM
  • Besides above suggestions, please also try the following steps to troubleshoot the issue.


    1. Temporarily disable all unnecessary hardware devices in Device Manager, such as Modem, sound card or external device.


    For detail steps, we can refer to the link below:


    Device Clean Boot



    2. Run System File Checker (SFC) to verify whether any system file is corrupted.


    If the issue persists, I suggest you insert the Windows 7 installation disk and repair the system.





    Tuesday, March 16, 2010 8:44 AM
  • As stated before, I cant get past the Safe mode loop. It try's to go into safe mode and then  crashes and restarts and then repeats. I'm thinking of just re-installing windows 7.
    Tuesday, March 16, 2010 8:22 PM
  • My computer is a Gateway too.

    I started to have this problem after installing the Sniper Ghost Warrior game.

    After boot, system just stopped to boot in 'Windows is starting'.


    What I did:


    Into BIOS, reseted all configs to default. Than, reboot and, inside the BIOS (again), reset system to your old configs;

    Restart Windows and everything should work fine.


    (I had this idea when I read that this classpnp.sys was a hardware file);

    Tuesday, June 29, 2010 11:21 PM
  • I'm having some problems with my main HDD. HD Tune pro accuses it of having a very high spin number.

    I'm working on it;

    Tuesday, June 29, 2010 11:41 PM
  • Hello,


    A little late but I just wanted to point out that Limbix's solution worked for me.  Now, I never created recovery disks.  I have a Sony Vaio VGN-NS325J.  My computer would just hang on the startup.  Then I would get the blue screen of death.  It will restart and then give me the option to repair or start normally.  I would choose repair.  Attempted restore.  Initially it would work.  But as days went by, it would not restore at all.  It would just reboot continously.  I tried booting in safe mode and the system would hang at the Classpnp.sys file.  I applied the solution provided above to renaming the classpnp.sys with classpnpn.old.  Restarted and then the system would hang at the strtup, a brief BLOD would show and the computer would restart.  So the bad thing was that I never backed-up my data.  So my going in was to try Limbix's solution on pressing Alt+F10.  Low and behold, the reccovery screen showed up.  I was able to see my C: drive.  I backed-up my data.  You can backup up to 21 CD/DVDs worth of data in one session.  After four DVD worth of backed-up data, the computer restarted.  I applied the Alt+F10 key again.  This time, I chose restore computer to factory setting.  WARNING: This will wipe out everything (formats the drive and restores computer to the same condition when you first purchased it).  The computer restored back to the Old Vista Home premium (Originally it was bought with Vista with a free windows 7 upgrade sent later).  I did this last night, and I am currently writing this post from the same laptop.  Granted that I have to reinstall Windows 7 Upgarde along with the usual Antivirus, MS Office, copy personal files from the backed-up DVDs, etc, etc., I am a happy camper. Basically, I got my laptop back.  I am still unsure what caused the problem.  A friend of mine said that perhaps a windows update caused the crash.  I do not know.  A very good lesson has been learned.  I will create recovery disks that Sony offers and put them away in case I run into a similar situation in the future. 

    So thank you Limbix for the post.  It helped me tremendously. 


    • Proposed as answer by Gaz Ferg Wednesday, February 22, 2017 1:09 PM
    Tuesday, October 26, 2010 12:02 AM
  • a late reply from me, but is migth be helpfull for people with the same problem as above. I got the classpnp problem but none of the solutions helped for me. A re-install was the only solution i could think of but even in a re-install the system hung during the installation. I begun to think what the problem could be and started to disconnect everything. At last i got to the harddrives and there was the problem, the cable was fine, but the d-drive (not the windows 7 drive) was not. After disconnecting it windows started and made me a very happy man.
    Tuesday, April 12, 2011 6:47 PM
  • Try enter to BIOS and change the disk mode from AHCI to IDE, that works for me.

    My computer:

    Acer Aspire 5536

    Athlon X2 64

    Win7 32bits

    • Proposed as answer by TheVoIP Saturday, January 12, 2013 5:03 AM
    Saturday, May 21, 2011 5:14 PM
  • I am having the same issue. I have only had the laptop since January. It is the first time this happened. I updated Windows 7 and then it stopped. Everything I have been told hasn't worked. Trying the BIOS idea and then I'm stumped..


    Monday, June 13, 2011 11:00 PM
  • Had the same problem on TOSHIBA SATELLITE A660. 


    Good luck and thanks

    • Proposed as answer by Diegolcv Monday, April 30, 2012 4:25 AM
    Friday, August 19, 2011 2:13 AM
  • I though I'd share my solution for anyone else who stubles upon this topic.

    I had tried all the solutions posted here with no luck, as well as a myriad of other suggested solutions.

    1. Boot into Windows Recovery Mode

    2. Open command prompt

    3. Type: 




    It ran for a few minutes, and said it had successfully repaired some files.

    I rebooted, and successfully rebooted into Windows.



    • Proposed as answer by jimmi6 Sunday, March 4, 2012 10:22 AM
    Saturday, October 1, 2011 9:30 PM
  • Had the same problem. Windows 7 startup hung up on classpnp.sys in both normal and safe mode. I don´t know why exactly but resetting the bios via removing the battery fixed it.
    • Proposed as answer by jaycab Monday, September 30, 2013 2:21 AM
    Thursday, October 13, 2011 2:28 AM
  • Hi,
    I had the same issue yesterday with my pc after loading fail-safe bios settings (OC gone wrong).
    After a while I just remembered to change to AHCI in the bios again (I have an SSD)...
    Solved for me. :)

    • Proposed as answer by mtbwalt Sunday, February 10, 2013 5:35 PM
    Monday, October 17, 2011 4:59 AM
  • I had the same problem. If I rebooted the computer in safe mode it hangs, if I reboot in safe mode with command prompt it hangs. Anything I do it hangs. I used another hard drive so I can do a clean install of Windows 7, it even hangs when I boot from the Windows 7 DVD!!!

    I noticed that when windows would load files and freeze at classpnp.sys, the lights on my keyboard would go out. Then if I pressed a key on the keyboard the keyboard lights would turn back on. I disconnected my USB keyboard and rebooted... problem solved... sort of. I plugged the keyboard back in after a successful reboot. My computer then started running REAL SLOW!!! I have since restored my hard drive to an image that was backed up when I did a clean install.

    If it freezes at classpnp.sys, I believe from my experience it will most likely be a hardware issue. Disconnect all hardware that is plugged in any ports not internal to the case and start from there. Then it is process of elimination like removing ram sticks, video cards, PCI cards, extra hard drives etc... 

    What makes the most sense is that sometimes windows can get confused in regards to allocating resources that all the hardware installed on your computer requires and can mix it up at times (IRQs, etc...)

    Anyways, that's my experience. Hope this helps

    • Proposed as answer by Sean Mao 858 Monday, November 7, 2011 5:14 PM
    • Edited by Sean Mao 858 Monday, November 7, 2011 5:17 PM
    Monday, November 7, 2011 5:14 PM
  • There's a good chance that you may have a bad memory module or two.  I tried a repair disk, safe mode, an Ubuntu Live CD, booting up from a Windows 7 CD.  Nothing seemed to work.  That is when I decided to make a Memtest86+ bootable CD to test the memory.  Sure enough...I discovered two bad memory modules.  I threw away those bad modules, and rebooted the machine with the other 4 and everything is fine.  To check your memory using Memtest86+ go to and burn a CD from the ISO downloads they have there. I tried a million things before I realized it might be a bad memory. Hope this saves you hours of frustration! Enjoy!
    Thursday, November 10, 2011 5:40 AM
  • Will not crash? Blue screen after blue screen ensued, so it is worse than before...
    Dennis C Kamper
    Tuesday, November 22, 2011 12:29 PM
  • I got the same problem after updating to Win7 SP1.


    Thursday, December 1, 2011 1:09 PM
  • Same problem. Spent hours benching parts etc. Finally removed wireless card and computer boots just fine. Grrr. Must be an update knocked out wireless card our case, anyway. Good luck!
    Wednesday, December 7, 2011 4:37 AM
  • Same problem. Turned out to be an SDHC card. I suppose any recently added hardware can be suspect.

    Update: I inserted the same SDHC card back and it now boots fine.  Very confusing now.

    Wednesday, December 28, 2011 6:04 PM
  • If it is actually an issue with a corrupted driver, it might be possible
    to repair it offline,

    -- Mike Burr
    Wednesday, December 28, 2011 10:37 PM
  • Worked! Thanks!!!!!!
    Sunday, January 8, 2012 7:36 PM
  • Try enter to BIOS and change the disk mode from AHCI to IDE, that works for me.

    My computer:

    Acer Aspire 5536

    Athlon X2 64

    Win7 32bits

    This also worked for me. i have a sata hdd so never thought of this simple fix.


    Sunday, January 15, 2012 8:15 PM
  • Hi


    I've just had this with an Acer, System restore etc didnt help but the problem did occur shortly after a windows update


    I removed a wireless card from the system that wasnt in use and it booted straight up


    Thanks for the hint above



    Thursday, January 26, 2012 5:20 PM
  • Alright I have a dell xps 830 and today I ran Windows Update. My PC no longer boots into windows. I've tried safe mode and it stops at classpnp.sys

    I have tried system restore, system repair, etc.

    Next im going to try the disc upgrade.

    Wednesday, February 15, 2012 8:07 PM
  • I though I'd share my solution for anyone else who stubles upon this topic.

    I had tried all the solutions posted here with no luck, as well as a myriad of other suggested solutions.

    1. Boot into Windows Recovery Mode

    2. Open command prompt

    3. Type: 


    It ran for a few minutes, and said it had successfully repaired some files.

    I rebooted, and successfully rebooted into Windows.

    it worked,  thanks!!
    • Proposed as answer by ZionTech1 Monday, November 21, 2016 8:00 PM
    Sunday, March 4, 2012 10:22 AM
  • I have tested this solution. It does crash your computer. it gives a blue screen giving an error for a tenth of a second, then reboots.

    This Classpnp.sys error is one major pain. There are no definitive solutions to it. My netbook doesn't allow me to try the BIOS solutions mentioned.

    This solution "can" crash your computer, be warned.

    Wednesday, March 7, 2012 7:23 AM
  • hi there,

    I faced the same poblem too. tried all the sugestions... nothin worked.

    finaly tapped f8 and selected one of the debugging option.... worked!!!

    hope this helps..... :)

    Thursday, March 22, 2012 10:25 AM
  • Thanks !

    It works like a charm !

    Feel like a "Genius" !!

    Tuesday, April 10, 2012 5:38 PM
  • I am still in the process of chkdsk and later on sfw, but sfw didn't work for me with the commands posted in this thread, i searched around a bit and i found this:

    didn't try it yet but maybe it helps :)

    Oh wow was posted above already, oops Oo

    • Edited by Pimpmuckl Friday, May 18, 2012 2:59 PM
    Friday, May 18, 2012 2:30 PM
  • Check that your windows directory is actually installed on C:\

    I found that my Windows drive had been relabelled as I:\ in Startup Repair mode, even though it is C: when Windows is running.

    Sunday, June 17, 2012 2:40 AM
  • A friend of mine had the same problem. Just disconnect all the cable's (from laptop and powersource), take out batteries also. Reconnect, put batteries back inside and hold the powerbutton of laptop down during 30 seconds. Problem should be solved.
    Sunday, June 24, 2012 12:25 PM
  • Right, I battled long and hard witgh this one and found it to be quiet simple if you hold your nerve.

    1. Boot from the Windows install DVD or get to Recovery mode via your preferred method choose to start the System Restore mode

    2. Choose a point as far back as you can.

    3. Restart the machine when prompted and the WAIT!!!

    I waited almost 45 minutes with a black screen and a hyper active hard drive but hey presto it worked. As a precaution I ran an in-depth stress test to make sure nothing was indeed failing and I was lucky.

    Tuesday, July 3, 2012 1:48 PM
  • hey guys...never posted on any useful forum before :)

    very weird, while playing L4D2 coop with the gf,(her on my laptop and me on my rig(laptop gigabyte Q1532 if thats any help.)) game hung and nothing help[ed to exixt it except turning off,had same problems would load into Safe mode,recovery mode and obviously normal. I tried booting into UBUNTU and still nothing :/. i had the same problem with the  c:\windows\system32\drivers\classpnp.sys stopping safe mode,just figured i'd leave it for a long time and it logged on.went in deleted L4D2(i dont feel it could have been that as we were 2 missions in)but figured since its the only change/addition i have made to the system and now shes working :) and im talking about the Laptop :)  any have insight into this problem i would appreciate an explanation cuz im sooo baffled. and would like to know what caused it

    im sorry for rambling and im sorry if someone has said this earlier but its 01:10 on sunday morning and i dont want to read through all the replies so not sure if the prob you have is fixed.

    win 7 64 pro


    4gb RAM

    Saturday, July 28, 2012 11:20 PM
  • Running a Toshiba laptop, plugged in a Toshiba external hard drive...epic crash...hangs at classpnp.sys...all of the similar symptoms.  Cleaning off the external hard drive and found the "system volume information" folder on the external hard drive.  How does that happen.  Trying to fix now.
    Thursday, August 30, 2012 2:59 AM
  • I have tried all of these and had no luck. I had just replaced a bad MoBo with the same exact one,which i have done with systems before,but now gets stuck on the dreaded classpnp.sys. Ive done all the options in the recovery console,tried unplugging everything,taking the battery out and still no luck. Bought this PC after moving oifff of Craigslist and had worked great for almost a year,but that also means no install disk. I hadnt installed anything new in a while and no new for now im stumped.
    Friday, September 7, 2012 5:54 PM
  • Issue solved in my case:

    After having read lots of information over internet, I tried almost everything I was advised to do, tried repairing Windows, overwriting CLASSPNP.sys with more recent and older version, updating system BIOS and running chkdsk, all of that was in vain, the last one I had to take was to reinstall OS, but I had read some posts where people reinstalled OS with no success, so I decided to go for some hardware issue and after some tests I noticed that all the headache was been caused by a damaged memory, just took it out and chose "last known good config" at F8 startup menu, everything is working fine now.

    Hudson Medeiros MCP 2003/XP

    Saturday, September 22, 2012 4:08 PM
  • I have tried:

    Safe mode - won't boot

    changing classphp.sys to classphp.old results in a flash of blue screen of death prior to it rebooting itself

    Booting from Win 7 recovery CD and running start up fix - = no errors found

    Restoring to previous date - Failure any date picked

    Debugging mode - won't boot

    sfc /scannow - can't perform because a start up fix is in effect

    checkdisk = no errors found

    battery out - no effect

    I have attempted rebooting 30+ times still stalls at classphp.sys file using boot logging or the "starting windows" screen (left overnight, hours, days)

    Running laptop using an iso file of Linux Xubuntu on CD and laptop is running perfectly, so I don't think its a hardware issue in this case. 

    Have not installed any new hardware in last year.

    Laptop is a Toshiba Satellite A505--6991 series,  Core 2 duo, Win 7 (purchased pre loaded Oct 23 2010). 500GB HD 16GB Ram

    Wondering if when Win 8 comes out upgrading may fix this so I don't have to reformat my entire hard drive (as above have seen reformatting has resulted in same error) and reinstall everything....  otherwise considering either completely installing the Xubuntu side by side for the time being and or if I have to reformat anyway.. making this a Linux machine completely... 

    Thursday, October 11, 2012 3:30 PM

  • I had same issue..boot your PC in safe mode using F8 . It will hang at classpnp.sys. Don't give up,do nothing and after a while your pc should restart itself and you should be able to get in with no issues.
    • Proposed as answer by mcatudal Monday, October 29, 2012 1:04 PM
    • Unproposed as answer by mcatudal Monday, October 29, 2012 1:04 PM
    Tuesday, October 16, 2012 9:19 PM
  • AI got the same problem on my HP Z400 workstation.

    That problem was occur after a BIOS default setting application.

    My problem was concern the RAID+AHCI setting... I change it for IDE and BINGO!
    It was solved the problem.

    Hope this help.

    Monday, October 29, 2012 1:07 PM
  • As it turns out, you're all going to find that something different is wrong with each of your computers. Yes it is a hardware issue when CLASSPNP.SYS is the offender.

    For me, it turned out that I had a hard drive on my secondary Marvell controller that would act up. All I had to do was remove power from that drive and my computer booted fine. Subsequently after booting into Windows I could then turn the key on the pull out drive tray which reapplies power to the drive and I have access to the drive. I am going to check now for driver updates from Marvell that I may have missed.

    I have an ASUS P8P67 EVO motherboard which actually has Intel and Marvel controllers along with a lot of other stuff that could have gone wrong. I stumbled across the hard drive issue because I didn't want my c: drive to become the f: when I ran a recovery with multiple drives installed. And one reboot before I was to run the recovery, my computer started working again, consistently I can recreate the error by having that drive powered during the boot process and it locks up every time at CLASSPNP.SYS.

    So start removing hardware one at a time (includes memory modules) untill you get a good boot. Then put all the hardware back in (powered off of course) except the last item you had removed before the computer started acting normal, again.

    Good Luck, I hope this helps people diagnose their computers and driver issues.

    Wednesday, October 31, 2012 6:35 PM
  • I made an upgrade in my bios and this error started.

    When I clean my bios, AHCI config was lost, to solve I just change from IDE to AHCI and it worked again!

    Saturday, November 24, 2012 10:30 PM
  • This was a great idea, in my case I got the blue screen after the classpnp.sys like everyone else but that was due to laptop MB exchange. I had to change e SATA mode to IRRT
    Saturday, January 12, 2013 5:02 AM
  • I had the same problem. I took my USB mouse out from my laptop, fixed this problem. I do not know why Win 7 stack at USB connection. My clinet had the same problem before. He put USB drive connect to his laptop and his laptop did not boot. His USB drive had only word files or excel sheet documents. No bootable OS. I fixed his non-bootable Win 7 by taking his USB drive off from his laptop. My case was USB mouse. 

    Wednesday, March 13, 2013 7:04 PM
  • Awesome, this worked for me too, thanks Carlos :)
    Thursday, March 21, 2013 6:32 AM
  • Peeps I know how stupid this will sound but when your laptop stop on the welcome screen just long press shift button ad it will unstuck .... WELL IT WORKED FOR ME.... 
    Sunday, April 14, 2013 1:14 AM
  • Try enter to BIOS and change the disk mode from AHCI to IDE, that works for me.

    My computer:

    Acer Aspire 5536

    Athlon X2 64

    Win7 32bits

    Awesome this worked. I was really stumped on what to do since I'm not very computer savvy. However, where would I go from here to go back into AHCI mode, since my PC seemed to run faster in that mode?

    Pretty much, how would I fix the problem so I could get my PC running the way it used to.

    In case you need them? Specs:

    Toshiba Satellite S855

    Intel i7 2.3GHz

    6GB Ram

    AMD Radeon HD 7670M

    Friday, April 19, 2013 2:40 PM
  • sfc worked for me also .. thanks heaps for help! I thought I'm gonna through the laptop through the window!!
    Friday, July 19, 2013 12:54 PM
  • Ok, so the CLASSPNP.SYS is causing problem again. After every single Windows Update, the windows don't start. If I try Safe Mode, they get stuck on CLASSPNP.SYS. The SFC works, but I can't do this after every Windows Update. Does anyone have a clue, what this could be causing? :/ I'm running Win7 Ultimate x64 SP1. Also, the problem started after I installed SP1. :/
    • Proposed as answer by Mealit Saturday, August 3, 2013 1:58 AM
    • Unproposed as answer by Mealit Saturday, August 3, 2013 1:58 AM
    • Proposed as answer by Mealit Saturday, August 3, 2013 2:13 AM
    Saturday, July 20, 2013 11:59 AM
  • F8 SPAM > BOOT LAST KNOWN GOOD CONFIGURATION!!! worked for me, nothing else did... tried ALLLL of the above.


    F8 SPAM > BOOT LAST KNOWN GOOD CONFIGURATION!!! worked for me, nothing else did... tried ALLLL of the above.


    F8 SPAM > BOOT LAST KNOWN GOOD CONFIGURATION!!! worked for me, nothing else did... tried ALLLL of the above.


    F8 SPAM > BOOT LAST KNOWN GOOD CONFIGURATION!!! worked for me, nothing else did... tried ALLLL of the above.


    F8 SPAM > BOOT LAST KNOWN GOOD CONFIGURATION!!! worked for me, nothing else did... tried ALLLL of the above.


    Friday, July 26, 2013 5:38 AM
  • I got the same problem -
    CLASSPNP.SYS freeze startup ..also on SafeMode (on SafeMode I realized it is this file)

    Test Environment:

    ASUS Vintage / P4 3 GHz / 2 GB RAM / Sandisk 64 GB SSD SATA3 / Wireless Keboard & Mouse / * Neither wired keyboard nor wired mouse are connected! * /
    Win 7 Ultimate x86 + SP1

    * The only USB that is connected: wireless mouse/keyboard USB transceiver

    * In the BIOS the USB settings it is important to Enable" the USB Legacy Support

    Test & Results:

    1) Startup "normally" with the wireless mouse/keyboard USB transceiver *plugged* - FAILED.

    2) Startup with no USB device attached ...the BIOS notify "no keyboard!"
          but startup - OK. ...I plugged the USB transceiver only after startup.

    3) Startup with the wireless mouse/keyboard USB transceiver *plugged*;
          BUT with DEL & F10 (*stay for few seconds in the BIOS setup ..& continue) - OK.

    • Proposed as answer by ThatRegularGuy117 Monday, August 19, 2013 7:12 PM
    • Unproposed as answer by ThatRegularGuy117 Monday, August 19, 2013 7:13 PM
    • Edited by e zi Tuesday, August 20, 2013 8:24 PM
    Saturday, August 10, 2013 7:14 PM
  • I have recently taken out my two 1 GB RAM modules in my Dell Laptop running Windows 7 Home Premium, and replaced them with two 2 GB modules (therefore giving me 2 GB extra RAM). It worked fine for a while, but then I ran into something similar to what you did. It would never boot all the way, so I tried booting in safe mode, and I found out that it would stop at classnp.sys. I tried taking one of the modules out and leaving the other one in, and that didn't work, so i tried removing the other and replacing the one I took out, and sure enough, Windows booted. I would try removing one piece of hardware at a time to narrow down where the problem is



    • Proposed as answer by SeanyMcSean Friday, May 1, 2015 12:24 PM
    Monday, August 19, 2013 7:22 PM
  • OK, My 2 cents.  I had a Lenovo X1 computer that came with a notoriously bad Intel 320 series SSD that crapped out.  Not wanting to do everything from scratch, I took another identical (except for SSD) Lenovo and made a clone of the hard drive.  Put it in the bad Lenovo and BSOD after CLASSPNP.SYS.  I might at this point remind people that the driver listed is the last one to successfully load, so don't bother trying to troubleshoot that one.  It's the next one if you can figure out what that it.

    After reading this and thinking it might hard drive related, I went into the BIOS and checked the drive interface.  Mine had two choices, 'compatibility' and 'AHCI'.  Mine was on 'compatibility'. so I changed it to 'AHCI' and it booted like a charm.

    • Proposed as answer by Brian-D Friday, August 30, 2013 1:21 AM
    Friday, August 30, 2013 1:21 AM
  • boot to a DOS screen and do a chkdsk c: /r
    Friday, August 30, 2013 11:42 AM
  • In my case it happens after I installed a video driver.  After several reboot/safe mode tries, I ended up put in an add-in video card and it boot in to windows with the new card then I can work from there.
    Wednesday, September 11, 2013 9:25 PM
  • I found that this problem occurs when there is a hardware conflict.  Say for instance you have an older PCI-e card that was available for your XP.  You decide to install that same card in a newer computer, but maybe is it worn out or maybe a protocol or electrical standard has been slightly updated in recent times...  Classpnp.sys will cause the system to hang.  The best approach that I have found is to remove the older PCI-e card(s) one at a time and perform the task that Thomas77 has suggested.  If it continues to hand when the last card that is left is your graphics card, you might consider buying a new one.

    • Proposed as answer by Justin Loop Saturday, September 14, 2013 2:39 PM
    Saturday, September 14, 2013 2:38 PM
  • Out of all other attempts to repair and fix, this one did the trick!  Thanks a bunch!
    Sunday, October 13, 2013 3:59 AM
  • The version mentioned by Thomas77 worked except I had C: and a boot drive on X:  When I renamed c:\windows\system32\drivers\classpnp.sys classpnp.old the system crashed. I renamed it back and renamed x:\windows\system32\drivers\classpnp.sys classpnp.old and it worked.

    Thanks Thomas77

    Sunday, October 20, 2013 2:40 PM
  • Spent half a day on this. Heres my fix:

    Unplugged all hard drives except the one with windows installation (in my case C: drive)

    Windows booted as normal.

    Not sure yet but I think one of the drives died.

    Seems most if not all problems here are related to hardware conflicts.

    Monday, December 30, 2013 9:51 AM
  • @Thomas_77

    Be careful here, I was unable to boot at all after trying this. Had to rename it back.

    I would recommend to instead type "sfc /scannow" which will look for damaged/corrupt system files and fix them.

    • Edited by khaaroon Wednesday, January 8, 2014 3:23 PM
    Wednesday, January 8, 2014 3:22 PM
  • Holy crep I got mine working again!

    I initially had the same problem as most of you, pc going into black screen after 'windows starting' screen and hanging at the classpnp.sys when trying to boot in safe mode.

    So what was my problem? I unhooked my second hdd (which was initially an external one) from the (i'm not sure how the cable is called but I believe ATA or SATA) and then boom.. rebooted and got in windows as usual in seconds.

    That hdd was already in there for a long time so still not sure what caused this problem, but it's fixed.

    Browsing through this thread it doesnt seem to have one specific reason, but i hope my comment helps someone out there!

    Friday, January 10, 2014 8:00 PM
  • Dear Diegolcv,

    God bless you.  You solved my problem !

    Thanks a lot !!!!

    Friday, February 21, 2014 7:58 PM
  • I came across this issue for the first time today. I checked this forum but did not find the solution. Here is what worked.

    After trying to boot to windows 7 in regular mode, the os would not load. then I tried safe mode and it loaded but when it reached classpnp.sys it seemed to take forever, after about 20 mins, it finally loaded, and I cleared some software out. then I rebooted, and it kept doing the hanging. finally I pressed f8 to get to advanced boot options and loaded debug mode. I downloaded the file from a third party and saved it onto a thumb drive. i then opened sys32 folder and pasted the new file. i opted to replace, then rebooted. worked like a charm. i hope this helps. sorry for the punctuation, i'm pretty tired.

    Sunday, March 9, 2014 7:07 AM
  • I was getting the same error.  Have a HP laptop.  Ran the hard drive test from the bios.  Hard drive test failed.  Bad hard drive
    Friday, March 14, 2014 2:53 PM
  • Hello,

    It seems that the solution is to replace Classpnp.sys by a good one

    but I cannot do anything in the drivers folder even after tryng to change the permissions ?

    Any idea ?

    Thank you.

    Thursday, May 15, 2014 11:32 PM
  • Why do people post solutions without bothering to read what the problem is? I'm sure this is well meant, but how can you do anything in Device Manager if you are stuck in a boot loop?
    Thursday, July 3, 2014 7:18 AM
  • I took the HDD out of my PC plugged it into a HDD USB Dock on a known good Windows 7 Pro 64bit installation. After taking ownership of the bad CLASSPNP.SYS file I renamed it CLASSPNP.OLD then copied the CLASSPNP.SYS from the good PC to the bad PC. Popped the HDD back in the bad PC and it booted up fine :)  

    • Edited by Ken_PMH Monday, July 28, 2014 3:34 PM
    Monday, July 28, 2014 3:34 PM
  • Thank you SO MUCH!

    I had a computer that I had upgraded from 2GB of RAM (2x1GB) to 4GB (2x2GB), and after a while, it wouldn't start Windows. It booted any distro of Linux in any way, shape, or form, (concerning the ports and drives it has), but it refused to boot Windows. One day, I decided to boot Windows into Safe Mode, and I saw that it had stopped at classpnp.sys, so that's how I got here.

    I removed one of the 2GB sticks of RAM, and sure enough, it works!

    Thanks again!

    Wednesday, July 30, 2014 5:00 AM
  • I also have Windows 7 and my Safe mode loading screen was stuck att classpnp.sys.

    SOLUTION: Just wait some extra time. For me it was like 5-10 minutes.

    Wednesday, July 30, 2014 6:12 PM
  • This is an old issue but since  I resolved it for an older system (Thinkpad T60 Windows 7) these notes might be helpful and clarify why there seems to be so many possible solutions.

    In my case it was related to an ATI driver issue - because some advanced drivers (usually part of ATI CC Catalyst complex driver install and features) play havoc with RAM allocation (especially with laptops using one of the special ATI chipsets).  The laptop would *sometimes* boot but most often NOT (after swapping ram chips, or signing in to a different user after a successful (rarely) boot in safe mode etc.

    Solution was ** when I was lucky being able to boot**, to completely uninstall the ATI CC Catalyst crap (you may need the special ATI uninstaller). This left the 2007 basic ATI driver, which works great.

    Note: before the boot problem, I had another issue, the laptop would always start with LCD in low light mode...

    • Edited by XCLN Monday, January 12, 2015 1:16 AM typo
    • Proposed as answer by XCLN1 Tuesday, August 25, 2015 6:20 PM
    Monday, January 12, 2015 1:15 AM
  • Thank, You save me!
    Saturday, February 7, 2015 6:10 PM
  • Hey All, I don't know if there has been a fix to this problem yet but I ran into it tonight. My computer wouldn't start and showed a black screen. When I tried to boot through safe mode it would hang on the classic classpnp.sys. I tried all the options online such as changing the file name to classpnp.old, running chkdsk, repairing through the windows repair option, etc,etc. What worked for me was go to the screen where you get to safe mode (so rapidly tap f8 on startup). Then navigate down a few option to "Last known good configuration". I hit this and it worked. 

    This is for microsoft sake but right before I got the classpnp.sys problem I performed error checking on my c drive. Right click drive>properties>tools>and under error-checking>check now... I selected both automatically fix file system errors and scan for and attempt recovery of bad sectors. When I hit start it said you cannot perform this blah blah because the drive is in use, would you like to perform this on your next reboot? This is what I believe caused my error.


    Thursday, February 12, 2015 6:59 AM
  • Internet Explorer 11. Do not install it.

    Suggestions for Windows 7 or later

    Friday, March 20, 2015 2:51 AM
  • I have recently taken out my two 1 GB RAM modules in my Dell Laptop running Windows 7 Home Premium, and replaced them with two 2 GB modules (therefore giving me 2 GB extra RAM). It worked fine for a while, but then I ran into something similar to what you did. It would never boot all the way, so I tried booting in safe mode, and I found out that it would stop at classnp.sys. I tried taking one of the modules out and leaving the other one in, and that didn't work, so i tried removing the other and replacing the one I took out, and sure enough, Windows booted. I would try removing one piece of hardware at a time to narrow down where the problem is



    I only had one 4GB stick of RAM in my laptop but switching it to the other empty slot resolved my issues with this.
    Friday, May 1, 2015 12:25 PM
  • Did not work in my case. Same issue Thanks
    Sunday, June 28, 2015 8:42 PM
  • Hello,

    In my case, I was using my laptop and suddendly it froze, so i did a hard shutdown pressing power button for 5 seconds, the next time it will show me 2 options to start normally  and to repair the SO.  Normal boot ends in blue screen, the repair mode got stuck in finding problems to repair (i let it run for 20 hours) and never ended.  F8 options all ended in blue screen. Then we took out the disk and connected it to a PC, the SO recognized it but the file system shows on windows 7 as RAW, and the data was inaccesible and telling us to format de disk, wich we didn't.  At last we use a software called "HDD Regenerator v1.7", ran a scan to the disk finding  187 bad sectors which the software repaired.  Restarted de PC and voila the PC recognized the disk and could backup the data.  Later we installed the disk on the laptop and SO started flawlessly.

    Diagnostic:  disk had bad sectors, so check them before anything.

    Thursday, July 9, 2015 5:20 PM
  • Had the same problem... my system was locked in endless safe mode loop and reboot.

    Best to get Windows back to Normal mode so you can trouble-shoot the Safemode issues without reloading windows or lossing data or have to reload programs after starting over. Use the options below to save all kinds of trouble. If you then find the solution to the Safe Mode issue, get back to me here.

    Follow the below steps to reboot Windows 7 in Normal mode:

    NOTE: This was not my suggestion. Another user came up with this but I lost the link to his note.

    To Start Windows 7 back in Normal Mode

    A) From step 2, look for the identifier (ex: {current}) for the OS description (ex: Windows 7) under a Windows Boot Loader section that has the safeboot value in it. 

    B) In the command prompt, type the command below and press enter.

    NOTE: Substitute identifier in the command below with the actual value or long GUID number to the right of identifer in the command used from step 2.

    bcdedit /deletevalue {identifier} safeboot

    For example: If I wanted to have Windows 7 not boot into Safe Mode anymore, I would type this command below 
    and press Enter.

    bcdedit /deletevalue {current} safeboot

    Sunday, September 27, 2015 3:19 PM
  • just enter BIOS and change sata drive mode to IDE. it's worked after 10 hours of fails.
    Saturday, December 12, 2015 6:31 PM
  • This Guy is a Genius even after 3 years he is still helping our fellow geeks. Well done son....I had tried everything in the forums and was about to send it to the computer shop hence they would have never have guessed to do that and cost me a fortune ......Yahoo!!! my friend Thank you 
    Friday, August 26, 2016 7:25 AM
  • Hi, I just wanted to reiterate another posters answer... Just leave the computer alone at the classpnp.sys message for as long as you can. It took 1.5 hrs for my system to finally come back to life. I assume it was doing a disk repair as the hard disk was busy the whole time.

    Thursday, September 14, 2017 2:24 AM
  • If your computer can not boot Windows and it's critical components are tested OK (HDD, RAM, CPU), this is usually problem with unsupported driver. Try to load "last known good configuration" or "safe mode", disable all suspected drivers and reboot, then try to enable it one by one. This way you should find what caused problem. There is complete solution on this site:

    Saturday, October 28, 2017 9:56 PM
  • For those that tried everything on this page without success.


    Problem isn't "Classpnp.sys" the next boot file is "AGP440.sys" that's your issue.

    [THE FIX]

    I suggest you make a BACKUP of the original before starting (see bottom of my post for backup instructions)

    First, you will need to access "system repair", press F8 on boot, it's usually the first option at the the top. If you can't find it, you can use a Windows 7 repair CD. (Instructions are in a previous reply if you don't have one)

    Second, you will need to access command prompt, if you used the CD and it booted into Windows Start-Up Recovery QUIT that. You'll be stuck on that forever. It should now bring you to the option to get the command screen.

    Now, Once command is started up you'll be located in, X:\Windows\System32\

    Type, cd Drivers

    Now type, copy AGP440.sys C:\Windows\System32\Drivers\
    (If your Windows directory is located in a different directory change the C for your drive)

    Press X, and Reboot.


    When in command prompt type, copy C:\Windows\System32\Drivers\AGP440.sys C:\Windows\System32\Drivers\AGP440.bak

    Just use the "rename" command to change the AGP440.bak to .sys if you encounter issues.

    Wednesday, February 28, 2018 4:21 AM
  • After a power failure, my computer restarted when I was loading Windows. In the safe mode, it restarted after the classpnp.sys line. I switched to the IDE mode of the disk in the Bios of my computer and the computer loaded normally.
    Tuesday, March 13, 2018 5:45 PM
  • For me the problem was a drive failure in a RAID array. Hope this helps someone. 


    • Proposed as answer by ZENATIM Thursday, June 14, 2018 7:35 AM
    Wednesday, May 23, 2018 9:43 PM
  • When I tried alt+f10 all it did was bring me to a black screen that said Missing operating system
    Wednesday, July 25, 2018 10:16 PM
  • My solution after attempting all options listed, was enabling CSM in the bios.

    Annoyingly simple solution to fix my issue.

    The bios had been set to default and disabled this option stopping Windows 7 booting or reinstalling.

    I had the freeze constantly at classpnp.sys when attempting to access cmd prompt and a freeze at Windows 7 logo when performing a normal boot.

    Hope this helps someone.

    The Compatibility Support Module (CSM) is a component of the UEFI firmware that provides legacy BIOS compatibility by emulating a BIOS environment, allowing legacy operating systems and some option ROMs that do not support UEFI to still be used

    • Edited by PCGEEKAU Thursday, August 23, 2018 9:52 PM
    Thursday, August 23, 2018 9:50 PM
  • I was able to load windows by disconnecting the SATA cable from my Blue Ray drive.

    I powered on my PC to find it just hanging on the Windows logo during boot.  Attempting to go into safe mode it would get stuck at classpnp.sys. 

    After reading some posts, I learned the system is actually getting stuck on cdrom.sys (the next driver after classpnp.sys).  This lead me to disconnecting my optical drive and being able to load windows.

    If I could ask Microsoft's development members a favor, its to change the safe mode boot screen to include the name of the driver its attempting to load next (Kinda like Tetris would show you the next block).  Would have made troubleshooting a little easier.

    Also interesting that the problem related to cdrom.sys would prevent safe mode and system recovery from executing.  I can't imagine that a subsystem couldn't exist to detect certain failures and move on?

    At this time I can't say if the failure is hardware or software, but I'm glad I was able to boot and backup files :)

    Hope this helps others.

    Wednesday, August 29, 2018 4:28 PM
  • I had a similar problem with windows 7. The system has been running normally for months (probably even for years before I came along). Today it hung. Upon reboot it was stuck in a boot loop, it would try to start and then reboot. Trying to get into safe mode it would hang on classpnp.sys then after a long while it would reboot again. Upon reading this thread I checked the DVD drive. The light was on and it would not eject. I powered down ,rebooted and ejected the disk as soon as the power supply was switched on. There was a damaged disk in the drive (the silver layer was flaking off). Once I took the disk out it booted up fine. I remember this kind of thing happening back in the old days where a hung or defective device would take down the whole system. (The original IDE interface was just an extension of the AT bus, and often times two devices were connected in parallel so one hung or defective device could take down the entire buss) I guess better designs (such as the star configuration of SATA and PCIE) and better error handling has mostly but not COMPLETELY eliminated those old issues. I guess the old troubleshooting technique is still a good one to fall back on. Disconnect everything and try booting. 

    I agree, its a serious flaw in the drivers that a bad device is not detected and disabled during boot. (or in my case, an otherwise operational device that itself has a firmware flaw where it cant gracefully detect and handle severely damaged media.) Both in the firmware and the driver there needs to be a bit of sanity applied to the detection process. If it takes MINUTES to respond or detect, something is very wrong and it should simply be disabled. I guess it WAS eventually detected and a timeout occurred. But it was not handled well. It should not have been a critical failure, but instead thrown an error message and then continued. 

    Friday, September 14, 2018 8:35 PM