none
How to permanently disable add-on allowing prompting? RRS feed

  • Question

  • IE9 always ask me whether run  add-on or not when I visit a site, how to disable the prompting?  Or how to tell IE9 that I want to disallow the add-on and don't ask me any more.
    Sunday, September 18, 2011 2:21 AM

Answers

All replies

  • Sunday, September 18, 2011 6:54 AM
  • It doesn't help with the "don't ask me any more" part of the questioner's question, unless I'm missing something.

     

    This is a serious interface design/user experience flaw and Microsoft should know better... your first-year interface design student knows better.   You do -NOT- repeatedly ask a user the same question over and over that they've either answered or dismissed, and especially in such an invasive way as a pop-over.  Shove the screen down and do something like "The yellow information bar at the top of the page" as done in times past.

    Wednesday, September 28, 2011 2:38 PM
  • Try the advice given here:  http://answers.groovypost.com/questions/438/speed-up-browsing-by-disabling-add-ons-go-away

       

    Unfortunately, Alex's answer is correct, but useless. You don't remove useful functionality (by disabling add-ons) just because IE9 thinks it is loading too slow.

    So, if you want your add-ons and do not want the stupid warning, here's the way: 1. Start Group Policy Editor (click Start and in the search/run box type gpedit.msc and hit return); 2. In the Policy Management Window that appears, navigate down to:Computer Configuration > Administrative Templates > Windows Components > Internet Explorerand locate Disable add-on performance notifications - double-click on it to open it 3. Select Enabled and click OK (check visually that it now says Enabled) 4. Close Group Policy Editor and restart IE9

    NOTE: I'm not sure whether the modified policy kicks in immediately or upon login (this Alex can answer much better than myself). Worse comes to worst, you'll need to re-login to activate it...

     

    Another user suggests that you disable an add-on in the manage add-ons utility, and that when you do, it will prompt you to choose to extend the time IE considers to be too long, thus prompting the annoying pop-over.

     

    Back to my tirade... both of these should be -in your face- -top of page- -first choice/option- in both the manage add-ons dialog and in the pop-over itself!    This romper-room level of interface design from one of the most notable software designers in the world is just silly.

    • Proposed as answer by Thistledowne Wednesday, September 28, 2011 3:14 PM
    Wednesday, September 28, 2011 3:14 PM
  • Is there another way to do this gpedit.msc does not seem to exist on my computer?

     

    Monday, January 23, 2012 6:33 AM
  • Useful info here: http://www.askvg.com/how-to-disable-speed-up-browsing-by-disabling-add-ons-popup-notification-message-in-internet-explorer/

    via registry:
    for 32-bit

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ext]
    "DisableAddonLoadTimePerformanceNotifications"=dword:00000001

    for 64-bit

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Policies\Ext]
    "DisableAddonLoadTimePerformanceNotifications"=dword:00000001

    Wednesday, August 15, 2012 8:21 AM
  • Here is some more info I posted else where...

    In it I mention how to disable the "add-on" warning for speeding up IE and for newly installed things like Java etc for all users... I hope it helps....It contains fix given by PiotrII in addition to the other one for new add-ons...

    The Reg setting fix is:

    ***** For x86 ******

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ext]
    "IgnoreFrameApprovalCheck"=dword:00000001

    ***** For x64 you need above line and another line. Both are shown below.... ***

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ext]
    "IgnoreFrameApprovalCheck"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Policies\Ext]
    "IgnoreFrameApprovalCheck"=dword:00000001

    *******

    If one wants to also disable the notification and recommendation of disabling add-ons to speed up IE add the following setting in the "EXT" key in the registry...

    "DisableAddonLoadTimePerformanceNotifications"=dword:00000001

    So to disable Both popup notifications in an x64 system use the following...

    Create a text file with .reg extension the copy and paste all the stuff between the "*****" lines, save and run when logged in with a local administrator account.

    *****************************

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Ext]
    "DisableAddonLoadTimePerformanceNotifications"=dword:00000001
    "IgnoreFrameApprovalCheck"=dword:00000001

    [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Policies\Ext]
    "DisableAddonLoadTimePerformanceNotifications"=dword:00000001
    "IgnoreFrameApprovalCheck"=dword:00000001

    ******************************

    In GP look for the following setting under the "Wndows Components\Internet Explorer" GP path...

    "Automatically enable newly installed add-ons"

    And Enable it

    I hope this helps, and thanks to Rory PS for the spreed sheet link!!!!!

    Thanks again to all who have helped,

    Ralph

    Thursday, August 1, 2013 5:44 PM
  • In Windows 8 follow the above but click "Turn off add-on performance notifications" instead of "Disable add-on performance notifications"  which doesn't exist.
    Saturday, September 7, 2013 1:53 PM
  • In 2017 this is apparently under "Turn off add-on performance notifications" for Windows 7 as well.

    • Edited by Steev43230 Wednesday, June 14, 2017 1:36 PM
    Wednesday, June 14, 2017 1:30 PM