RDS session host access is getting removed automatically-getting error "the connection was denied because the user account is not authorised for remote login" RRS feed

  • Question

  • we have a 2016 RDS farm and we have few Session host collection in it and users are able to use the session host.

    Now when i am trying to give access to new users in the existing collection, the user is able to access the session host for certain duration after providing access. if he tries to login to the session host next day he is getting the error 

    "the connection was denied because the user account is not authorised for remote login"

    if i remove the user and add again, the access works for certain period of time and again the next day he is getting the same error. the username is in the properties of the user group collection and still facing the same error

    Please help on this issue, im not able to trace it.

    • Edited by vrtechlearner Tuesday, June 25, 2019 10:42 AM added more details
    Tuesday, June 25, 2019 10:38 AM

All replies

  • Hi,


    1. Have you got a chance to check if CAL has been issued to this user or the device he logged in?

    • In Remote Desktop Licensing Manager right-click the license server, click Create Report, and then click Per User CAL Usage.
    • Set the scope for the report - select one of the following: Entire domain - the domain in which the license server is a member. ...
    • Click Create Report.

    2. Did you try to log in again later after receive the error message, like the day after tomorrow. Still have same error?

    3. When the error occurred, please check the event logs and find if anything related has been recorded.

    Event log checking:

    TerminalServices-RemoteConnectionManager and TerminalServices-LocalSessionManager logs to view information about connections.


    Step 1: Press Windows+R to open the Run dialog, enter eventvwr (or eventvwr.msc) and hit OK.


    Step 2: Navigate to Event Viewer\ Applications and Services Logs\ Microsoft\ Windows\ TerminalServices-*



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Wednesday, June 26, 2019 5:52 AM
  • Hi Jenny,

    1. License is user based

    2.yes even next day, we are getting the same error not seeing any event logs in connection broker or the session host

    Kindly let me know how to proceed further to troubleshoot the issue

    Friday, July 19, 2019 9:54 AM