none
Help with Audiocodes Mediant 1000. Audio and call disconnect problems

    Question

  • I am having some problems with my Audiocodes Mediant 1000 MSBG.  The device is sitting between Lync FE/Mediation and my IP-PBX.  It is configured for TLS/SRTP.  There are two issues I'm seeing right now.  The first is outlined in my other thread: http://social.technet.microsoft.com/Forums/en-US/ocsucintegration/thread/60a09e5a-c887-48a7-b078-ae70f5440cf6

    In short - Exchange UM voicemail does not detect voice input most of the time.  I'm running ACsyslog server and see that the gateway is 'doing stuff' such as sending data/DTMF to my mediation server while leaving a voicemail, however none of it is making it to Exchange.  I don't see any oddities during a sip trace on the mediation server when this happens either.  I know the problem is related to the gateway because when I use a direct SIP connection (TCP) to my PBX I don't have the problem.  It's strange that it works sometimes but mostly not others.

    The second issue is if Lync is set to forward to voicemail after more than 20 seconds an external caller will get disconnected before actually making it to voicemail.  If it is at the default of 20 seconds or lower, it forwards to voicemail successfully.  The IP-PBX has a timeout of 120 seconds so that shouldn't be the issue, is there a setting on the Mediant that I should look at changing?  I've browsed through and don't see any timeout settings under 60 seconds on the gateway.

    The first problem is the most critical as it essentially halts my deployment.  Can anyone offer suggestions?
    I would be glad to post my config file as well. 



    Friday, August 26, 2011 8:13 PM

Answers

  • Got it.  Set-CsTrunkConfiguration -RTCPActiveCalls $False

    The answer was pretty clear, here's the Technet description of RTCPActiveCalls:

    If RTCPActiveCalls is set to True, the Mediation Server or Lync Server client can terminate a call if it does not receive RTCP packets for a period exceeding 30 seconds.

     

    The issue with no audio for Exchange UM went away when I changed the gateway to Lync connection to TCP instead of TLS.  I need to play around with that some more.

    • Marked as answer by tpullins Wednesday, August 31, 2011 7:22 PM
    Wednesday, August 31, 2011 6:09 PM

All replies

  • Hi tpullins,

    can you send a syslog from this error?

    Do you have configure the gateway throgh the Audiocodes described configuration guide?

    http://www.audiocodes.com/products/microsoft-gateways

    Check if you have set the parameter "disconnect on Broken connection" to no on the GW.


    regards Holger Technical Specialist UC
    Saturday, August 27, 2011 4:03 PM
  • It looks like something wrong with configuration of gateway. Can you find any error logs about the failure of voice forwarding in lync server?
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, August 29, 2011 6:23 AM
    Moderator
  • Hi tpullins,

    can you send a syslog from this error?

    Do you have configure the gateway throgh the Audiocodes described configuration guide?

    http://www.audiocodes.com/products/microsoft-gateways

    Check if you have set the parameter "disconnect on Broken connection" to no on the GW.


    regards Holger Technical Specialist UC

    I can certainly capture a syslog. Where do I send it?

    I have followed the documentation from AC to configure the gateway.

    'Disconnect on broken connection' is set to Yes. Changing to No seems to have no effect.


    Monday, August 29, 2011 5:22 PM
  • The 30 second disconnect appears to be an issue with media bypass.  If i disable media bypass it will ring as long as I'd like.  What would be causing this?  Is the Lync client itself causing the disconnect?
    Tuesday, August 30, 2011 4:51 PM
  • It could be that the configuration for the media bypass in the AC Gateway is wrong.

    The standard configuration of the lync client is after 20 sec forward to voicemail od disconnect if no voicemal is configured.

    You can also make a ocsloger trace on the mediation server with sipstack, mediationserver to see what is the problem with the connection to the gateway.

    The trace can be read with the snooper tool from the Lync reskit


    regards Holger Technical Specialist UC
    Tuesday, August 30, 2011 8:24 PM
  • What is there to even configure for media bypass on the gateway?  All I know of is whether SRTP is forced/negotiate/off.

    Yes, 20 seconds is the standard setting, which is why I wasn't even aware of this problem until a user needed it set to a higher number and noticed he wasn't getting voicemails any more.  Can anyone else test a setting of 30 seconds or more in their environment with media bypass?

    I started logging at about 28 seconds into my lync client ringing from a call from the gateway, the disconnect comes at 30 sec.  Here are 3 interesting entries from the trace(some info removed to keep thread length down):


    Start-Line: SIP/2.0 487 Request terminated
    From: <sip:6025551234;phone-context=DialPlan@company.edu;user=phone>;epid=C44B40FC43;tag=55881f83dc
    To: <sip:22254;phone-context=DialPlan@company.edu;user=phone>;tag=12BFA088F54ECF67566EF6DC5D4DFC83
    CSeq: 5579 INVITE

    Start-Line: CANCEL sip:10.254.70.56:56522;transport=tls;ms-opaque=5447c3948a;ms-received-cid=C48F00 SIP/2.0
    From: <sip:6025551234;phone-context=DialPlan@company.edu;user=phone>;epid=C44B40FC43;tag=55881f83dc
    To: <sip:22254;phone-context=DialPlan@company.edu;user=phone>;epid=1a2575fc7a
    CSeq: 5579 CANCEL
    Via: SIP/2.0/TLS 10.254.1.104:5061;branch=z9hG4bK1AA38377.259404A41CD7E06C;branched=FALSE
    Authentication-Info: TLS-DSK qop="auth", opaque="9EDDCA10", srand="3722F06B", snum="416", rspauth="64c2837d71711fae20c7a3d9d0f4e9c5b98afb07", targetname="LYNCFE01.htn.hti.bfn", realm="SIP Communications Service", version=4
    Max-Forwards: 70
    Content-Length: 0
    Server: http%3A%2F%2Fwww.microsoft.com%2FLCS%2FDefaultRouting
    Reason: SIP;cause=487;text="Request Terminated";source=client
    ms-diagnostics: 32;source="LYNCFE01.htn.hti.bfn";reason="Call terminated on mid-call media failure where both endpoints are internal";component="MediationServer"
    ms-diagnostics-public: 32;reason="Call terminated on mid-call media failure where both endpoints are internal";component="MediationServer"
    Message-Body: –
    $$end_record

    Start-Line: SIP/2.0 487 Request Terminated
    From: <sip:6025551234;phone-context=DialPlan@company.edu;user=phone>;epid=C44B40FC43;tag=55881f83dc
    To: <sip:22254;phone-context=DialPlan@company.edu;user=phone>;epid=1a2575fc7a;tag=1b8422423d
    CSeq: 5579 INVITE
    Call-ID: 5c2038cb-bbdb-418c-9c9a-6d7859cf04da
    Via: SIP/2.0/TLS 10.254.1.104:5061;branch=z9hG4bK1AA38377.259404A41CD7E06C;branched=TRUE;ms-internal-info="dvD-ar8GKlFjwiqMdbowEmTUpK0UBVxymc7TZwaekIYYykBJQlQ4H8awAA"
    Via: SIP/2.0/TLS 10.254.1.104:63847;branch=z9hG4bK553f8ff5;ms-received-port=63847;ms-received-cid=C71200
    Record-Route: <sip:lync.htn.hti.bfn:5061;transport=tls;ms-fe=LYNCFE01.htn.hti.bfn;opaque=state:F:Ci.Rc48f00:Ieh.dA1MZbgPHVi5Dx1YbhTR1h4MG4OZoGeo_lbRJVclig2PhbjfMkJJ64eTDlRyqkBJQlNdLoMwAA;lr;ms-route-sig=bhWNOo75VPeD2juKaXOCGV7NIAlHt_uC3_xyFViINUVzmkBJQlNdLoMwAA>;tag=12BFA088F54ECF67566EF6DC5D4DFC83
    User-Agent: UCCAPI/4.0.7577.314 OC/4.0.7577.314 (Microsoft Lync 2010)
    Ms-client-diagnostics: 52092;reason="The call was cancelled by the caller before the remote party answered"
    Proxy-Authorization: TLS-DSK qop="auth", realm="SIP Communications Service", opaque="9EDDCA10", targetname="LYNCFE01.htn.hti.bfn", crand="5b7ca165", cnum="213", response="8486c67f3903ebad1e49c302b255131b1f099d5a"
    Content-Length: 0
    Message-Body: –
    $$end_record

     

    The bolded parts in the 2nd entry are the most interesting to me, although I have no idea what could be causing that.

     

    Tuesday, August 30, 2011 9:18 PM
  • Got it.  Set-CsTrunkConfiguration -RTCPActiveCalls $False

    The answer was pretty clear, here's the Technet description of RTCPActiveCalls:

    If RTCPActiveCalls is set to True, the Mediation Server or Lync Server client can terminate a call if it does not receive RTCP packets for a period exceeding 30 seconds.

     

    The issue with no audio for Exchange UM went away when I changed the gateway to Lync connection to TCP instead of TLS.  I need to play around with that some more.

    • Marked as answer by tpullins Wednesday, August 31, 2011 7:22 PM
    Wednesday, August 31, 2011 6:09 PM
  • Have you configure every thing right for TLS , Certificate, Timeserver and so on
    regards Holger Technical Specialist UC
    Wednesday, August 31, 2011 8:42 PM
  • Have you configure every thing right for TLS , Certificate, Timeserver and so on
    regards Holger Technical Specialist UC
    Yeah, certificate is configured correctly as I can tell.  Installed certificate and root cert on the mediant from the same authority that Lync uses.  Timeserver is set to the correct IP, however I did just noticed that my UTC offset wasn't set, so it was showing an improper time in "Regional Settings".  I just corrected that.  Would that have any impact on intermittent 1 way audio?  What else is there to configure for TLS?
    Wednesday, August 31, 2011 8:55 PM