IE8 encodes Japanese characters in URL RRS feed

  • Question

  • I am facing an issue in saving and then opening a file which has Japanese characters in its name. The IE8 browser is converting the Japanese chracters to '%%C7%95'. There is no problem while trying to open the file for reading since the file is copied to a local temp directory on the IIS 6.0 server for reading. Where as when the same file is checked out for editing then the file is brough on to the users workstation and i.e. tries to open it in the appropriate program such as word or excel. There is no issue in this functionality with IE6. Can some one tell me how to stop IE8 from encoding the file name? Any suggestions are much appreciated.
    Thursday, December 9, 2010 7:32 PM

All replies

  • Can some one tell me how to stop IE8 from encoding the file name?

    There are some relevant setting in the Options, Advanced tab, International section.   Please list what you have checked in there.


    Robert Aldwinckle

    Saturday, December 11, 2010 10:09 PM
  • Thanks for your reply, here is what i have checked in the International section: Send IDN server names Send UTF-8 URLs Show information bar for encoded addresses We have tried with UTF-8 option (check/uncheck), this did not help. Let me know if you have any other suggestions.
    Tuesday, December 14, 2010 9:37 PM
  • Please elt me know if any one has other suggestion about resolving this problem.
    Friday, December 17, 2010 4:14 PM
  • We have tried with UTF-8 option (check/uncheck), this did not help.

    What effect did it have then?   You may have to use an HTTP trace (e.g. Fiddler2) to check.   I think that that whole International section was not in IE6?  So, that would explain why there is a difference.   FWIW I don't understand how UTF-8 can be escaped to Hex without causing ambiguities.  Also, I don't understand why those characters would be escaped anyway.  E.g. they certainly don't create ambiguities in the HTTP URI syntax.  Another thing that I would try is using ProcMon to see if there are any registry values being checked unexpectedly when your URL is being prepared for transmission.

    On another tack, what character is  0xC795  anyway?  Is it really a valid UTF-8 string?

    Otherwise can you point it out to me using CharMap please?



    Friday, December 17, 2010 11:06 PM
  • I did use HTTP Trace using Fiddler and thats when it showed me that http request for bringing the document from IIS server to local workstation is not showing the document name correctly. Let me explain the process again:

    1. Document is searched and the results are displayed
    2. User selects the document and clicks edit link to edit the document
    3. Application queries the document and downloads it to temp directory on IIS server with the help of an active-x component (till this step document looks corerct and has all the required content)
    4. Then again using the same active-x component the document is copied form the IIS temp directory to the users local workstation under c:/ drive.
    5. Now the document is opened from this location for editing. This is where the problem is, the document does not display any content but an internet explorer page not found message.
    6. By using Fiddler we found that the http request for opening the document is trying to use a encoded name.

    Our application uses Shift-JIS encoding.

    Let me know if you have any suggestions.

    Tuesday, December 21, 2010 3:09 PM
  • Guys...this issue is giving me please help me out...any suggestions to resolve this would be greatly appreciated.
    Monday, December 27, 2010 6:37 PM
  • I installed latest updates from Microsoft, but this also did not work. Any suggestions?
    Monday, January 3, 2011 7:50 PM
  • For downloading the file from the server, I am using Internet Transfer Control (ITC), here is the code that I am using: intFile = FreeFile() ' Retrieve the URL into the Byte array bArray() = mobjInet.OpenURL(strURL, icByteArray) ' Open the binary file Open strDestination For Binary Access Write As #intFile ' write the Binary file Put #intFile, , bArray() Close #intFile This works fine in IE6 but does not work in IE8 when the file name contains Japanese chracters in its name. Any suggestions?
    Tuesday, January 18, 2011 4:39 PM