locked
Browsing History Not Being Recorded RRS feed

  • Question

  • I am having a problem with my Internet Explorer 9

    Something is wrong with the browsing history. A few days ago, it suddenly stopped recording the sites I have visited and it only records the documents I have opened up through Computer

    I do not have InPrivate Browsing on, I did not check the option for Delete Browsing History on Exit, I did not click the Delete button to delete my browsing history, and I did not change any settings. All that happened was that I was browsing websites and the Browsing History function was working like normal, and then all of a sudden on Wednesday, it stops recording my websites and only records the Microsoft Word documents I have opened up that day

    I am not sure if the Temporary Internet Files Folder is full, but I have never had a problem with it in the past and the storage space is in the recommended range.

    I have not made any changes to any of the setting at all.

    I could really use some help on this because it is really bothering me

    Thanks in advance to whoever helps!

    Matt

    Saturday, October 22, 2011 3:23 AM

Answers

  • Hi,

     

    Did you check the size of Temporary internet file folder? It is usually located in C:\users\profile\appdata\local\microsoft\windows\temporary internet files

     

    If the folder is full, IE will not record history.

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Miya Yao Thursday, November 3, 2011 8:20 AM
    Monday, October 24, 2011 8:55 AM
  • Something is wrong with the browsing history. A few days ago, it suddenly stopped recording the sites I have visited and it only records the documents I have opened up through Computer


    Other users have found that their Low\History.IE5\index.dat was either corrupt or too big.  The simplest fix is to try deleting History and start over.   E.g. press Ctrl-Shift-Delete and check *only*  History.


    FYI

    Robert Aldwinckle
    ---

    • Marked as answer by Miya Yao Thursday, November 3, 2011 8:20 AM
    Monday, October 24, 2011 2:53 PM
    Answerer

All replies

  • Hi,

     

    The following factors could affect the history.

     

    1. In Internet Option, General Tab, the option for Delete browsing history on exit was selected.

    2. In Internet Option, General Tab ,You clicked Delete button to delete the Browsing History.

    3. In Internet Option, General Tab, click Settings button besides Delete button, if the Temporary Internet files folder's size is full, the history won't be recorded. Also, it only records the latest days' history.  

    4. You used the in-private browsing mode to visit the site.

     

    Your problem might be caused by the temporary internet file is full, you can check the size in IE\Tools\Internet Options\General\Browsing history\Settings, you can view the limitation of the folder.

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, October 24, 2011 2:30 AM
  • None of those are affecting my history right now. I specifically said above that none of those are applicable since they are not affecting my history.

    Any other tips on what could be wrong?

    Monday, October 24, 2011 3:15 AM
  • Hi,

     

    Did you check the size of Temporary internet file folder? It is usually located in C:\users\profile\appdata\local\microsoft\windows\temporary internet files

     

    If the folder is full, IE will not record history.

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Miya Yao Thursday, November 3, 2011 8:20 AM
    Monday, October 24, 2011 8:55 AM
  • Something is wrong with the browsing history. A few days ago, it suddenly stopped recording the sites I have visited and it only records the documents I have opened up through Computer


    Other users have found that their Low\History.IE5\index.dat was either corrupt or too big.  The simplest fix is to try deleting History and start over.   E.g. press Ctrl-Shift-Delete and check *only*  History.


    FYI

    Robert Aldwinckle
    ---

    • Marked as answer by Miya Yao Thursday, November 3, 2011 8:20 AM
    Monday, October 24, 2011 2:53 PM
    Answerer
  • How do I get to that folder? I am unable to find it. Could you please walk me through it?
    Thursday, December 22, 2011 5:00 PM
  • Try this ....

     

    Problem:

    C:\users\%username%\appdata\local\Microsoft\Windows\history is lacking the +S (system attribute)

     

    Test:

    > Desktop > File Explorer > \users\appdata\local\Microsoft > Shift+Right Click on Windows Folder > Open new command prompt > attrib History

     

    The result you get back in the command window should read something like this (Note the "S" to left):

       S    I    C:\Users\%username%\AppData\Local\Microsoft\Windows\History

     

    Fix:

    > \users\appdata\local\Microsoft > Shift+Right Click on Windows Folder > Open new command prompt > attrib +S History

     

    ... and History comes back in IE:

    > Desktop > IE to confirm.

     

    Reason:

    A Bug in Windows (or Windows 8 ... seen this issue posted quite a few times for Windows 8.

    I'm actually able to recreate the issue persistently with domain accounts and roaming profiles on a second login on any Windows 8 system. The issue is there after the local profile has been ("re")created on that system. I don't why it happens ... but it happens every time for domain account.

    • Proposed as answer by Rory Conway Wednesday, October 31, 2012 5:27 PM
    Tuesday, September 11, 2012 10:25 PM
  • Hi -

    While attempting to solve the same issue with my IE9, Win7 64 bit system, I located the following after entering the command, attrib History , in the command line.

    The admininstrator: c:\windows\syatem32\cmd.exe window displays attributes for the wrong drive, a drive other than the c: drive.

    Might that create the problem viewing Internet History?

    If so, how can I correct it?

    thanks - george

    Tuesday, October 16, 2012 5:39 AM
  • Test:

    > Desktop > File Explorer > \users\appdata\local\Microsoft > Shift+Right Click on Windows Folder > Open new command prompt > attrib History

    The result you get back in the command window should read something like this (Note the "S" to left):

       SH    I    C:\Users\%username%\AppData\Local\Microsoft\Windows\History

    Fix:

    > \users\appdata\local\Microsoft > Shift+Right Click on Windows Folder > Open new command prompt > attrib +S History

    ... and History comes back in IE:

    > Desktop > IE to confirm.

    No History in IE10

    Even if it shows that the S has been set. Set it again That will solve the problem.

    I have tryed it on 2 different non Domain machines(1 x86 and 1 x64) 


    Carsten Spangsberg

    Wednesday, July 24, 2013 10:14 PM
  • Thanks Carsten, this worked for me too!

    I had no +s attrib and no history prior but history works fine after manually adding the +s attribute. Really not sure what caused the issue though. I had recently upgraded from ie 10 to 11 though and 2cd this was a rather new userid too.

    Chuck Marofske - MCSE

    Friday, November 22, 2013 2:06 AM
  • Thanks a lot. I was going crazy how to get history to show view options on windows 8 explorer. It really worked for me.
    • Edited by blof Sunday, December 29, 2013 4:23 AM
    Sunday, December 29, 2013 4:22 AM
  • I am having same problem, no history in IE10 with Windows 8.  I tried your solution above, however when checking for the attribute, I get a message "File not found-HISTORY".  History has never worked on this computer and this is probably why.  However, I am very untechy and do not know how to create this file.  Can you or anyone reading tell me the step to add this file and where?  Thanks for any help. 
    Friday, January 10, 2014 8:50 AM
  • You are the man! Adding the missing System attribute to the History folder did the trick!

    Tks!

    Tuesday, June 23, 2015 2:07 PM
  • This worked for me thank you for posting this was really helpful

    cheers

    Wednesday, June 29, 2016 12:20 PM
  • It should definitely be under the Windows folder. Make the history folder there anyway if its still not there and then try the solution above again.

    C:\Users\Username\AppData\Local\Microsoft\Windows\History

    Wednesday, June 29, 2016 12:29 PM
  • Thank you so, so, much this worked or me when everything else did not!!!!
    Monday, January 23, 2017 8:51 PM