none
DFS doesnt replicate RRS feed

  • Question

  • Guys,

    I got 2 sites, seperated with a pfsense server. The sites can communicate, but dfs isnt replicating from site A to site B.

    I tried troubeslooting like this:

    i created the replication group as stated in several tutorials i watched/read

    about the log, it states the following:

    Cannot access the local WMI repository. 

    servers unavialable for reporting

    Tried this, but that didnt help:

    https://www.hostfav.com/blog/index.php/2017/01/27/dfs-error-cannot-access-the-local-wmi-repository/

    Think server B is causing the Problems. I removed DFS, reboted,reinstalled, but the problems still occur.

    So i created a new server in a third site and that give me also the following error:

    Cannot access the local WMI repository.  
      Registration failed for the DFS Replication service providers.  

    But i dont get it working. Anyone who can help me with this? What am i missing/doing wrong?

    Regards,

    Tuesday, April 14, 2020 2:27 PM

All replies

  • Hi,

    Thanks for posting here!

    Here are some suggestion for your reference:

    1,I would recommend you check all the DFS service are running on both your servers .

    2 ,Check if it will turn good if you disable the firefall.

    3, DFS servers do not have the permission to read AD information,for more steps you can refer to the following link:

    4,Granting the account “Debug Programs” rights:
    Go to Computer Configuration | Windows Settings | Security Settings | Local Policies | User Rights Assignment | Debug Program in the GPO, and then click Add new user or group button.
    Select your user logon name and then click the ok button.
    Run "gpupdate /force" on the target servers.

    Best Regards,

    Fan




    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, April 15, 2020 3:17 AM
  • Hi,

     

    Just want to confirm the current situations.

    If there's anything you'd like to know, don't hesitate to ask.

     

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, April 17, 2020 8:59 AM
  • Hi

    As this thread has been quiet for a while, we will propose it as ‘Answered’ as the information provided should be helpful. If you need further help, please feel free to reply this post directly so we will be notified to follow it up.

    Again thanks for your time and have a nice day!

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, April 20, 2020 8:51 AM
  • Hi,

    I am going to rebuild the lab, but i am still trying to find a best practice for the dfs part. I still find it somewhat confusing that dfs isnt able to replicate folders with sharenames and usergroips with rights to a different dfs server. I am still trying to find the best sollution for this.

    Wednesday, May 13, 2020 5:40 PM
  • Hi,

    Thanks for your reply!

    When discussing the issue on the forum, we may not be able to understand all your configuration and problems. If you still encounter the same problem when rebuild the lab, I suggest you open a ticket under the following link:

    https://support.microsoft.com/en-in/hub/4343728/support-for-business

    Best Regards,

    Fan


    Please remember to mark the replies as an answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, May 14, 2020 2:41 AM