none
Solution to disable Quicktime plugin for IE (this one works)

    General discussion

  • It is a known issue that the Quicktime plugin will hijack file associations and play content within the browser, regardless of your file associations. Simply disabling the plugin in the Internet Explorer options doesn't always seem to work. When you try to open a media file on a website upon disabling the plugin, the browser will display a red X and the media will not play. Even with your Windows file associations configured to open with the media player of your choice, the Quicktime plugin will still take precedence. Uninstalling Quicktime will resolve the issue. However, if you are like me and own an Apple device, you must have Quicktime installed to use iTunes. I've searched the web for a solution, but none of the suggested methods worked.

    Well, I have finally figured out how to remove the plugin without, as it seems so far, breaking iTunes. Here is what I did:

    Close out of Internet Explorer. Backup and then delete the registry entry below. I have provided the reg.exe commands to make it easier than going through the registry editor. NOTE: The registry values below are for 64-bit Windows. For 32-bit Windows, I'll assume that you just need to remove the Wow6432Node from the path and target "HKLM\SOFTWARE\Classes\CLSID\" instead. If that is not it, search the registry for the Quicktime CLSID ID (long string of characters and numbers in the paths below).

    reg export "HKLM\SOFTWARE\Classes\Wow6432Node\CLSID\{4063BE15-3B08-470D-A0D5-B37161CFFD69}" D:\qt_plugin\qt1.reg
    reg delete "HKLM\SOFTWARE\Classes\Wow6432Node\CLSID\{4063BE15-3B08-470D-A0D5-B37161CFFD69}" /f

    If that doesn't get it, try these as well. Just delete and test one at a time.

    reg export "HKLM\SOFTWARE\Classes\Wow6432Node\CLSID\{CB927D12-4FF7-4A9E-A169-56E4B8A75598}" D:\qt_plugin\qt2.reg
    reg delete "HKLM\SOFTWARE\Classes\Wow6432Node\CLSID\{CB927D12-4FF7-4A9E-A169-56E4B8A75598}" /f
    reg export "HKLM\SOFTWARE\Classes\Wow6432Node\CLSID\{02BF25D5-8C17-4B23-BC80-D3488ABDDC6B}" D:\qt_plugin\qt3.reg
    reg delete "HKLM\SOFTWARE\Classes\Wow6432Node\CLSID\{02BF25D5-8C17-4B23-BC80-D3488ABDDC6B}" /f
    reg export "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\3F9E7EA97A1AEE54490637032025DEF9" d:\qt_plugin\qt4.reg
    reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\3F9E7EA97A1AEE54490637032025DEF9" /f

    Startup Internet Explorer and test (a reboot shouldn't be required). For me, IE reverted back to opening media files with my default player, Windows Media Player. I assume it will have the same results for other media players. I am not sure if this solution will work for other web browsers. 

     

     

    Sunday, June 12, 2011 10:03 PM

All replies

  • hey I have the same issue but am having a hard time following your instructions...Where exactly am I opening this file up to input the commands??
    Tuesday, June 21, 2011 9:57 AM
  • Sorry, guess I should of mentioned that. Run reg.exe from a Command Prompt window. It is located under Start -> All Programs -> Accessories. You may want to right-click on the Command Prompt shortcut and select "Run as administrator" to make sure that you have elevated your account to execute administrative commands. Also note that last part of the reg export command I have in my example is a path on my computer (D:\qt_plugin). This can be changed to the destination of your choice. This is simply where the backup file will be saved.
    Tuesday, June 28, 2011 3:06 PM
  • Hi,

    Thank you some much Brandon.M to figure out how to "disable/remove" this damn plugin. Man, I looked many times on the web to resolve this annoying problem without finding a good answer. Last time, I had to reinstall IE which is also a pain in the ***. This time,  I found your trick and it worked perfectly. I never encounter a such annoying file type association hijacking before. There is an option in the QuickTime preferences to stop playing video file automaticaly which doesn't work at all. I hope some QuickTime developers will read this thread one day to fix the problem. QuickTime is surely of the program I hate the most among the video players. This file type association hijacking is just dumb.

    Disabling the add-on in IE seems to only break the playback functionality instead of reverting to the default programs set in Windows configuration (via Default Programs in the Controle Panel). This should also be fixed by the IE team, if an add-on wiling to play a certain content is disabled, IE should try to revert to the default program before displaying a red cross.

    Just a litte fix to your post: The command provided in the original post are for the 64 bits edition of Windows. For the 32 bits version, use those commands and as Brandon.M said, replace D:\qt_plugin with your custom path (usually, just change D: to C:):

    reg export "HKLM\SOFTWARE\Classes\CLSID\{4063BE15-3B08-470D-A0D5-B37161CFFD69}" D:\qt_plugin\qt1.reg
    reg delete "HKLM\SOFTWARE\Classes\CLSID\{4063BE15-3B08-470D-A0D5-B37161CFFD69}" /f

    reg export "HKLM\SOFTWARE\Classes\CLSID\{CB927D12-4FF7-4A9E-A169-56E4B8A75598}" D:\qt_plugin\qt2.reg
    reg delete "HKLM\SOFTWARE\Classes\CLSID\{CB927D12-4FF7-4A9E-A169-56E4B8A75598}" /f
    reg export "HKLM\SOFTWARE\Classes\CLSID\{02BF25D5-8C17-4B23-BC80-D3488ABDDC6B}" D:\qt_plugin\qt3.reg
    reg delete "HKLM\SOFTWARE\Classes\CLSID\{02BF25D5-8C17-4B23-BC80-D3488ABDDC6B}" /f
    reg export "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\3F9E7EA97A1AEE54490637032025DEF9" d:\qt_plugin\qt4.reg
    reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Components\3F9E7EA97A1AEE54490637032025DEF9" /f

    I suggest also two other alternative methods to execute those commands:

    1. Copy/paste the commands above in a a text file and change the file extension to: .bat. Then, right-click and choose Run as Administrator.
    2. Open a command prompt (Start Button -> Run.. -> cmd.exe) then copy/paste the commands in the console.

    Again, thank you very much to your answer.

    Keywords: QuickTime, QuickTime Plugin, QuickTime add-on, Remove, Disable, IE, IE7, IE8, IE9, Internet Explorer

     

    Tuesday, July 05, 2011 2:17 AM
  • Thanks for posting the 32-bit entries.

    Yeah, as soon as i figured out which CLSID I had to take out, I knew I had to post this on the web. I too searched many times for a solution, but none of them worked. Quick Time plugin is garbage. Apple needs to get rid of it, or at least make an optional installation.

    Tuesday, July 05, 2011 5:46 PM
  • You're a genius, thanks a lot!

    Quicktime hi-jacking the MP3 association (amongst others) is incredibly annoying. And it's even more annoying that it doesn't respect the associations you set in Windows.

    Thanks again!

    Saturday, January 21, 2012 9:02 PM
  • You are fantastic!  Thank you so much - you are a life-saver!   Just a note for others, I kept on getting "Access Denied" running the delete at the command line.  I had to go into the registry editor and manually find and delete the entry (the first one mentioned: "HKLM\SOFTWARE\Classes\Wow6432Node\CLSID\{4063BE15-3B08-470D-A0D5-B37161CFFD69}"), but it worked fine and now my machine is back to "normal."   I am DEFINITELY going to bookmark this forum!
    Tuesday, April 24, 2012 11:59 AM
  • Set up account just to post my thanks. I've spent about 1 hour Googling to find this post which works.
    Just had to delete the first registry key (as below) and restart IE.
    To delete the key, I had to run the command as administrator, so I created a shortcut to cmd.exe on my desktop and then right clicked to run as administrator. My PC is Win 7, 64 bit, Media Player 12. Many thanks.

    reg delete "HKLM\SOFTWARE\Classes\Wow6432Node\CLSID\{4063BE15-3B08-470D-A0D5-B37161CFFD69}" /f

    Saturday, May 19, 2012 12:36 PM
  • Hi. Just wanted to drop by and check the thread. Thanks for all the nice and helpful comments. I am glad the fix is working out for everyone. I spent a few days working on this one a year ago and it looks like that time is paying off for everyone else that hates the Quicktime plugin like myself. It is good that Google index these forums so that other people can find helpful solutions. If Apple doesn't fix the Quicktime controls for the qt plugin, maybe this thread will one day be the most viewed thread in all of Microsoft's forums. :D
    Thursday, May 31, 2012 7:22 PM
  • I had to jump through some hoops to reply here, but I would not stop until I could reply and... WOW  THANK YOU!!!  This did it!!!  I don't know what motivates Brandon to give up his time to help, but it sure is GOOD that he did.  Thanks again!  It's amazing how QuickTime gets away with it, AND how IE does not have a fix!!

    I really appreciate this.  I LOVE the internet! :)

    Monday, August 20, 2012 12:54 AM
  • btw, an added benefit was having WMP open with the list rather than without by default.  I like that a lot!  :)
    Monday, August 20, 2012 12:57 AM
  • XP Registry and IE-8: (regedit: run-line or command prompt)-First Export (if desired):"HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{4063BE15-3B08-470D-A0D5-B37161CFFD69}\EnableFullPage\MIME\audio/mpeg" (without double quotes) then delete this key only. IE-8 (my test case) will now prompt you with a File Download (Open, Save & Cancel) dialog box for a .mp3 URI. Associate Media Player or some other application to the file extensions (.mp3, .m3u) as desired. Lastly, Apple's QuickTime developers have left Microsoft's Registry, in essence, broken for far too long, and they obviously do not care.

    Tuesday, January 22, 2013 3:58 PM
  • Thank you, thank you for this brilliant bit of advice and, I assume, detective work. I too had been searching for a fix that worked (after I'd reluctantly installed iTunes), and did not risk installing other nasties.

    If Apple really thinks that hijacking the playing of ".mp3" files in IE is going to do them one bit of good, then the people involved in configuring this trap need to talk to someone who understands human behaviour.

    Saturday, August 10, 2013 8:45 PM