none
"Make proxy settings per-machine (rather than per user)" Group Policy setting not applied to Administrators RRS feed

  • Question

  • It seems like this policy is just not applying when I logon as an administrative user. I can still change the settings for proxy in Internet Explorer. If I logon as a nonadministrator, the check boxes and settings are greyed out.

    Can someone confirm that this policy just doesn't apply to administrators? Or, is it that all control panel restrictions from Group Policy just never apply to administrators?

    Thursday, June 7, 2012 9:06 PM

Answers

  • Hi ,

    I enabled this policy on my machine, and it worked for me. It greyed out in the IE settings when I logon as administrator.

    Please check the group policy below:

    Start>type gpedit.msc in search bar and press enter.

    Open User Configuration>Administrative templates>Windows Components>Internet Explorer, enable “Disable changing proxy settings”.

    Hope it helps.


    Tracy Cai

    TechNet Community Support

    Monday, June 11, 2012 6:12 AM
    Moderator

All replies

  • In my experience, all IE restrictions applied through GPO affect Adminsitrators.

    Are you certain the GPO in question is being applied to for administrators?  Are other settings from that GPO applied for Administrators?  If not, maybe a WMI filter or security restriction is preventing the GPO from being applied.  You can check if the policy is applied by running gpresult.exe /v from a command prompt.

    The policy you indicated is a computer policy, no?  So, it should be applied regardless of which user is logged on.


    -Tony

    Thursday, June 7, 2012 11:27 PM
  • Well, yes, that's the thing. It's a computer policy. If I logon with a user which is not in the administrators group, the settings are greyed out. If I add that user to the administrators group, then I can change the settings and also the user policies in Group Policies apply.

    This is a domain in Windows 2000 functional mode with Server 2003 R2 domain controllers and the computer I'm testing on is Windows 7.

    And I did run gpresult and do see that the policy is applied.

    GPO: Default Domain Policy
                    KeyName:     Software\Policies\Microsoft\Windows\CurrentVersion\Internet Settings\ProxySettingsPerUser
                    Value:       0, 0, 0, 0
                    State:       Enabled

    And I'm not sure if this has anything to do with it, but it's also in the gpresult /Z results.

    GPO: Default Domain Policy
                    KeyName:     Software\Policies\Microsoft\Internet Explorer\Control Panel\Proxy
                    State:       disabled

    • Edited by notRoman Thursday, June 7, 2012 11:49 PM
    Thursday, June 7, 2012 11:46 PM
  • Hmm, I don't know.  I guess we'll have to wait until a Microsoft person, or MVP responds.  Sorry.

    -Tony

    Friday, June 8, 2012 3:39 PM
  • Hi ,

    I enabled this policy on my machine, and it worked for me. It greyed out in the IE settings when I logon as administrator.

    Please check the group policy below:

    Start>type gpedit.msc in search bar and press enter.

    Open User Configuration>Administrative templates>Windows Components>Internet Explorer, enable “Disable changing proxy settings”.

    Hope it helps.


    Tracy Cai

    TechNet Community Support

    Monday, June 11, 2012 6:12 AM
    Moderator