locked
SharePoint permissions issues (running into “Sorry, you don’t have access to this page” message) RRS feed

  • Question

  • I am having issues with enabling certain features in SharePoint 2013 due to lack of permissions. I’m trying to edit a calendar and create tabs above it. I heard this can be done by selecting “Modify in SharePoint Designer (advanced)” under “Modify View”.  However, that is grayed out. A way of accessing it from what I’ve heard is to add “_layouts/15/SharePointDesignerSettings.aspx” after your site name and check all boxes and you are good. This is where I am running into the “Sorry, you don’t have access to this page” message. I have tried going into top level admin site settings and giving myself access by approving my pending requests by giving myself full control but I am still getting the same message saying I don’t have access. I have signed in with multiple accounts with administrative privileges (even my own) with no luck to activate these features or give myself access. I am also having a similar issue saving and using templates. Any idea of what I need to do to access these features that are giving me this error like SharePoint designer and creating templates?


    Wednesday, May 10, 2017 5:12 PM

Answers

  • Hi BKK2115,

    Please go to site settings->site collection administrators under Users and Permissions, check if the account in this box.

    If not, add the user account in it and check if you can enter the URLs.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by BKK2115 Wednesday, May 17, 2017 3:09 PM
    Tuesday, May 16, 2017 10:04 AM

All replies

  • Hi BKK2115,

    Since SharePoint Designer Settings is the settings in site collection level, try to use Site collection administrator account to access this page.

    As for the issue with saving list template, go to site settings->List templates/Master pages and page layout->LIBRARY tab->Library settings->permission for this library->check permission, check if the gallery have unique permission and if the user have proper permissions.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, May 11, 2017 10:56 AM
  • I have used 2 other accounts with administrative privileges before with no luck. I should note that whenever I go to site settings, there is not a template link to select. The only way I can get to making a template is to put "_layouts/savetmpl.aspx" after my site url but I still get the "Sorry, you don't have access to this page" message. Do you think I am missing something. Do you think I need purchase some kind of package for SharePoint?
    Friday, May 12, 2017 11:30 AM
  • Hi BKK2115,

    Please go to site settings->site collection administrators under Users and Permissions, check if the account in this box.

    If not, add the user account in it and check if you can enter the URLs.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by BKK2115 Wednesday, May 17, 2017 3:09 PM
    Tuesday, May 16, 2017 10:04 AM
  • Hello,

    The SharePoint designer settings can also be done on web application level, maybe you should ask the administrator if it is allowed  => http://stackoverflow.com/questions/25014500/sharepoint-designer-settings-on-site-collection-administration-not-exist-on 


    Best regards, Christopher.
    Blog | Mail
    Please remember to click "Mark As Answer" if a post solves your problem or "Vote As Helpful" if it was useful.
    Why mark as answer?

    Tuesday, May 16, 2017 11:36 AM
    Answerer
  • That was pretty much it! Thank you so much!

    ["Site Settings">"Go to top level site settings">Under the "users and permissions" text, click "Site collection administrators"> Enter your username/account in the box]

    Wednesday, May 17, 2017 3:14 PM