none
Opening files with .jnlp extension in IE 9 (Windows 7)

    Question

  • Internet Explorer 9 on Windows7 is not able to directly open and run a .jnlp file. It asks for the prompt "do you want to open or save xxx.jnlp from <host name>" every time and does not give an option to either Run the file or "remember to do this for this file extension always".

    I verified that the file extension .jnlp is associated to "javaws". if the file is saved and double clicked, it launches the application.

    Is there any setting in IE using which we could always run this MIME type instead of open/save prompt?

    Wednesday, June 15, 2011 8:38 PM

All replies

  • Is there any setting in IE using which we could always run this MIME type instead of open/save prompt?


    You can make it stop doing MIME sniffing.   (In Options, Security, Miscellaneous section.)

     

    ---

     

    Thursday, June 16, 2011 2:48 AM
  • I tried it and it didn't work. It exhibits the same behavior as before.
    Thursday, June 16, 2011 10:20 AM
  • I tried it and it didn't work. It exhibits the same behavior as before.


    Then you will have to get a fix from the server.

     

    ---

    Thursday, June 16, 2011 1:58 PM
  • What fix do you think should be done on the server?

    There is a Java Servlet that generates the JNLP contents and it has the correct content type set in the response:

    response.setContentType("application/x-java-jnlp-file");

    Thursday, June 16, 2011 3:23 PM
  • What fix do you think should be done on the server?

    There is a Java Servlet that generates the JNLP contents and it has the correct content type set in the response:

    response.setContentType("application/x-java-jnlp-file");


    But you're now using an option which ignores that information and goes by the filename extension.   So, what filename extension is being specified?   And is that how it is being saved?   Tip: use Fiddler2 and ProcMon to check on those details.

     

    ---

    Friday, June 17, 2011 12:11 AM
  • .jnlp file name extension is being specified. When you choose "save", the file is saved as "200.jnlp" and after saving it to local disk and double clicking it works fine. I want to be able to directly open the JNLP file without prompting (which works in IE7 and IE8)

    I used Developer Tools options in IE9 to see the network traffic between the IE9 on the client machine and the host I'm accessing and the MIME type is correctly being set.

    This is how it works:

    The user clicks on a link in IE

    It calls a Java servlet which returns a URL with some parameters and gives out the JNLP contents in the response.

    The JNLP is opened using "javaws" executable on the client PC.

     

    Monday, June 20, 2011 1:38 PM
  • Any fix or leads for this?

    I'm experiencing this error on Windows 7 x64 using an up-to-date IE 8 accessing a manufacturer-configured PaloAlto VPN device (so there is no option of manipulating server-side settings).

    I can save or not save the file when downloading from IE, but no option to run. When saved, the file runs without issue.

    Thursday, December 08, 2011 10:58 PM
  • Any fix or leads for this?


    Did you try using ProcMon to produce some more clues?   FWIW my guess would be that this is yet another example of security/obscurity.   E.g. files of the filetype in question may be considered "machine input" and therefore blocked from direct use.   Do you get a prompt when you run "without issue"?  ; )

     

    HTH

    Robert
    ---

    Friday, December 09, 2011 5:31 PM
  • IE8 worked OK in this respect and you could automatically open the JNLP file without prompts. So looks like a change in IE9 behaviour which cannot be obviously overridden.
    Friday, January 13, 2012 3:53 PM
  • Any solution to this issue yet or hint, other than revert to IE8?

    Thank you in advance

    Wednesday, March 07, 2012 12:46 PM
  • I may also be hitting this issue trying to run simulations from

    http://phet.colorado.edu/en/simulations/category/new

    Running IE v 9.0.8112.16421 on Windows 7 SP 1

    Would be helpful to know if there is any workaround.  Thanks!

    Monday, March 12, 2012 2:36 PM
  • trying to run simulations from

    http://phet.colorado.edu/en/simulations/category/new

    Are you sure you have the right server and domain name?   <eg>

    http://www.zdnet.com/blog/igeneration/brothel-owner-snaps-up-universitys-xxx-domain-name/13996

    ---


    Tuesday, March 13, 2012 1:46 PM
  • Oracle Java installed? java.com to download.

    JNLP (Java Network Launching Protocol) file formatted in XML; used for launching
    and managing Java programs on the Web or as standalone applications over a
    network


    Rob^_^

    Tuesday, March 13, 2012 8:41 PM
  • Try resetting your IE settings using the Fix IT tool

    http://support.microsoft.com/kb/923737

    I tried it with IE 8 and it worked.

    http://windows.microsoft.com/en-US/windows-vista/Reset-Internet-Explorer-8-settings

    Wednesday, March 21, 2012 8:22 PM
  • Easiest way around this is to add the launch URL to the Local Intranet Zone within IE's security settings.
    Thursday, May 24, 2012 11:08 AM
  • I know this is an old thread but this is what got me going:

    When the box pops up with open/save option, click open.  List of applications comes up, click the "Browse" button.

    Navigate to C:\Program Files\Java\jre\bin\

    Select javaws.exe and click ok. 

    You may also want to check the box "Always use the selected program to open this kind of file" so that it doesnt prompt you for this again in the future.

    • Proposed as answer by -paralysed- Friday, January 18, 2013 6:36 PM
    Friday, January 18, 2013 6:36 PM
  • I tinkered with this one for days- so hopefully this will help others:

    In my case, It varied if it worked per user.  At first I thought it was the profile that installed java was the one that worked, but turned out to be a GPO setting.

    If you set 'Do not save encrypted pages to disk' in a GPO or the advanced tab or IE settings, in my case a JNLP file would not launch automatically.

    Wednesday, May 22, 2013 3:07 PM
  • Kudos to you!  Adding the launch URL to the Local Intranet Zone did it for me!

    On IE 10 (Internet Options - Security - Local Intranet - Sites - Advanced)

    Thursday, October 03, 2013 3:20 PM