none
Prerequisite installer failing "please check your internet connection" (but I have internet connection) RRS feed

  • Question

  • Hello there,

    I'm trying to do a SharePoint 2016 installation on a Windows server 2012 R2 virtual Azure machine.

    The problem is that the perequisiteInstaller is failing. At first it didn't pass the IIS server role, so I did this manually. Now it stuck at installing Miscrosoft SQL Server 2012 Native Client.  Error: The tool was unable to download Microsoft SQL Server 2012 Native Client. Please check your Internet connection and try again.

    When I use the browser I have internet acces and can download stuff, so I don't understand why its saying that I do not have internet connection.

    As a workaround I downloaded and installed the Sql Server 2012 Native client manaully, which seemed to complete succesfully, but the prerequisite installer is still not passing this requirement.

    I also tried to run the prerequisite installer as administrator, but this is also not working. It keeps saying I have no internet connection.

    Does anyone have any idea of what could be causing this?

    Thanks in advance!!

    Sunday, May 22, 2016 3:38 PM

Answers

  • Here's the download for the correct SQL Native client. Are you able to browse to it? You're using the RTM version of SharePoint Server 2016, correct?

    http://go.microsoft.com/fwlink/?LinkId=622997

    And the complete list of downloads:

    Windows Management Framework 3.0 for Windows Server 2008 R2 SP1 (Windows6.1-KB2506143-x64.msu): http://go.microsoft.com/fwlink/?LinkID=233187

    Microsoft Sync Framework Runtime v1.0 SP1 (x64) (Synchronization.msi): http://go.microsoft.com/fwlink/?LinkID=224449

    Microsoft SQL Server 2012 Native Client (sqlncli.msi): http://go.microsoft.com/fwlink/?LinkId=622997

    Microsoft ODBC Driver 11 for SQL Server (msodbcsql.msi): http://go.microsoft.com/fwlink/?LinkId=517835

    Windows Server AppFabric (WindowsServerAppFabricSetup_x64.exe): http://go.microsoft.com/fwlink/?LinkId=235496

    Microsoft Identity Extensions  (MicrosoftIdentityExtensions-64.msi): http://go.microsoft.com/fwlink/?LinkID=252368

    WCF Data Services 5.6 Tools (WcfDataServices.exe): http://go.microsoft.com/fwlink/?LinkId=320724

    Cumulative Update 7 for Microsoft AppFabric 1.1 for Windows Server  (AppFabric-KB3092423-x64-ENU.exe): http://go.microsoft.com/fwlink/?LinkId=627257

    Active Directory Rights Management Services Client 2.1
     (setup_msipc_x64.exe): http://go.microsoft.com/fwlink/?LinkID=544913

    Microsoft .NET Framework 4.6 (NDP46-KB3045560-Web.exe): http://go.microsoft.com/fwlink/?LinkID=691472

    Microsoft Visual C++ 2012 Redistributable (x64) (vcredist_x64.exe): http://go.microsoft.com/fwlink/?LinkId=627156

    Microsoft Visual C++ 2015 Redistributable (x64) (vc_redist.x64.exe): http://go.microsoft.com/fwlink/?LinkId=623013



    Trevor Seward

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, May 22, 2016 7:19 PM
    Moderator

All replies

  • Here's the download for the correct SQL Native client. Are you able to browse to it? You're using the RTM version of SharePoint Server 2016, correct?

    http://go.microsoft.com/fwlink/?LinkId=622997

    And the complete list of downloads:

    Windows Management Framework 3.0 for Windows Server 2008 R2 SP1 (Windows6.1-KB2506143-x64.msu): http://go.microsoft.com/fwlink/?LinkID=233187

    Microsoft Sync Framework Runtime v1.0 SP1 (x64) (Synchronization.msi): http://go.microsoft.com/fwlink/?LinkID=224449

    Microsoft SQL Server 2012 Native Client (sqlncli.msi): http://go.microsoft.com/fwlink/?LinkId=622997

    Microsoft ODBC Driver 11 for SQL Server (msodbcsql.msi): http://go.microsoft.com/fwlink/?LinkId=517835

    Windows Server AppFabric (WindowsServerAppFabricSetup_x64.exe): http://go.microsoft.com/fwlink/?LinkId=235496

    Microsoft Identity Extensions  (MicrosoftIdentityExtensions-64.msi): http://go.microsoft.com/fwlink/?LinkID=252368

    WCF Data Services 5.6 Tools (WcfDataServices.exe): http://go.microsoft.com/fwlink/?LinkId=320724

    Cumulative Update 7 for Microsoft AppFabric 1.1 for Windows Server  (AppFabric-KB3092423-x64-ENU.exe): http://go.microsoft.com/fwlink/?LinkId=627257

    Active Directory Rights Management Services Client 2.1
     (setup_msipc_x64.exe): http://go.microsoft.com/fwlink/?LinkID=544913

    Microsoft .NET Framework 4.6 (NDP46-KB3045560-Web.exe): http://go.microsoft.com/fwlink/?LinkID=691472

    Microsoft Visual C++ 2012 Redistributable (x64) (vcredist_x64.exe): http://go.microsoft.com/fwlink/?LinkId=627156

    Microsoft Visual C++ 2015 Redistributable (x64) (vc_redist.x64.exe): http://go.microsoft.com/fwlink/?LinkId=623013



    Trevor Seward

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Sunday, May 22, 2016 7:19 PM
    Moderator
  • Hi,

    I see this question has been marked as answered but I also ran into this issue and in troubleshooting found the issue to be within the security settings of Internet Explorer blocking some of the prerequisite installer URLs.  While Trevor's answer is very thorough and works, you might want to give this a shot first as it is significantly less work.  

    1.  On the server, open IE and go to www.microsoft.com.  You should get at least 1 pop up box that say "Content from website listed below is being blocked by Internet Explorer Enhanced Security Configuration".  Uncheck the box that says "Continue to prompt when website content is blocked"

    2.  Open IE settings (gear) > Internet Options > Security tab.  Click on trusted sites. in the zones  Click sites and then type http://*.microsoft.com to the trusted websites and then click add.  

    3.  Close IE

    4.  Retry prerequisiteinstaller.exe

    These steps worked great for me.  If it helps you please give it a vote so that other people will know it is a good solution.  

    Good luck!  :)
    • Proposed as answer by Nico Martens Tuesday, January 31, 2017 12:47 PM
    Saturday, October 8, 2016 5:51 PM
  • I had the same issue even after adding Microsoft to trusted sites. I realized that I was running the prerequisiteinstaller.exe vs the splash page executable. Once I ran the prereqs from the splash page it worked fine. 
    • Proposed as answer by BomSquad Monday, November 20, 2017 6:45 PM
    Wednesday, February 8, 2017 11:38 PM
  • Pamin is correct.  I was installing SP 2016 on Windows Server 2016 and it failed to download the component.  Disabling IE ESC did the trick. 
    Wednesday, February 22, 2017 7:31 PM
  • Thanks Disabling IE ESC works with me thanks  .. just i need to add one more thing how to disable IE Security here is the Video so it will more easy to every one 

    https://www.youtube.com/watch?v=BINOvcKIr5g


    RB



    Sunday, March 26, 2017 2:07 PM
  • I had the same issue even after adding Microsoft to trusted sites but after Disabling IE it worked for me. Thanks @moffitar 
    Monday, March 27, 2017 9:19 AM
  • Doing this didn't work for me, but after disabling IE ESC prerequisites now are downloading.
    • Proposed as answer by DonMcB Thursday, April 5, 2018 4:38 PM
    Thursday, June 8, 2017 7:45 PM
  • This is probably the better answer. Thank you. 
    Monday, June 12, 2017 11:24 PM
  • This is a good solution. you don't need to download all program and install by yourself. because prerequisite will auto download and installed.

    James Liang

    Monday, July 10, 2017 9:20 PM
  • I had the same issue.  Installing from the Splash screen worked for me.  Thanks Batherton.  Likely, it was a combination of all of these steps that worked - Disabling IE Enhanced Security Configuration, adding Microsoft.com to the list of trusted sites, then running prerequisites from the splash executable instead of the prerequisiteinstaller application.
    • Edited by Abadabadooo Thursday, July 27, 2017 2:12 AM
    Thursday, July 27, 2017 2:11 AM
  • Hello there,

    I'm trying to do a SharePoint 2016 installation on a Windows server 2012 R2 virtual Azure machine.

    The problem is that the perequisiteInstaller is failing. At first it didn't pass the IIS server role, so I did this manually. Now it stuck at installing Miscrosoft SQL Server 2012 Native Client.  Error: The tool was unable to download Microsoft SQL Server 2012 Native Client. Please check your Internet connection and try again.

    When I use the browser I have internet acces and can download stuff, so I don't understand why its saying that I do not have internet connection.

    As a workaround I downloaded and installed the Sql Server 2012 Native client manaully, which seemed to complete succesfully, but the prerequisite installer is still not passing this requirement.

    I also tried to run the prerequisite installer as administrator, but this is also not working. It keeps saying I have no internet connection.

    Does anyone have any idea of what could be causing this?

    Thanks in advance!!

     just On the server, open IE and go to www.microsoft.com.  You should get at least 1 pop up box that say "Content from website listed below is being blocked by Internet Explorer Enhanced Security Configuration".  Uncheck the box that says "Continue to prompt when website content is blocked" then keep the IE open and open prerequisiteinstaller.exe . it will work without issue 
    Monday, July 31, 2017 11:40 AM
  • That did it for me!  Thank you!
    Thursday, May 31, 2018 9:18 PM
  • Many thanks for this. That did the trick for me.
    Thursday, November 15, 2018 11:27 AM
  • disable windows firewall for private and domain network.

    turn on (resume) windows update

    try on differente internet connection, in my case was my wifi route firewall blocking some connection.

    Friday, January 25, 2019 5:07 PM
  • This issue might occur in case of :

    1. The Proxy setting is not configured properly in the Internet Explorer Settings.
    2. The file download option is not enabled in the Internet Explorer settings.
    3. The IE Enhanced Security Configuration is set to On.

    Check the details at 

    Friday, March 8, 2019 3:55 AM
  • wow its simple and the correct solution thank you very much
    Tuesday, June 18, 2019 10:37 PM