none
F5 Networks Firepass and Internet Explorer 11

    Question

  • I am running Windows 7 and recently appear to have been upgraded to Internet Explorer 11.

    A Couple of days ago i was successfully using F5 Firepass (using IE 10). Today i cant use it...

    After sorting out Kaspersky - which has started to consoder the logon as needing a secure keyboard entry (never did this before...),

    I am getting warnings; (a) that Javascript is not enabled - it looks enabled to me...

    (b) I need to install the F5 Browser plugin.

    I have downloaded the plugin (NPuroamHost.dll), and the instructions are to 'unpack it into the plugins folder of your browser tree.'

    Where on earth is this?

    I found another post elsewhere with a similar problem - and the solution was to uninstall Internet Explorer 11. Amazing!

    Friday, December 06, 2013 11:24 AM

Answers

  • After reading your post and seeing that F5 was not detecting IE correctly - I simply added the F5 site to the compatibly sites in IE. Works fine now.
    Tuesday, December 10, 2013 4:11 PM

All replies

  • Hi,

    Its not supported in MSIE browsers.

    post to support.mozilla.org

    see http://support.mozilla.org/questions/919980

    and http://www.prevx.com/filenames/1270772988390356004-X1/NPUROAMHOST.DLL.html

    Prevx. Removal of Malware. Information about NPUROAMHOST.DLL. NPUROAMHOST.DLL has been seen to perform the following behavior:.


    Rob^_^

    Saturday, December 07, 2013 12:17 AM
  • Hi,

    Are you saying that F5 Firepass is not supported in IE? It has been working fine with IE up until the latest version.

    Paul


    Paul Durdin

    Saturday, December 07, 2013 9:34 AM
  • working fine with IE up until the latest version.

    Have you checked for a User-Agent string problem, e.g. using Developer Tools to override either Document mode or User-Agent string?



    Robert Aldwinckle
    ---

    Saturday, December 07, 2013 4:21 PM
    Answerer
  • Hi Robert,

    Thanks for the reply. I dont see how your suggestion works. The F5 Firepass is telling me that it needs to install a dll (NPuroamHost.dll), and is suggesting where it needs to be installed. I'm puzzled on two counts (a) what has happened between IE10 (which works fine) and IE11, and (b) where the dll needs to be installed for IE11. The instructions appear to relate to Firefox (ref the earlier post).

    I have since found a note on F5's site saying that Windows 8.1 & IE11 are not supported; so maybe i'm flogging a dead horse here!


    Paul Durdin

    Monday, December 09, 2013 8:32 AM
  • I dont see how your suggestion works. The F5 Firepass is telling me that it needs to install a dll (NPuroamHost.dll), and is suggesting where it needs to be installed.

    Are you implying that you have tried it and found it works?  <eg>

    I'm puzzled on two counts (a) what has happened between IE10 (which works fine) and IE11, and (b) where the dll needs to be installed for IE11.

    The site is misinterpreting the IE11 UAS and thinking it is a Mozilla one, e.g. Netscape or Firefox.  Those browsers add-ons are called "plug-ins".  No version of IE supports that method.  It's add-ons were/are referred to a "ActiveX extensions".



    Robert Aldwinckle
    ---

    Monday, December 09, 2013 12:45 PM
    Answerer
  • I'm having the same issue. Did you ever get it straightened out? I'm thinking about uninstalling IE11 as well.
    • Proposed as answer by bisceg1 Tuesday, December 10, 2013 3:26 PM
    • Unproposed as answer by bisceg1 Tuesday, December 10, 2013 3:26 PM
    Tuesday, December 10, 2013 2:48 PM
  • I uninstalled IE11 and F5 Networks works fine- right off the bat
    • Proposed as answer by bisceg1 Tuesday, December 10, 2013 3:27 PM
    Tuesday, December 10, 2013 3:27 PM
  • I uninstalled IE11

    Implying that the UAS that IE is now using has an MSIE pattern.  Did you try overriding the IE11 UAS accordingly?



    Robert Aldwinckle
    ---

    Tuesday, December 10, 2013 3:56 PM
    Answerer
  • After reading your post and seeing that F5 was not detecting IE correctly - I simply added the F5 site to the compatibly sites in IE. Works fine now.
    Tuesday, December 10, 2013 4:11 PM
  • It didnt try it because the message didnt make sence. as you rightly pointed out F5 seems to have misidentified IE as Firefox.


    Paul Durdin

    Tuesday, December 10, 2013 5:55 PM
  • Thanks for that suggestions - problem now fixed!


    Paul Durdin

    Tuesday, December 10, 2013 6:04 PM
  • I used aquateen.mastershake<abbr class="affil"></abbr>'s suggestion (love the name!) - add to compatability list. Works a treat.

    Paul Durdin

    Tuesday, December 10, 2013 6:06 PM
  • please can you tell me where you added and where, I couldn't find list or sites?
    Tuesday, December 10, 2013 8:59 PM
  • Tools -> Compatibility View Settings -> Add this web site:

    Paul Durdin

    Wednesday, December 11, 2013 8:00 AM
  • Possibly it is sufficient to add the VPN link to the compatibility sites and restart the Computer once. If not proceed reading...

    Following Steps helped me to make the BIG IP Edge plugin work with Internet Explorer 11:

    1. Uninstall "BIG IP Edge..." in "Add/Remove Programs" (Start > Control Panel > "Switch to classic view")
    2. Open the Internet Explorer 11 and add the Company´s VPN Site to the "Settings for the compatility view"
    3. Open the company´s VPN Site and install the plugin
    4. Restart the PC

    More Information about compatibility may be found here, on the official Page:

    Thank you Aquateen

    Sunday, December 22, 2013 2:15 PM
  • Adding to the compatibility solved my IE11 as well.  Very helpful answer.
    Friday, January 17, 2014 3:02 AM
  • We got the same problem between IE11 and F5 Firepass, and adding the site to the compatibility list has worked for us, too. Thanks to aquateen.mastershake for proposing it!
    Wednesday, January 22, 2014 11:59 AM
  • Very very helpful! same problem solved by adding F5 site to the compatibly sites in IE
    Wednesday, April 23, 2014 7:47 PM
  • First of all added the Company's site to Compatible View. It did not work. The F5 site always asked to install a plug in and after downloading the dll file manually and pasting it, it did not work.

    Then I Uninstalled the BIG IP Edge from Control Panel (Add Remove Program).

    Then opened the Company's VPN Site.

    The new settings were installed after the due acceptances.

    It worked and is working fine today.

    Thanks. By the way I did not even restart the PC.

    Very Helpful

    Tuesday, April 29, 2014 8:13 PM
  • An alternative is to run F5 in Chrome - you will need to add/remove each session as the Extension is not included in the Chrome Store.
    Friday, July 04, 2014 7:32 AM
  • An alternative is to run F5 in Chrome - you will need to add/remove each session as the Extension is not included in the Chrome Store.

    I'm glad you've been successful with Chrome, I have not.  Any guidance with this alternative would be helpful.

    TIA.


    -C.P.

    Sunday, November 09, 2014 7:06 PM
  • This is perfect...

    I added the plugin to the browser tree under program files and program files (X86) and added site to compatibity exceptions list, restarted PC, works perfectly.

    Saturday, January 24, 2015 10:16 AM
  • Perfect Man Thanks!

    Friday, January 30, 2015 11:53 PM
  • Worked like a treat! thanks man.
    Friday, May 22, 2015 5:01 PM
  • That worked! Thanks a lot.
    Wednesday, August 12, 2015 9:31 AM
  • Adding the site to the compatibility sites in IE (Tools -> Compatibility View Settings -> Add the web site) worked. Thanks a lot!
    Tuesday, September 08, 2015 1:44 PM
  • You can resolve this issue by  following steps,

    1 - Go to Internet Explore Setting

    2- Click Compatibility View Settings

    3-  Add your VPN URL or company URL 

    4- Click 'Add'

    It is working in window 7 with IE 11 of mine.

    Tuesday, January 26, 2016 6:28 AM
  • Thanks it works for me once I added the site in the compatible sites in IE 11.

    Wednesday, November 30, 2016 6:38 AM