none
Problem with opening documents from sharepoint. RRS feed

  • Question

  • Hello all.

    We have a problem with IE11.

    We has installed Win7 x64, IE11, Office professional 2010 and Skype for business.

    When we tried to open some office documents from our SharePoint intranet site, IE11 always shows prompting to open or save a file.

    SharePoint OpenDocument Class Add-On present in browser

    What to do to open the application automatically without any promts IE11?

    Thanks

    Thursday, November 26, 2015 7:28 AM

Answers

All replies

  • Have you checked/confirmed the IE zone is correct?

    e.g.

    Add your SharePoint server’s FQDN to your Trusted Sites or Intranet Sites zone.

    If you are using the Intranet Sites zone, note that you need to manually add the SharePoint server URL under Advanced settings.
    A.Internet Explorer -> Internet Options -> Security -> Local Intranet -> Sites -> Advanced
    B.Add the URL(s) of your SharePoint server(s).
    C.Click OK
    D.Click Custom Level -> Scroll to the bottom -> User Authentication
    E.Ensure that it is set to Automatic logon with current user name and password

    If using Trusted sites, ensure that you do not select “Require server verification (https:) for all sites in this zone”.
    A.Internet Explorer -> Internet Options -> Security -> Trusted Sites -> Sites
    B.Add the URL(s) of your SharePoint server(s).
    C.Click OK
    D.Click Custom Level -> Scroll to the bottom -> User Authentication
    E.Ensure that it is set to Automatic logon with current user name and password


    Don [doesn't work for MSFT, and they're probably glad about that ;]


    • Edited by DonPick Thursday, November 26, 2015 8:24 AM
    Thursday, November 26, 2015 8:22 AM
  • Hi,

    Thank you for your recommendations, but we do not receive an prompt authorization and authentication on our intranet sites, it works fine.The problem is that when you open the document on the intranet site, IE will be offered to save, open, or downloads. We need to open the document directly in the application, such as Word or Excel.

    Thanks

    Friday, November 27, 2015 1:10 AM
  • Hi,

    Unfortunately this is by design, Internet Explorer offer the option for user to "open", "save" and "save as". It is difficult to bypass the option to open the file.

    http://answers.microsoft.com/en-us/ie/forum/ie9-windows_other/how-can-i-set-ie9-to-open-download-files/c3605601-856d-4455-8144-121ef3338d2d

    Wish you have a nice day.

    Best Regards

    Simon


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, November 27, 2015 5:51 AM
    Moderator