none
Workflow Tasks: The file is not a valid XML document. RRS feed

  • Question

  • I have a custom approval workflow for individual documents in a document set. The workflow changes the approval status of a document and creates a new record in another list (audit).

    Users have Contribute access to the document library and a task list and view only in the audit list.

    When a user tries to open a workflow task directly from Outlook 2010 or Word 2010 he/she gets this error:

    ============================
    Outlook cannot open a new form.
    The form cannot be opened. To fix this problem, contact the form designer.
    Form template: https://[site address]/_layouts/formResource.aspx?templateFile=https://[site address]/Workflows/ABC%20Workflow/Approval%20_x0028_36_x0029_.xsn
    The file is not a valid XML document.
    DTD is prohibited.
    Line 2, Position 9
    ============================

    Here are some of the other observations and notes:

    • The task form is auto-generated when creating the workflow. It is not customized in any way.
    • Users can open and approve the task directly from the SharePoint site without any problems.
    • The site is in a local intranet zone.
    • When given Full permissions to the above document library and task list the problem still occurs.
    • When given Full permissions to the entire site users can open tasks from Outlook or Word. In addition if the task was opened once and then the user is removed from the Full permissions group it still works for the same task! I don't want to use this as a solution.
    • Deleting XSN templates and republishing the workflow didn't help.
    • Task Body field is plain text.
    • Please do not suggest deleting entire Web Application and recreate it.

    Any idea how to make this work?

    Thanks,

    Wednesday, July 2, 2014 5:46 PM

Answers

  • Hi LetMe, because of your testing with Outlook Vs SP, and the fact that it works when you provide full control, I would say you narrowed the problem down to Outlook. I would suggest checking your Outlook settings, especially the "trust" and intranet sites.

    cameron rautmann

    • Marked as answer by JasonGuo Sunday, July 13, 2014 5:36 PM
    Wednesday, July 2, 2014 7:54 PM

All replies

  • Hi LetMe, because of your testing with Outlook Vs SP, and the fact that it works when you provide full control, I would say you narrowed the problem down to Outlook. I would suggest checking your Outlook settings, especially the "trust" and intranet sites.

    cameron rautmann

    • Marked as answer by JasonGuo Sunday, July 13, 2014 5:36 PM
    Wednesday, July 2, 2014 7:54 PM
  • Hi Cameron - can you please be more specific what settings in Outlook (and Word) might be affecting this?

    Thanks!

    Wednesday, July 2, 2014 8:12 PM
  • I would check under "file" then "options" and look at the add ins and trust center settings.

    cameron rautmann

    Wednesday, July 2, 2014 8:20 PM
  • I have same issue, did you had a chance to fix this...

    Any help would be appreciated

    Thanks

    Tuesday, September 16, 2014 3:51 PM
  • I have the same issue, deleting the web app is not solution, any help is appreciated

    Thanks


    • Edited by sathishvijay Tuesday, September 16, 2014 3:52 PM
    Tuesday, September 16, 2014 3:52 PM
  • We had this same behavior also and figured out it was due to having our web application using the local host server name.  Once I created a new web application using a host header and moved all the content databases there the issue went away.  We thought it was due to using Office 2010 but it wasn't.

    Hope this helps someone.  It took me several days to resolve.

    Carlene S.


    Carlene S.

    • Proposed as answer by Carlene S Thursday, September 25, 2014 2:31 PM
    • Unproposed as answer by Carlene S Thursday, September 25, 2014 2:31 PM
    Thursday, September 25, 2014 2:31 PM
  • All our web applications use host headers and SSL.

    Outlook's Trust Centre has no specific settings related to sites or zones, it refers to Internet Options (from IE).

    Adding the problem sites to Trusted Sites or Intranet Zone does not resolve the issue. Neither does providing Site Collection Admin credentials when prompted from the "Open this Task" ribbon button.

    For whatever reason, only task emails from our production farm are affected. The reusable workflows were moved from dev to production via a web backup.

    I've extracted the contents of the XSN and reviewed every file. I can find nothing wrong with the XML and no mention of a DTD anywhere.

    If at first you don't succeed, ask an MVP.

    Friday, December 12, 2014 12:41 AM
  • After several more hours of debugging and comparing farm settings I narrowed it down to the Request Management service which had been enabled on our production farm.

    I have no idea why RM would refusing this type of request (especially considering no application level rules had been created) but disabling it has resolved the issue.

    Hope this helps someone else.


    If at first you don't succeed, ask an MVP.

    • Proposed as answer by Nadhiya Monday, September 26, 2016 5:11 AM
    Friday, December 12, 2014 2:44 AM
  • Hey, looks like I'm a bit late to the party, but did you ever solve this? I am getting the exact same issue. It turns out that when this happens, instead of giving you the XML, it throws an error page, which you can see if you plug the URL from the error into a browser. Word or Outlook happily grabs this HTML, believing it to be the XML it requested. However, as <! is a comment in HTML, but a DTD in XML, it says the XML is invalid. This is as far as I was able to get. Were you ever able to come up with a solution to this problem?
    Thursday, August 6, 2015 5:36 PM
  • Hi Edward,

    Please read my post just before yours. This worked for us.

    If it works for you, please consider proposing this as an answer.

    Thank you.


    If at first you don't succeed, ask an MVP.

    Thursday, August 6, 2015 11:51 PM
  • My solution was to grant the end users permissions to the Workflow list itself. 

    In SPD, go to All Files --> Workflows and right-click on the Workflow in question, selecting Properties. In the Properties activity, select Permissions for this List. Grant the user(s) permissions.

    Thursday, January 19, 2017 8:14 PM