locked
Opening document from Search results - This action couldn't be performed because Office doesn't recognize the command it was given. RRS feed

  • Question

  • Hi I am trying to open an Office document by clicking on the search results document title, however an error box pops up saying:

    This action couldn't be performed because Office doesn't recognize the command it was given.

    This is really strange, as from another computer it is OK and opens normally! I am running Office 2013, and the url of the link is below: 

    http://intranet/sales/_layouts/15/WopiFrame.aspx?sourcedoc=/sales/Shared/Documents/Proposals/test.docx&action=default&DefaultItemOpen=1

    Any ideas what I can check to troubleshoot this please?

    Wednesday, January 30, 2013 7:23 AM

All replies

  • Just to update, on the same machine, doing the same thing in Chrome opens the document fine without any issues - but in IE its not OK.

    A different machine IE is OK, on another machine again IE is not OK!

    Screenshot below:

    • Edited by g18c Wednesday, January 30, 2013 9:28 AM
    Wednesday, January 30, 2013 7:39 AM
  • A further update - if I right click the document on the search page, and click open in new tab, the file opens OK and can be viewed with WAC as expected.

    It is only when left clicking the file, when I get the above error 'This action couldn't be performed because Office doesn't recognize the command it was given'

    Appreciate any assistance to fault find this further.


    • Edited by g18c Thursday, January 31, 2013 3:40 PM
    Thursday, January 31, 2013 3:40 PM
  • This only happens in Office 2013 - in Office 2010 there is no problem.

    Can anyone from Microsoft comment on this issue please?

    I don't want to use one of our support tickets for something that seems like a bug!!

    Saturday, February 2, 2013 9:11 AM
  • Did you ever find an answer?  We're seeing the same thing with Office2013 and an Infopath Forms Library...
    Thursday, March 21, 2013 3:30 PM
  • We have the same problem, did anyone find a solution?
    Sunday, May 19, 2013 2:37 PM
  • Hi g18c,

    I have exactly the same problem. I'm also running office 2013. However I have traced our particular problem to the fact that I am using IE10.

    if I use the f12 tool pane and change the document standard to IE9 it all works fine. (This isn't the only error I have experienced with IE10 and SP2013).

    As a result we're not going to move from IE9 on our standard desktop until something significantly improves!

    Regards,

    Paul.

    Tuesday, July 16, 2013 10:24 AM
  • Hi g18c,

    Have you or anyone else found a solution to this issue?  I am seeing the same issue.  I do have Office Web Apps installed a configured but I have this library setup to open the documents in the client.

    If I right click and open in new tab/window it opens in the web browser.

    If I change the Document Mode to IE9 it opens in the browser also.\

    EDIT: This only occurs when attempting to open a document directly from a search result.

    Thanks for any information!


    • Edited by igibason Tuesday, August 20, 2013 8:11 PM
    Tuesday, August 20, 2013 7:46 PM
  • Does this happen if you navigate to the document library directly and click the links?
    Tuesday, August 20, 2013 8:05 PM
  • Hi Turismon,

    Thanks for the quick reply.  Sorry, I forgot to mention this only happens when clicking on a document from a search result.  Opening documents by navigating the document library directly works fine.

    Thanks again...

    Tuesday, August 20, 2013 8:10 PM
  • Is your document preview working and what happens on the broken browser if you use the edit link in the preview window vs. clicking the link?
    Tuesday, August 20, 2013 8:19 PM
  • Yes, my document preview is working.  While on the broken browser (IE 10) if I click on the Edit link in the preview window the document does open.  However, it opens in the web browser.  I do have the library settings set to open in the client but I think it may be because I am not open the document in the actual library?

    I am also finding Chrome is working with no problem.

    EDIT: I am also running build version 15.0.4420.1017.  I realize I do need to upgrade to the latest CU.  Is this a known issue in my current build and will the latest CU fix?

    Thanks again...


    • Edited by igibason Tuesday, August 20, 2013 8:52 PM
    Tuesday, August 20, 2013 8:36 PM
  • Hi,

    make sure the protected mode of your browser is off. If it does not help then try repairing your office installation.

    I hope this will help you out.


    Thanks, Rahul Rashu

    Wednesday, August 21, 2013 12:35 AM
  • Hi Rahul,

    Thanks for your input.   I have repaired my Office 2013 installation, rebooted, and I am seeing the same behavior.  Next I checked and noticed I did have Protected Mode off in my IE 10 browser.  I enabled closed and opened my browser and still the same behavior.  I then turned it back off and nothing changed.

    Thanks...

    Wednesday, August 21, 2013 1:50 PM
  • Do you have your domain added to compatibility mode? I have mine via group policy so maybe that's why this can't reproduced. If you go into IE right click your top area and add your file menu back, then click tools compatibility mode settings and add your intranet there does it work? I guess if you have the compatibility mode button that would work too but does that have any affect?

    Wednesday, August 21, 2013 2:57 PM
  • Hi Turismon,

    Thanks again for the input.  I did not have our domain added to the compatibility mode but when I added it, it did not make a difference.  If I run in compatibility mode or not I still see the same behavior.

    You said you cant reproduce this?  What version of SharePoint are you running, I am on 15.0.4420.1017 (I know I need to update) and am starting to wondering if its a bug in the RTM.

    Thanks...

    Wednesday, August 21, 2013 3:38 PM
  • I am running Latest before this one that just came out CU, June I think.
    Wednesday, August 21, 2013 3:40 PM
  • One other thing, if you paste the URL from the link on the page directly into the browser URL it will do the same thing right?


    Wednesday, August 21, 2013 3:48 PM
  • If I do a search for a document and right click, Copy Shortcut, and paste into a new tab the document opens in the browser.  If I simply left click the document from search I get the error.

    I do have the document library settings set to "<label for="ctl00_PlaceHolderMain_OpenDocumentSection_ctl01_RadDefaultItemOpenPreferClient">Open in the client application".</label>

    It appears opening documents from a search opens the document in Office Web Apps by default?  When I copy and compare the shortcuts from the search and the document library I can see the ../WopiFrame.aspx... line in the URL.

    Could this be an Office Web Apps error?

    Thanks...

    Wednesday, August 21, 2013 4:32 PM
  • I don't think it's office web apps error, it has to be something with how IE is translating the link to open in the client vs. browser for some reason. I'm trying to figure out how to reproduce the issue on my end and I could maybe figure something out, but at this point not really sure :).
    Wednesday, August 21, 2013 8:06 PM
  • Hi,

    I encounter the same problem with some users who have recently switch to Office 2013. 

    Have you find an answer to this behaviour please?

    Best regards

    Monday, September 16, 2013 1:49 PM
  • This just sucks big time... Microsoft please go fix it.

    Same issue here, and the sad thing is that firefox and chrome handels this just fine!

    Tuesday, September 17, 2013 12:13 PM
  • Hello,

    i believe it is because of the browser passing on the instructions to the office installed on the client machine

    When i looked at the anchor tag of the result rendered, it has an attribute openapp="powerpoint" and the href it has is not the direct reference to document but instead being passed as query string parameters. The office app is not able to recognize the url and is yelling at the user.

    If I remove the attribute, everything worked fine.

    Regards,

    Pavan

    Tuesday, October 29, 2013 1:21 PM
  • hello all, I am experiencing this same issue, but none of the suggestions here have helped.  I'm on IE9 and have Office 2013.  The version of SP I am using just got updated from 2010 to 2013 a few weeks ago.

    thanks!

    Tuesday, February 4, 2014 4:00 PM
  • Hello g18c...!

    Please download and install the hotfix available from Microsoft's support website (kb article 2849962)

    I believe that this must solve your problem.

    Please rate this post if you find it helpful !


    • Proposed as answer by Ank8 Upadhyaya Wednesday, May 7, 2014 2:00 PM
    • Edited by Ank8 Upadhyaya Wednesday, May 7, 2014 2:03 PM Grammatical editing
    Wednesday, May 7, 2014 2:00 PM
  • Hi

    The problem could be due to missing updates of your .NET on the SharePoint servers. There is some sort of browser detection build in the solution. 

    Pls. report back if that has solved your problem.

    Kind regards

    Asger

    Tuesday, April 28, 2015 11:54 AM
  • I had the same issue at a client. 

    We ended up solving the problem by going to the display templates of the search results, and commenting out the following line in the HTML file. 

    ctx.CurrentItem.csr_OpenApp = "word";

    Make sure to publish a major version of the template file before testing. 

    Monday, September 7, 2015 2:23 PM
  • Hello g18c...!

    Please download and install the hotfix available from Microsoft's support website (kb article 2849962)

    I believe that this must solve your problem.

    Please rate this post if you find it helpful !


    We're having the same issue as this thread. Has anyone tried the fix provided by Ank8 and has this helped? 

    Wednesday, December 6, 2017 9:49 AM
  • Thanks "Thijs Deschepper". Editing "Item_Word.html" under the Masterpage/Display templates gallery fixed my issue where users (including myself) were receiving "You'll need a new app to open this word". The openapp attribute was set to "word" when it should have been set to "ms-word".

    Wednesday, February 7, 2018 11:47 PM
  • This is due to the fact an attribute is added to the link openApp="word"

    I fixed it by commenting the following lines in item_commentitem_body.html file under _catalogs\masterpage\display templates\search\item_commentitem_body.html 

    if (!$isEmptyString(ctx.CurrentItem.csr_OpenApp)) { appAttribs += "openApp=\"" + $htmlEncode(ctx.CurrentItem.csr_OpenApp) + "\"" };
    if (!$isEmptyString(ctx.CurrentItem.csr_OpenControl)) { appAttribs += " openControl=\"" + $htmlEncode(ctx.CurrentItem.csr_OpenControl) + "\"" };

    Tuesday, June 4, 2019 3:09 AM