locked
IE8 and UAC - how can i set IE8 to run each time as an administrator ?

    Question

  • I am using a site which runs a script in order to provide live feeds from its server ( bsewebx.co.in ). Its online stock exchange site which is safe to use. It uses MS JAVA and script could be MS JAVA to get live feeds.

    Recently I got an update on VISTA of IE8 ( 8.0.6001.18702 ) and now I cannot use above site as the IE8 stops working when that script runs or want to run in background. It gives a message " IE has stopped working" and close program button has to be pressed to continue.

    Now that had an issue with DEP. I disabled DEP from CP - System - Advanced System Settings - DEP and DEP was set to exclude IE8. Now on restart, I am getting a message "windows explorer has stopped working" and nothing happens. I can only see a black screen. Then PC has to be booted using control+alt+del.

    I tried changing IE8 settings from internet options and "Enable memory protection to help...." was disabled. When IE8 was run as an admin, I could run bsewebx. I found from net forums that such setting can solve this problem.

    When IE8 was normally run, "Enable memory protection to help...." was activated again though it was unchecked.

    Now I understood that each time IE8 has to run in admin mode by right clicking to run bsewebx site properly. Now to avoid this step, icreated shortcut of IE on desktop and properties were set to run as admin by right clicking. 

    With this I am getting a box each time "program needs your permission to continue" which is an alert from UAC. 

    I wish to exclude IE8 from UAC alerts OR set IE8 file ( iexplore.exe ) to run as admin ( by default ). I dont want alerts from UAC. Is this possible ? When I right click on iexplore.exe, I cant access compatibility menu where in I can set IE8 to run as admin forever. The whole menu of compatibility is gray and not accessible. Is it possible to change settings in this box ?

    Too much of security can be a punishment sometimes which I can feel in this case. BSE people have no clues of this problems and they are asking me to lead IE6 and use webx. :-) I hope that microsoft shall come out with solution and make controls where one can easily exclude a software.


    Best Rgds,
    Dhiren.
    Monday, June 01, 2009 2:49 PM

Answers

  • Hello Dhiren,

     

    According to your problem description, please try the following steps to see whether they do work on your issue.

     

    Turn off IE protect mode

    1) Click Start button-> Control Panel.

    2) Change to Classic View on the left pane and double-click the Internet Options icon.

    3) On the Security tab, clear the Enable Protected Mode (requires restarting Internet Explorer) option.

    4) Click OK and restart IE7.

     

    Turn UAC off

    1) Log on to the Windows Vista-based computer as a local administrator.

    2) Click the Windows Pearl (Start Button) -> Control Panel.

    3) Select Classic View on the left and double-click the User Accounts icon.

    4) Click Turn User Account Control on or off option.

    5) Uncheck the User User Account Control (UAC) to help protect your computer and click OK.

    6) If prompted, choose restart, otherwise restart from the Start Menu.

     

    How to use User Account Control (UAC) in Windows Vista

    http://support.microsoft.com/kb/922708/en-us

     

    For more detail about this subject, please refer to the following article.

    Understanding and Working in Protected Mode Internet Explorer

    http://msdn.microsoft.com/en-us/library/bb250462.aspx

     

    If the problem still persists, you'd better to submit a new thread to MSDN forum Internet Explorer Web Development, who might help you to perfect your JavaScript tool.

     

    Good Luck!

    Andy

    • Marked as answer by Andy Song Wednesday, June 10, 2009 10:30 AM
    Tuesday, June 02, 2009 7:32 AM

All replies

  • Well as you might know the security architecture of IE8 is to run in a LORIE i.e. Low rights execution mode..however you can make IE to always run as an administrator by just a small change...

    create a shortcut of IE8 on the desktop or wherever you wish to...now right click on the shortcut and go to properties...
     
    now in the properties window go to "advanced"...and now you must see two options there "Run as administrator" and "Run in separate memory space"...make sure both of them are checked and click on "OK" and that's all...you are all set...from the next time you run IE it runs in Adminisrator mode by default....

    hope this should help...if not please do revert back to this post with the results..
    Regards, KOWSHAL H.M. a.k.a W@R10CK
    • Proposed as answer by CODEVANDAL Tuesday, June 02, 2009 12:51 AM
    Tuesday, June 02, 2009 12:51 AM
  • Thanks Kowshal for your quick answer. I have already done as per your suggestion. But each time I run IE8, a security box comes with a message "program needs your permission to continue". Is it possible to avoide this box for ever ? It disturbs a lot.

    Best Rgds,
    Dhiren.
    Tuesday, June 02, 2009 4:18 AM
  • Hello Dhiren,

     

    According to your problem description, please try the following steps to see whether they do work on your issue.

     

    Turn off IE protect mode

    1) Click Start button-> Control Panel.

    2) Change to Classic View on the left pane and double-click the Internet Options icon.

    3) On the Security tab, clear the Enable Protected Mode (requires restarting Internet Explorer) option.

    4) Click OK and restart IE7.

     

    Turn UAC off

    1) Log on to the Windows Vista-based computer as a local administrator.

    2) Click the Windows Pearl (Start Button) -> Control Panel.

    3) Select Classic View on the left and double-click the User Accounts icon.

    4) Click Turn User Account Control on or off option.

    5) Uncheck the User User Account Control (UAC) to help protect your computer and click OK.

    6) If prompted, choose restart, otherwise restart from the Start Menu.

     

    How to use User Account Control (UAC) in Windows Vista

    http://support.microsoft.com/kb/922708/en-us

     

    For more detail about this subject, please refer to the following article.

    Understanding and Working in Protected Mode Internet Explorer

    http://msdn.microsoft.com/en-us/library/bb250462.aspx

     

    If the problem still persists, you'd better to submit a new thread to MSDN forum Internet Explorer Web Development, who might help you to perfect your JavaScript tool.

     

    Good Luck!

    Andy

    • Marked as answer by Andy Song Wednesday, June 10, 2009 10:30 AM
    Tuesday, June 02, 2009 7:32 AM
  • Dear Andy,

    Thanks for your help. I tried steps suggested by you but that doesn't work. Protected mode is not actually the issue.

    "Enable memory protection to help mitigate online attacks" feature has to be disabled in order to run BSEWEBX script. Now when I disabled it in safe mode, IE8 was supposed to show me disabled for ever. However when in normal startup, BSEWEBX failed, I found that "Enable memory protection to help mitigate online attacks" was still active and couldn't be deactivaed even from Admin a/c.

    I discovered from few forums that IE has to run as an admin to effect such changes. When I right clicked and ran IE8 as admin, internet properties showed that "Enable memory protection to help mitigate online attacks" was disabled. Then I could run BSEWEBX site properly.

    Hence to continue my work, I had to run IE8 as an admin forever. However right click on IEXPLORE.EXE disappointed me as there was no provision to make any changes in IE8 in compatibility menu as the file was a component of windows. Hence as per microsoft, ther was no need to run IE8 as admin.

    As per Kowshal's suggestion and few forums, shortcut was created on desktop and IE8 was set to run as admin from the shortcut. Now this works ! But each time a nagging screen come and I have to give permission to continue. There is no provision to ignore that message for ever.

    Here I wanted solution. Or microsoft can improve IE and to run as admin feature should be enabled.

    However I found one fix from UAC-tweak from one site that doesn't diable UAC but disables messages. So using that, I am successful in running bsewebx and not getting that screen on each run of IE8.

    if anybody has a better fix, please suggest.

    Thanks again for your help.

    Best Rgds,
    Dhiren.


    Thursday, June 04, 2009 2:09 PM
  • Dhiren,

    I have been trying to use BSE Webx on one of my computers in office and it just won't work.

    This is my problem

    No. of Computers: 2 (For Reference Calling is A & B)
    Broadband Connection: MTNL
    Router: - DLINK 4 Port.
    Configuration of System A: Dual Core Processor, Asus Motherboard
    Configuration of System B: Core 2 Duo, Gigabyte Motherboard
    Operating System: Windows XP, SP3 (both have been updated with the same set of windows Update)

    System A runs BSE Webx just fine.

    System B give me the following error.
    21-Oct-09 14:58:09: Sucessfully Loaded 
    21-Oct-09 14:58:09: UMC Mapping file is not available. Unable to load UMC Information
    21-Oct-09 14:58:09: Loading UMC Mapping and UserSet files...
    # If I try logging in once more it gives the following message
    21-Oct-09 14:59:12: Socket Communications Fatal Error : null .. Please login again

    I have tried to look up every thing I possibly could understand in try to resolve the problem, with no success. I have called up BSE helpdesk and they too can't solve the problem.

    I was hoping if you could help



    • Proposed as answer by niravvvvvv Friday, April 09, 2010 7:41 PM
    Wednesday, October 21, 2009 9:31 AM
  • Dear acrazindian,

    Introduce yourself with your real name.

    BSE people wont be able to help you as they are least concerned with errors. They will just tell you that you should try to login from another PC and if that works, its not their fault !

    Are you using same login and password on both systems ? ie: logged in on A and trying to login to B ?

    I suggest that you delete your setup completely on B. From website of BSEWEBX, login on A using your login password. When you see menu after login, download EXE setup from the last item in menu. Run that setup on B. Your broker should have given you Premium access.

    Once you have installed setup on B, login from B. Come back with the result.

    Rgds,
    Dhiren.

    Wednesday, October 21, 2009 12:47 PM
  • Ok first the real name - Dhawal.

    I'm using the same login on both computers, but not trying to access it at the same time.

    I've reinstalled the entire OS a few times, but still no success.

    I have also tried logging in through the exe on it, but that didn't help either.

    It seems like something to do with the hardware than the software, which I find strange but a possibility.

    Because just after I posted my query earlier today, i switched hard drives of computer a and computer b. But computer B still won't connect to Webx.
    21-Oct-09 21:59:12: Socket Communications Fatal Error : socket was closed .. Please login again
    21-Oct-09 21:59:12: Socket Communications Fatal Error : null .. Please login again

    Thanks
    Dhawal
    Wednesday, October 21, 2009 5:26 PM
  • Ok Dhawal,

    Hardware should not be a problem. Have you got SUN JAVA on your PC ? If yes, disable it and remove it. You can check that from properties of IE.

    You should have MS JAVA on your PC. Install MS JAVA by downloading it from bsewebx site. You will get such link after login. Or simply check below link.

    https://www.bsewebx.co.in/STSB/syssettings.html

    Tell me what happens after such set up. When you login, do you see a screen that opens in new window which has a menu to enter in EASY, CLASSIC OR PREMIUM user ? Use EASY and check if you can enter in that mode. If successful, hardware is not an issue.

    If you dont have that sceen, you must enable pop-up in IE for bsewebx site.

    Come with your findings so that I can study the problem. Also tel me from where do you get above errors. Also tell me which version of IE you use. YOu may have to make changes in IE to run bsewebx.

    Rgds,
    Dhiren.
    Thursday, October 22, 2009 10:45 AM
  • Dhiren,

    I have done all the settings you have recommended. I have had this problem with Webx of that particular computer for almost 2 years now and I was never able to figure out what the problem is. i've also spent hours on the phone with the BSE helpdesk.

    But, Hardware seems to be an issue. Strange I know, and I want to figure it out why and how hardware.

    I plugged in a Wifi Card into the PC and tried to use WebX using the Wifi Card and voila... It just worked like it was supposed too.

    I am going to try to plug in a new Lan card and see if i can get positive results. I'll let you know if that solves the problem.

    Thanks for the help
    Dhawal
    Friday, October 23, 2009 8:10 AM

  • it still have the run as an administrator Greyed out..

    Thanks and Regards
    Samyy (Sameer Mittal)
    Sunday, December 20, 2009 7:45 PM
  • Hello every body i am using broadband mtnl and all system requirment for bsewebx is properly installed in my pc .IE version is 6.I am having problem in loging with bsewebx.When i launch software from start programme bsewebx premium window will open asking login id ,login name and trade password i feed up all the details but when i click on the same it's gives me some socket error in message box it's goes very fastly and i can read some socket connection like that error what can i do so that i can run bsewebx properly please guide me the same.and once again when we run bsewebx first time from bsewebx site and when i click on premium it's open some small window and showing connectivity between to pc and it tills wait for 845kb file but these file is not comming if i can get these file also then also i can sort out the problem please guys help me out.please help me dhiren or any other guy if u have the solution for the same .

    Thanks,

    Nirav

    Friday, April 09, 2010 7:41 PM
  • Mine too, which is why I was searching for the answer too without the UAC turn off ect...
    eph61820
    Thursday, April 22, 2010 2:10 PM