locked
add template - Sorry, you don't have access RRS feed

  • Question

  • Hi,

    i m trying to import list template when i try to upload getting Sorry, you don't have access.  user has full control pls guide what could be an issue and how to fix it.

    thx


    iffi

    Tuesday, January 7, 2020 10:08 AM

Answers

  • Hi iffi,

    Firstly, check if the user permission have "Add and Customize Pages" level.

    If not, using PowerShell command to enable script for specific site:

    Set-SPOSite -Identity https://tenant.sharepoint.com -DenyAddAndCustomizePages $false

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, January 8, 2020 8:38 AM

All replies

  • Check if the user has got proper permissions over the site and the template if you are admin try refreshing the permissions 

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered"Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Tuesday, January 7, 2020 10:16 AM
  • Hi,

    user has full control, i also tried with admin but getting same error.

    thx


    iffi

    Tuesday, January 7, 2020 11:04 AM
  • Hi iffi,

    Please go to SharePoint admin center->Settings->classic settings page, check if you have allowed user to run custom script.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, January 8, 2020 6:58 AM
  • Hi,

    These setting are enable at SharePoint global, do i have to enable these setting on my specific site.

    Thx


    iffi

    Wednesday, January 8, 2020 7:58 AM
  • Hi iffi,

    Firstly, check if the user permission have "Add and Customize Pages" level.

    If not, using PowerShell command to enable script for specific site:

    Set-SPOSite -Identity https://tenant.sharepoint.com -DenyAddAndCustomizePages $false

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, January 8, 2020 8:38 AM
  • Hi iffi,

    Is there any update?

    If the post helps you, you can mark it as answer to help other community members to find the information quickly.

    Thanks for your understanding.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Monday, January 13, 2020 5:42 AM
  • Hi,

    When i execute command

    Set-SPOSite -Identity https://tenant.sharepoint.com -DenyAddAndCustomizePages $false


    getting following error

    Connect-SPOService : Could not authenticate to SharePoint Online https://tenant.sharepoint.com using OAuth
    2.0
    At line:1 char:1
    + Connect-SPOService -Url https://tenant.sharepoint.com
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Connect-SPOService], AuthenticationException
        + FullyQualifiedErrorId : Microsoft.Online.SharePoint.PowerShell.AuthenticationException,Microsoft.Online.SharePoi
       nt.PowerShell.ConnectSPOService

    pls guide
    thx

    iffi

    Tuesday, January 14, 2020 12:27 PM
  • Hi iffi,

    Before run the “Set-SPOSite” command,  run the “Connect-SPOService” command using URL of SharePoint Online Administration Center ("https://tenant-admin.sharepoint.com") and run the SharePoint Online Management Shell as administrator. Then use global administrator account to login.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, January 15, 2020 2:23 AM
  • Hi iffi,

    I’m checking how the things are going on about this issue. Whether the post helps you?

    You can mark the post as answer if it helps.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, January 21, 2020 7:48 AM
  • Hi,

    i run command successfully but still getting same access denied error.

    pls guide

    thx


    iffi

    Tuesday, January 21, 2020 7:56 AM
  • Hi iffi,

    Have you ever wait at least 24 hours to bring this setting into effect?

    If the issue still exists, make sure all authenticated users have read access for SharePoint Taxonomy Hidden List.

    This list is hidden and does not inherit permissions, you can find it by browsing directly to https://spsite/Lists/TaxonomyHiddenList.

    If all authenticated users don't have access, we can add "Everyone" to this list with Read permission.

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, January 21, 2020 8:42 AM
  • Hi,

    I am able to access https://spsite/Lists/TaxonomyHiddenList but still getting same error.

    pls advise.

    thanks.


    iffi

    Wednesday, January 22, 2020 5:41 AM
  • Hi,

    now its working with given command i just disable it.

    Set-SPOSite -Identity https://tenant.sharepoint.com -DenyAddAndCustomizePages $false


    iffi

    Thursday, January 23, 2020 5:34 AM