none
IE11 Enterprise Mode Fails on Windows 2008 R2 RRS feed

  • Question

  • Citrix XenApp 6.5 Environment with Citrix Profiles enabled on Windows 2008 R2 SP1

    IE version 11.0.9600.17.207

    Enterprise Enabled through Group Policy at the Computer Object level. Confirmed. Also tried at the User policy level with the same result.

    Site List accessible via http, confirmed that it does work.

    The websites that are in the Site List sporadically work, today the user logs on (same server) Enterprise Mode gets enabled. Log off and log back onto the same server, Enterprise mode fails to turn on. More times than none, it fails to turn on. Even with the same session if I close and reopen IE (without logging on) it may or may not turn on, if it does turn on however it seem to stick no how many times I open and close IE...until you log off and on again. 

    Any anyone within a remote desktop environment seen similar results?   


    • Edited by MrFrankieG Friday, August 29, 2014 8:12 AM
    Friday, August 29, 2014 8:11 AM

Answers

  • After a weekend of testing I figured it out.

    1. A local copy of the xml file is saved in th IE cached folder

    2. After the file has been save to cache the following registry key HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\EnterpriseMode\CurrentVersion is updated with the version number of the xml file

    3. If this key exists and matches the current xml file version number, then the xml file is not downloaded and reapplied, since the assumption is that it is current and has already been applied.

    In an RDS/Citrix environment if you use roaming or mandatory profiles and do not sync/upload the temporary Internet Files (as you shouldn't be) the xml file will be lost when you log off. At next logon your Temporary Internet files have been lost and because of the existence of the above registry key the xml file is not downloaded and reapplied.

    My solution was to delete the above registry key at each logon, using registry preferences.  But after working out the above I found the following forum on the issue. Typical couldn't have found that first, I guess knowledge is everything. Hopefully this helps someone else.

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/6c266558-a7f0-4169-a0a7-668899b1653e/ie-11-enterprise-mode-on-remote-desktop-server?forum=ieitprocurrentver   

    • Marked as answer by MrFrankieG Monday, September 1, 2014 1:05 AM
    Monday, September 1, 2014 1:05 AM

All replies

  • After a weekend of testing I figured it out.

    1. A local copy of the xml file is saved in th IE cached folder

    2. After the file has been save to cache the following registry key HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\EnterpriseMode\CurrentVersion is updated with the version number of the xml file

    3. If this key exists and matches the current xml file version number, then the xml file is not downloaded and reapplied, since the assumption is that it is current and has already been applied.

    In an RDS/Citrix environment if you use roaming or mandatory profiles and do not sync/upload the temporary Internet Files (as you shouldn't be) the xml file will be lost when you log off. At next logon your Temporary Internet files have been lost and because of the existence of the above registry key the xml file is not downloaded and reapplied.

    My solution was to delete the above registry key at each logon, using registry preferences.  But after working out the above I found the following forum on the issue. Typical couldn't have found that first, I guess knowledge is everything. Hopefully this helps someone else.

    http://social.technet.microsoft.com/Forums/windowsserver/en-US/6c266558-a7f0-4169-a0a7-668899b1653e/ie-11-enterprise-mode-on-remote-desktop-server?forum=ieitprocurrentver   

    • Marked as answer by MrFrankieG Monday, September 1, 2014 1:05 AM
    Monday, September 1, 2014 1:05 AM
  • Hi,

    Glad to see your problem resolved, hope your experience was helpful with others who had same problem.


    Roger Lu
    TechNet Community Support

    Monday, September 1, 2014 9:42 AM
    Moderator
  • Awesome, thanks a lot. IT is pretty crazy they've designed it this way!
    Thursday, January 15, 2015 7:32 AM