locked
Disabling Remote Desktop Protocol from saving Username RRS feed

  • Question

  • Hi

    I have a domain in which users have to access different servers with different user IDs with a single remote desktop connection. They have to plug in the server name each time in the RDP client and they get the server log in screen. But the problem is that when ever they access any server they have the last user ID, which they used already for a previous logon, is already plugged in the username field.

    My requirement is that when ever the user accesses the servers through RDP client the logon screen must always have username field empty.

    Regards     

    Thursday, May 17, 2012 3:58 AM

Answers

  • Hi,

    On the client PC you may use the public mode option of the Remote Desktop Client.  This is accomplished via command line switch, like this:

    mstsc /public

    or by adding the following line to the .rdp file using Notepad (add to default.rdp to set as the user's default):

    public mode:i:1

    On the servers you may force the password to be entered each time by opening RD Session Host Configuration or Terminal Services Configuration, double-clicking on RDP-Tcp, select Always use the following log on information, enter the domain in the domain box, and leave the rest of the boxes blank.

    -TP

    Monday, May 21, 2012 6:25 AM

All replies

  • You need to create a GPO and link it to your RDS computers OU. In the GPO go to Computer Configuration > Policies (for 2008 Servers) > Windows Settings > Security Settings > Local Policies > Security Options. Here enable Interactive logon: Do not disply last username policy.

    Adrian Costea - MCP, MCTS, MCSA 2003, MCITP: Windows 7

    My Blog: www.vkernel.ro/blog

    Thursday, May 17, 2012 6:27 AM
  • Hi Adrian

    Thanks for posting

    I have already applied that policy locally on all the RDS computers. But with the RD Client it doesn't seem to work :( . It works only if I directly log in on the RDS server :(

    Thursday, May 17, 2012 7:20 AM
  • For that follow this guide http://support.microsoft.com/kb/312169

    Adrian Costea - MCP, MCTS, MCSA 2003, MCITP: Windows 7

    My Blog: www.vkernel.ro/blog

    Thursday, May 17, 2012 8:06 AM
  • 
    
    Thanks Adrian. Problem is that even if we delete those entries from the registry the user ID still appears on RDP.....
    Thursday, May 17, 2012 9:25 AM
  • After logging in to server 1 with rdp client when he logs on to server2 using rdp client the previuos user ID(used on server1) appears automatically :( 

    I want the username field to be empty at this time

    Monday, May 21, 2012 3:16 AM
  • Hi,

    On the client PC you may use the public mode option of the Remote Desktop Client.  This is accomplished via command line switch, like this:

    mstsc /public

    or by adding the following line to the .rdp file using Notepad (add to default.rdp to set as the user's default):

    public mode:i:1

    On the servers you may force the password to be entered each time by opening RD Session Host Configuration or Terminal Services Configuration, double-clicking on RDP-Tcp, select Always use the following log on information, enter the domain in the domain box, and leave the rest of the boxes blank.

    -TP

    Monday, May 21, 2012 6:25 AM
  • Thanks TP. It solved my problem
    Monday, May 21, 2012 10:05 AM