locked
Wrong Album Art in Windows Media Player 12 RRS feed

  • Question

  • Hello all.

    In some music, I can't get the correct album art to show.

    Even if I right click in the wrong album art, and search for the album cover, choose from the available options, it doesn't update.

    What to do?

     

     

    Tuesday, May 25, 2010 1:32 AM

Answers

  • Hi Victor,

     

    Please first check the suggestions in this article: Add or change album art in Windows Media Player

     

    If the issue persists, try clearing the Windows Media Player database by the steps below:

     

    1.     Exit Windows Media Player.

    2.     Click Start, type %LOCALAPPDATA%\Microsoft\Media Player in the Start Search box, and then press ENTER.

    3.     Select all the files in the folder, and then click Delete on the File menu.

     

     Note: You do not have to delete the folders that are in this folder.

     

    4.     Restart Windows Media Player.

     

    Note: Windows Media Player automatically rebuilds the database.

     

    If this does not resolve the problem, clear the Windows Media Player database cache files. To do this, follow these steps:

     

    1.     Exit Windows Media Player.

    2.     Click Start, type %LOCALAPPDATA%\Microsoft in the Start Search box and then press ENTER.

    3.     Select the Media Player folder, and then click Delete on the File menu.

    4.     Restart Windows Media Player.

     

    Note: Windows Media Player automatically rebuilds the database.

     

    Hope this helps.

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Monday, May 31, 2010 2:20 AM
    Tuesday, May 25, 2010 9:26 AM

All replies

  • Hi Victor,

     

    Please first check the suggestions in this article: Add or change album art in Windows Media Player

     

    If the issue persists, try clearing the Windows Media Player database by the steps below:

     

    1.     Exit Windows Media Player.

    2.     Click Start, type %LOCALAPPDATA%\Microsoft\Media Player in the Start Search box, and then press ENTER.

    3.     Select all the files in the folder, and then click Delete on the File menu.

     

     Note: You do not have to delete the folders that are in this folder.

     

    4.     Restart Windows Media Player.

     

    Note: Windows Media Player automatically rebuilds the database.

     

    If this does not resolve the problem, clear the Windows Media Player database cache files. To do this, follow these steps:

     

    1.     Exit Windows Media Player.

    2.     Click Start, type %LOCALAPPDATA%\Microsoft in the Start Search box and then press ENTER.

    3.     Select the Media Player folder, and then click Delete on the File menu.

    4.     Restart Windows Media Player.

     

    Note: Windows Media Player automatically rebuilds the database.

     

    Hope this helps.

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Monday, May 31, 2010 2:20 AM
    Tuesday, May 25, 2010 9:26 AM
  • It won't allow me to erase the media player file. And the incorrect album art still show up.

    Tuesday, December 7, 2010 2:27 AM
  • myisalas, try resetting the media library by following these instructions: (note that resetting the library will make you lose all current play counts, and possibly ratings too)

    - Reboot the PC.
    - Go to Start, type services.msc in the Search field, and press Enter. In Services, find the Windows Media Player Network Sharing Service . If its status is Started , double-click the service and click Stop .
    - Go to Start, type  %LOCALAPPDATA%\Microsoft in the Search field, and press Enter. This folder will open up in Windows Explorer.
    - In this folder, rename the Media Player folder to something like Media Player old . If you can't see the folder, then it's probably hidden. Set Explorer to show hidden files and folders, and to show protected system files.
    - Start WMP, your library will have been reset and will be rebuilt. Check if the issue still occurs.
    Tim De Baets
    http://www.bm-productions.tk
    Wednesday, December 8, 2010 4:11 PM
  • Greetings Sir,


    I tried both the way i.e deleting and renaming but my WMP's album art is stuck. It shows only one album art no matter which song I play. Do you still have any other way to solve it?

     

    With Regards

    Davvy Jones

    "Do you fear death?"

    Friday, December 9, 2011 2:03 PM
  • Davvy: I suggest that you check your music folder for hidden JPEG files containing the incorrect album art and delete those files (make sure that Explorer is still set to show hidden files and folders, and to show protected operating system files). Especially JPEG files called Folder.jpg can be the culprit, but there may be others as well.
    Tim De Baets
    http://www.bm-productions.tk
    • Edited by Tim De Baets Saturday, December 10, 2011 2:41 PM
    Saturday, December 10, 2011 2:41 PM
  • Try this, it worked for me:

    1) go on start menu
    2) Search "run"
    3) and type in "msdt.exe -id WindowsMediaPlayerConfigurationDiagnostic" no bracets this will reset all your settings and fix all issues you have with windows media player
    4) apply fix and close troubleshoote

    • Proposed as answer by Rahul Seth Saturday, June 16, 2012 12:44 PM
    Saturday, June 16, 2012 12:44 PM
  • Sounds like the album cover is in the TAG for the song, which WMP cannot get rid of.  Download freeware program MP3TAG to get rid of the album art.
    Sunday, June 24, 2012 7:26 PM
  • I'm having the problem with incorrect album art being displayed in WMP.  THe problem first appeared after I allowed WMP to update some album info from the internet.

    So far, I have done the following:

    1) Checked the metadata tags for the tracks using Mp3tag to display all attributes, including the album cover. I have also used the Remove Field action of Mp3tag to remove any tag data pointing to pictures for the affected files - not fixed

    2) Rebuilt the WMP database - no luck

    3) Searched my entire music library for .jpg files, including hidden files and folders. I found one, however it was not the offending image (and is not related to the same artist as the affected albums).

    4) Deleting albums using WMP, and ripping again (with the option to retrieve info from the internet disabled).  This seems to work but a) is a waste of time, and b) may not fix the root cause, so the problem may recur.

    Can anyone suggest other cause(s) and fix(es)? 

    To clarify, I don't need to find a associate the correct album art. The affected recordings so far have been independent productions where album art is probably not available. (The issue only affects a small subset of the small label / independent recordings in my collection however. Possibly I never asked or allowed WMP to try to provide album art for those.)

    I would be very happy with a solutiion that enables me to remove the inappropriate album art, and allow WMP to display the default graphic associated with these album(s).  Any suggestions for what solutions I have overlooked so far?

    thanks!




    • Edited by FL Guy Saturday, July 14, 2012 5:02 PM
    Friday, July 13, 2012 8:39 PM
  • FL Guy: I suggest that you first clear IE's Temporary Internet Files. Then, try clearing the album art cache. Close Windows Media Player and Media Center, and make sure that Windows Explorer is set to show hidden files and folders, and to show protected operating system files. Then, navigate to %LOCALAPPDATA%\Microsoft\Media Player\Art Cache\LocalMLS and delete all files in that folder. Does that help?

    Tim De Baets
    http://www.bm-productions.tk

    Sunday, July 15, 2012 4:25 PM
  • Thanks for the suggestion. Somehow I missed seeing the post. I'll try that this weekend and let you know...
    Saturday, July 21, 2012 7:01 PM
  • hey, I found the glitch for my problem... turns out that all the songs on the desktop/ particular folders were showing the same album art due to the hidden jpeg files...... if the other music's art is displaying correctly, try moving the problematic song to that folder, else, look for the hidden jpeg and delete it...... it seems this glitch occurs when you permanently delete a song, but the image is left....
    Saturday, October 6, 2012 9:35 PM
  • i have tried to delete the media player folder but it says....this action cant be completed because the folder or a file in it is open in another program... but nothing is up or open but the file you told me to go to delete it how do i solve this problem plz help

    Thursday, May 15, 2014 2:37 PM
  • i tried both of these things and the cover art will not change to what its suppost to be
    Thursday, May 15, 2014 3:22 PM
  • Sjr123: please create a new question in this forum for your issue, and describe your exact steps and what exactly goes wrong. Thanks!

    Tim De Baets
    http://www.bm-productions.tk

    Friday, May 16, 2014 8:32 PM
  • That worked for me.

    (show protected operating system files --> delete folder.jpg)

    Friday, June 6, 2014 11:22 AM
  • Hi Buddy, 

    Sorry for late replies, Just saw your question here. Hope your issue has been resolved but there are many other that need help! :)

    The issue is due to a reason that the Album art is hidden as "System File". The issue will only persist when you play music from a specific folder. Please follow the below steps to resolve the issue yourself.

    If you enable "Show hidden files" and uncheck "Hide protected operating system files" in folder options and then manually delete any images (Image that show up to be wrong album art). That should fix the issue, You may also delete any thumbs.db or desktop.ini (in case of desktop folder).

    Now when you play music from the same folder the Media Player should collect the right Album Art from the music tag.

    Thanks. :)

    • Proposed as answer by Mr.January19 Saturday, December 20, 2014 6:33 PM
    Saturday, December 20, 2014 6:32 PM
  • After trying every other suggestion I could find in this thread, I finally found that "show protected operating system files" and then deleting folder.jpg from the folder the music was in was what worked. It's disappointing that Windows Media Player is so faulty and can waste so much of an evening.
    Monday, April 13, 2015 11:46 AM
  • You know what you need to do? Install iTunes. That is the best fix for this.
    Monday, August 10, 2015 11:53 AM
  • This one worked for me :) 

    • Proposed as answer by Rounak Biswas Tuesday, March 7, 2017 4:20 AM
    • Unproposed as answer by Rounak Biswas Tuesday, March 7, 2017 4:21 AM
    Tuesday, March 7, 2017 4:20 AM
  • I have several files with embedded album art, which made Windows Media Player recreate "Folder.jpg" every time I had cleared the cache. This messes up other files in the folder. See Mr.January19's answer.

    Here is my general solution (you could try directly steps 7, 15, 16, 17):

    1. Open Windows Media Player.
    2. Press ALT and select Tools > Options.
    3. From the Library tab deselect "Retrieve additional information from the Internet".
    4. From the Privay tab deselect everything under "Enhanced Playback and Device Experience".
    5. Close Windows Media Player.
    6. Delete "%LOCALAPPDATA%\Microsoft\Media Player" folder.
    7. Enable "Show hidden files" and uncheck "Hide protected operating system files" in folder options.
    8. Go to your global music folder (or each if multiple).
    9. Search "AlbumArt OR Folder.jpg" and delete all files (use CTRL+A to select).
    10. Open Windows Media Player.
    11. If it's not in Library mode, press "Switch to Library" in the top right bellow the Close button.
    12. Right click on Music and select "Manage music Library".
    13. Add your global music folders (to rebuild cache faster).
    14. Wait to finish.
    15. Close Windows Media Player.
    16. Go to your global music folder (or each if multiple).
    17. Search "Folder.jpg OR AlbumArtSmall.jpg" and delete all files (use CTRL+A to select).

    Now, only files with embedded album art should have a different visualization.

    If cannot delete cache folder at step 6, try this (as suggested by Tim De Baets): Go to Start, type services.msc in the Search field, and press Enter. In Services, find the Windows Media Player Network Sharing Service. If its status is Started, double-click the service and click Stop.



    • Edited by MatrixRonny Friday, October 26, 2018 5:24 PM Added space after step 17
    Friday, October 26, 2018 5:22 PM