none
IE9 does not delete cookies when set to delete all history on close RRS feed

  • Question

  • I have IE9 installed in Win7 x64 Ultimate.

    I have the Tools / Internet Options / Browsing History set to delete browsing history on exit.  I have checked off all the possibilities. (history, cookies, etc).

    Steps to Reproduce Bug:
    I sign into Gmail.
    Close the browser without signing out
    Wait 30 seconds for IE to finish its closing out business
    Relaunch IE9.  Go to www.gmail.com
    It will already be logged into your account.

    IE8 worked fine with this.  IE9 does not.  Can others reproduce this?

    Tuesday, February 22, 2011 5:55 PM

Answers

  • There is a new option in IE9 which overrides the other settings.  Under Tools / Internet Options, under Browsing History, make sure the checkmark is there for Delete Browsing History on Exit. Then click "Delete ... "  and make sure the very top checkmark is EMPTY. This setting will KEEP your cookies for Favorited sites, including your homepage. 

     

    My homepage was set to www.google.com and thus it would not clear google cookies on exit. I have unchecked this box and it works as I expected it to.

     

    • Marked as answer by docsmody Friday, August 19, 2011 5:09 PM
    Friday, August 19, 2011 5:09 PM

All replies

  • Hi,

     

    According to your description, I suggest to perform these steps to solve the issue:

    1 Delete IE temporary files, history, cookies, saved passwords first

    2 Choose “Delete browsing history on exit”

    3 Click “Settings” with “Browsing history”

    4 Select “Never” in “Check for newer version of stored pages”

    5 Click “OK”

     

    If the issue persists, please wait for a bit longer time to see if the same issue occurs.

     

    Hope that helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, February 24, 2011 8:27 AM
    Moderator
  • I have also noticed the same problem, which I think is a serious issue if you're going to deploy IE9 on public or shared computers. The solution you have proposed is rather long-winded. It should be much simpler than that, one or two clicks, not five. I urge Microsoft to look into this ASAP.
    Friday, March 11, 2011 6:51 PM
  • I've been having exactly the same problem with IE9. After a chance attempt with Glary Utilities to try to force the clearing of cookies, something became apparent. It seems that IE9 sometimes just never closes off processes properly; I had about 5 of them hanging around in Task Manager - when I killed them and ran Delete Browsing History manually, my cookies were gone. This is surely a bug.
    Tuesday, March 15, 2011 8:33 PM
  • It seems that IE9 sometimes just never closes off processes properly; I had about 5 of them hanging around in Task Manager - when I killed them and ran Delete Browsing History manually, my cookies were gone. This is surely a bug.


    Not necessarily.   It could be a symptom of an environmental detail that you have overlooked.  E.g. a certain AV product is known to create and hold half sessions which could cause that symptom.  Instead of killing those processes first try to find out what is holding them up.  E.g. W7 users could use the Task Manager's Resource Monitor to do that.  For the specific example I gave you could use TCPView or  netstat  /abnop TCP  in a cmd window.  Another example would be spawning a  WLMAil.exe  process using  File, Send and forgetting about that when trying to close the IE task.   I think you might be able to detect that one using ProcExp  (e.g. it shows the relationship between processes better than TM).


    HTH

    Robert Aldwinckle
    ---

    Wednesday, March 16, 2011 3:05 AM
    Answerer
  • I have the same problem, and I am not a computer-savvy programmer - I only use the menus available.

    Please tell me what settings in IE9 I need to change to get these darned cookies to delete on exit!  I have checked every menu setting I can find, so obviously IE9 has 'improved' to have a hidden setting somewhere.

    This is frustrating and pretty lame of Microsoft.

    Tuesday, March 29, 2011 3:29 PM
  • There is a new option in IE9 which overrides the other settings.  Under Tools / Internet Options, under Browsing History, make sure the checkmark is there for Delete Browsing History on Exit. Then click "Delete ... "  and make sure the very top checkmark is EMPTY. This setting will KEEP your cookies for Favorited sites, including your homepage. 

     

    My homepage was set to www.google.com and thus it would not clear google cookies on exit. I have unchecked this box and it works as I expected it to.

     

    • Marked as answer by docsmody Friday, August 19, 2011 5:09 PM
    Friday, August 19, 2011 5:09 PM
  •  

    Hi,

     

    According to your description, I suggest to perform these steps to solve the issue:

    1 Delete IE temporary files, history, cookies, saved passwords first

    2 Choose “Delete browsing history on exit”

    3 Click “Settings” with “Browsing history”

    4 Select “Never” in “Check for newer version of stored pages”

    5 Click “OK”

     

    If the issue persists, please wait for a bit longer time to see if the same issue occurs.

     

    Hope that helps.

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    THis by the way had NOTHING to do with the issue or solution.  You MSFT people need to be more aware of your products and features.  And MSFT staff shouldn't go around marking answers that don't solve the problem.
    Friday, August 19, 2011 5:14 PM
  • I also can confirm this, sites visited that are not homepages or whatever not being cleared upon exiting ie9. 

    under internet exploer 8

    1. homepage = google

    2. visit youtube

    3. close browser

    4. open browser check history

    5. result = nothing

    ----------------------

    nothing changed

    installed internet exploer 9

    1. homepage = google

    2. visit youtube

    3. close browser

    4. open browser check history

    5. result = youtube is present in history still

    ==============================================================

    i tried to uncheck and retick the 'delete browsing history on exit' option, same result

    i unticked the option to 'preserve favorite websites data' option when i manually deleted the history, same result

    honestly the suggestion mentioned above to [4 Select “Never” in “Check for newer version of stored pages”] WOULD TOTALLY DEFEAT THE PURPOSE OF HAVING THE HISTORY DELETED ON EXIT BECAUSE IT SHOULD HAVE TO LOAD NEW EVERY TIME YOU REOPEN IE!  THIS OPTION IS TOTALLY BROKEN!

    Tuesday, August 23, 2011 7:05 AM
  • i think i found a solution:

    1. goto advanced tab in internet options

    2. scroll almost to the bottom under Security section

    3. locate "empty temporary internet files folder when browser is closed" option and tick it!

    4. result = browsing history is deleted upon closing internet explorer 9

    5. they must have forgot the original setting to delete browsing history upon exiting on the first 'general' tab of internet options, apparently that option is pointless and does nothing if ticked or unticked. also, the advanced option that i located does not say anything about altering or deleting history but apparently that is what is needed.  ms fix this please!

     

     

    Tuesday, August 23, 2011 7:21 AM
  • this only worked the first time i closed my browser, now i'm getting the same result as before, history/cookies/temp files.... all still there after i close ie....

     

     

    interestingly enough, when i click the internet exploerer shortcut, it will not delete browsing history on closing, but if i open internet exploerer by clicking on another link or shortcut directly to another webpage, then when i close ie it does delete the browsing history.  so is it something with the old internet explorer shortcuts????????????


    for example, goto google, drag that shortcut to desktop, and use that to start up internet explorer instead of the original shortcut, and just fyi this did work to delete the browsing history, but i was still able to login directly to this website so it is not deleting all of the cookies.  buggy as hell if you ask me, i'm going to try to go back to ie8
    Tuesday, August 23, 2011 7:26 AM
  • i think i found a solution:

    1. goto advanced tab in internet options

    2. scroll almost to the bottom under Security section

    3. locate "empty temporary internet files folder when browser is closed" option and tick it!

    4. result = browsing history is deleted upon closing internet explorer 9

    5. they must have forgot the original setting to delete browsing history upon exiting on the first 'general' tab of internet options, apparently that option is pointless and does nothing if ticked or unticked. also, the advanced option that i located does not say anything about altering or deleting history but apparently that is what is needed.  ms fix this please!

     

     


    I'm not sure this is the answer.  I'm having the same problem after upgrading to IE9.  I went back to IE7 until I can figure out the problem.  I went to "Empty Temp internet files" and it is not ticked, and yet is working perfectly.  There is some setting in IE9 that is different from IE7 that is making this happen.  Very frustrating, as I have several different Gmail accounts, some I share with others.  I prefer closing the window to signing out, because I don't want to sign out the other person if they happen to be on at the same time!
    Tuesday, November 1, 2011 8:43 PM
  • The problem is with Windows Search Index. Click the start button and type 'Indexing' into the search box. In the Indexing Options box make sure Internet Explorer appears and is enabled for indexing. Click the Advanced button and select the option to Rebuild. This will take some time as it re-indexes all the selected locations.
    Monday, January 30, 2012 2:37 PM