none
Office 2019 cannot open files on a mapped WebDAV share RRS feed

  • General discussion

  • We have a client who uses a WebDAV server to access file shares remotely. The server is based on IIS 7 and works perfectly fine. All users have the WebDAV share mapped as a drive letter and can access all files. Opening documents with Office 2010, 2013 and 2016 works flawlessly but not Office 2019.

    When a user double clicks a file, Word (or Excel and PP for that matter) opens and displays an error message saying:

    Word found unreadable content in "<documentname.docx>". Do you want to recover the contents of this document? If you trust the source of this document, click Yes.

    When clicking yes, the recovery process fails miserably.

    The interesting thing is that if I copy the document to the desktop, it opens fine. When I map the location of the WebDAV share as an SMB share, it also opens fine. 

    Permissions to the files and the share are ok as different office versions can access them.

    What has changed in Office 2019 that might be causing this? Does it require different authentication compared to older Office versions? 

    Any help would be appreciated.

    Wednesday, September 18, 2019 1:44 AM

All replies

  • Nobody came across this issue yet? 


    Monday, September 30, 2019 10:59 PM
  • Ok, the mystery is solved.

    It turned out that after an update, Office 2013 and 2016 were showing the same behaviour. Interestingly enough, we've discovered that the there was no problem opening documents from the root of the mapped drive but anything in subfolders would fail.

    It turns out that the WebDAV share in IIS had "Windows authentication" and "anonymous authentication" enabled. after disabling the anonymous access, Office asked the user for credentials when opening a document and after authenticating again, the documents would work. 

    In hindsight, it makes sense that anonymous was in the way but it doesn't explain why the root of the drive was fine but subfolders weren't.

    Either way, all is sorted, thanks to myself :)

    Thursday, October 10, 2019 12:31 AM