none
How to enable/disable SMBv1 in Windows 10 RRS feed

  • Question

  • Hi all,

    I need your help with knowing how to How to enable/disable SMBv1 in Windows 10? It's what Buffalo NAS drive support have suggested I need to do to get my NAS to work in Windows 10.

    Cheers


    Ant

    Friday, September 30, 2016 11:10 PM

Answers

  • Hi ANTMAL,

    What is the main issue?

    SMB 1 should be enabled by default but it won`t be used if SMB2.0 or SMB 3.0 is available.

    If your NAS device only supports SMB 1.0, we could try to disable SMB 2.0 and SMB3.0 to force the Windows 10 machine to use SMB 1.0 to access the share by running the following command line.

    Disable SMB2.0 and SMB 3.0
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled

    Here is a link for reference:
    How to enable and disable SMBv1, SMBv2, and SMBv3 in Windows Vista, Windows Server 2008, Windows 7, Windows Server 2008 R2, Windows 8, and Windows Server 2012
    https://support.microsoft.com/en-sg/kb/2696547

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, October 3, 2016 7:36 AM
    Moderator

All replies

  • Go to Control Panel > Programs and Features > Turn Windows Features on or off > check or uncheck the box for "SMB 1.0/CIFS File Sharing Support"

    Best Regards, Todd Heron | Active Directory Consultant

    • Proposed as answer by Coed Friday, June 8, 2018 4:20 PM
    Saturday, October 1, 2016 2:46 AM
  • Hi ANTMAL,

    What is the main issue?

    SMB 1 should be enabled by default but it won`t be used if SMB2.0 or SMB 3.0 is available.

    If your NAS device only supports SMB 1.0, we could try to disable SMB 2.0 and SMB3.0 to force the Windows 10 machine to use SMB 1.0 to access the share by running the following command line.

    Disable SMB2.0 and SMB 3.0
    sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
    sc.exe config mrxsmb20 start= disabled

    Here is a link for reference:
    How to enable and disable SMBv1, SMBv2, and SMBv3 in Windows Vista, Windows Server 2008, Windows 7, Windows Server 2008 R2, Windows 8, and Windows Server 2012
    https://support.microsoft.com/en-sg/kb/2696547

    Best regards


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, October 3, 2016 7:36 AM
    Moderator
  • That was easy! Thank you Todd Heron.  Good day.
    Wednesday, May 17, 2017 5:20 PM
  • Ditto. Thank you Todd.
    Monday, June 26, 2017 12:43 AM
  • I have SMB 1 turned on, but I still cannot see my NAS drive?
    Thursday, December 28, 2017 3:16 PM
  •   That is a good start. You also need NetBIOS over TCP/IP .

      Can you see your NAS if you do a NET VIEW command?


    Bill

    Friday, December 29, 2017 12:53 AM
  • super thanks Todd - VERY helpful!!
    Saturday, April 28, 2018 2:37 AM
  • Todd,

    If I'm ever in Washington, DC, I'm going to look you up and buy you as many beers as you like.  Thanks!

    - C. Patrick

    Tuesday, May 22, 2018 11:13 PM
  • Hi Todd ,

    Thank the Lord i found your reply ... the beers are mine if you land in Brisbane one day - Again thanks for sharing mate

    Wednesday, May 23, 2018 5:00 AM
  • I have been working to fix this problem for 3 month and reading posts. but the sit fixed my problem

    Thank You

    Sunday, July 8, 2018 2:44 PM
  • Hi Todd!

    Thanks it was simple and worked for me.

    Hgraym

    Friday, February 1, 2019 7:54 PM