none
OteleData .etl files being created - causing performance issues and space issues RRS feed

  • Question

  • Hi, I have a weird issue that I am not sure of the source. Recently on a few of our terminal server clients we have noticed that large amounts of files have been created that are using a lot of space and apparently causing a lot of performance issues. As the files are continuously being created.

    These files have a standard naming scheme which starts OTeleData_XXXX_X.etl where the X's are digits. They are located in the AppData\Local\Microsoft\Office\ folder they max out at 50MB a file but there can be hundreds in any one users directory.

    Firstly does anyone know why these files are being created, what creates them and a way to stop them from being created?

    Tuesday, April 14, 2015 3:28 PM

All replies

  • Hi Dave,

    Thanks for your question. 

    .etl files are event trace logs, I have tested and found that these .etl files are actually generated by Microsoft Outlook. Please have a check, and see if you've enabled global logging in your Outlook client:

    • Launch Outlook, on the File tab, select Options.
    • In the Outlook Options dialog box, click Advanced.
    • Scroll down the list of settings, check whether the Enable troubleshooting logging (requires restarting Outlook) option is selected. If yes, deselect it then try again.

    Regards,

    Ethan Hua

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Wednesday, April 15, 2015 9:34 AM
    Moderator
  • I have the exact same problem with over 30 GB of etl files in the same folder as the OP.

    Enable troubleshooting logging was already deselected in outlook. Is it save to delete those etl files ?

    Wednesday, April 15, 2015 10:50 AM
  • @Kasper Peulen - We have been deleting them as they appear. Which is really not ideal.

    @Ethan Hua - Outlook Logging is disabled for the people that the logs are being created on.

    Wednesday, April 15, 2015 4:54 PM
  • Hi Dave,
     
    Thank you for your confirmation.

    This is a quick note to let you know that we are performing research on this issue.

    Regards,

    Ethan Hua

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Thursday, April 16, 2015 5:33 AM
    Moderator
  • I seem to have the same problem. 

    I tried to open the files in Windows Performance Analyzer, but I got an error, "File not found". I got the same error when I tried to open the files with Notepad.

    I also noticed that there is an "OTele" subfolder in the same folder. It contains many small files with names like {C3372D96-8BB2-44A9-A9C3-1E421A86A296} - nnnn - OTele.dat. 

    Also in my case, logging was turned off in Outlook. I tried turning it on to see what would happen:

    1. The resulting .etl file was very large - over 50Mb in just a few seconds
    2. The file was deleted once I turned logging back off and exited Outlook

    The .etl files that are produced with logging turned off are much smaller and get me that "File not found" error when I attempt to open them. This leads me to believe that I have been infected with some sort of virus or other malware. I have reason to believe this is likely.


    John Saunders
    WCF is Web Services. They are not two separate things.
    Use WCF for All New Web Service Development, instead of legacy ASMX or obsolete WSE
    Use File->New Project to create Web Service Projects

    Friday, April 17, 2015 2:56 AM
  • Hi,

    Thanks for your feedback.

    We are able to reproduce the issue on our end. The investigation is still ongoing, we will keep you updated if there will be news.

    Thanks for your understanding.

    Regards,

    Ethan Hua

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Friday, April 17, 2015 9:42 AM
    Moderator
  • That's brilliant to hear. I await your update eagerly.
    Friday, April 17, 2015 12:40 PM
  • That's great news.

    Can you confirm that this is not a virus or other malware? I'm not likely to bring my machine into the company network until the "virus" is cleaned up.

    Meaning if it's not a virus, I'd better stop "cleaning up".


    John Saunders
    WCF is Web Services. They are not two separate things.
    Use WCF for All New Web Service Development, instead of legacy ASMX or obsolete WSE
    Use File->New Project to create Web Service Projects

    Friday, April 17, 2015 1:44 PM
  • The units that are experiencing it for us, have reported zero virus/malware from several scanners. Added to the fact that the person above has been able to reproduce it makes me think it is not a virus/malware 

    Now obviously I cannot 100% say this is the case for your situation John but hopefully it is an issue with the software itself.

    Monday, April 20, 2015 8:22 AM
  • Thanks, Dave. I was hoping to hear from Microsoft on this, and so are my employers; I see no viruses after scanning my machine, and they'd rather see none on their internal network.


    John Saunders
    WCF is Web Services. They are not two separate things.
    Use WCF for All New Web Service Development, instead of legacy ASMX or obsolete WSE
    Use File->New Project to create Web Service Projects

    Monday, April 20, 2015 11:37 AM
  • FYI, I can't really use Outlook until this is resolved. It uses up to 5MB/sec of disk I/O to these .etl files. And has begun to create 50MB files.

    BTW, when I attempt to open one of the 50MB .etl files, I get an error from Windows Performance Analyzer saying that 109993 events and 5 buffers have been lost.

    Also, do you need one of these files to help you diagnose the problem?

    I miss Outlook.


    John Saunders
    WCF is Web Services. They are not two separate things.
    Use WCF for All New Web Service Development, instead of legacy ASMX or obsolete WSE
    Use File->New Project to create Web Service Projects



    Monday, April 20, 2015 10:41 PM
  • It seems since the latest round of updates, these files do not seem to be generating any further at least for ourselves. I am unsure if this issue has been resolved fully but we are going to monitor the issue for the moment.

    Friday, April 24, 2015 1:17 PM
  • Hi, David,

    Can you say which updates you're referring to? The latest updates on my machine are from 4/16/2015.



    John Saunders
    WCF is Web Services. They are not two separate things.
    Use WCF for All New Web Service Development, instead of legacy ASMX or obsolete WSE
    Use File->New Project to create Web Service Projects

    Friday, April 24, 2015 3:10 PM
  • Hi there,

    Sorry it takes me so long to get back to you on this. Actually I have escalated this one and have been waiting for a response.

    We still have no idea on what's this log file, why it got generated. We have tried to open these .etl file with Network Monitor, found lots of NETEvent traces loged in it. If possible, please share one of the 50 MB file, we will have a further look at it.

    Dave, How is it going? Any new file been monitored?

    Regards,

    Ethan Hua

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here
    Sunday, April 26, 2015 5:57 AM
    Moderator
  • See OTeleData.zip in Dropbox.

    John Saunders
    WCF is Web Services. They are not two separate things.
    Use WCF for All New Web Service Development, instead of legacy ASMX or obsolete WSE
    Use File->New Project to create Web Service Projects

    Sunday, April 26, 2015 9:37 AM
  • Thank you John. We will let you know if we have any update on this.

    Regards,

    Ethan Hua

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Sunday, April 26, 2015 9:43 AM
    Moderator
  • Good Afternoon, 

    I have been monitoring the situation over the past few days, it seems the issue is still there and we do have .etl files being created but the amount created has dropped sharply. Most users now only seem to have one or two 50MB files and the rest are 0.1. Whereas before it would be closer to the image above. 

    I did check the list of updates installed, and none made no mention of these files however the update linked below has been installed but I am unsure of what it does exactly.

    https://support.microsoft.com/en-gb/kb/2825678


    • Edited by Dave-Hall Monday, April 27, 2015 10:13 AM
    Monday, April 27, 2015 8:26 AM
  • Hi,

    KB2825678 only contains file "Oscfb-x-none.msp" which only affect the "Facebookprovider.dll" file (you can find the info under the "File Information" section).

    We have checked the file shared by John, about 544,000 traces for NetEvent were generated in 8 seconds, that might be root cause of the performace issue you've experienced.

    We have done a lot of research on this and the work is still ongoing, however, as of now, we still don't know much about these file.

    By the way, have you installed All the available updates?

    Regards,

    Ethan Hua

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here
    Wednesday, April 29, 2015 10:19 AM
    Moderator
  • Hi there,

    We are suspecting it might be related to the Telemetry, we suggest to add the DisableTelemetry register key to disable the Telemetry feature, and verify result:

    HKEY_CURRENT_USER\Software\Microsoft\Office\Common\ClientTelemetry
    Value name: DisableTelemetry
    Value Data:1

    Let me know if you have any findings.

    Regards,

    Ethan Hua

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here
    • Marked as answer by Dave-Hall Tuesday, November 17, 2015 5:57 PM
    • Unmarked as answer by Chloe WangModerator Tuesday, January 5, 2016 6:36 AM
    Thursday, April 30, 2015 8:10 AM
    Moderator
  • Thanks. This workaround worked. I am not getting any new .etl files generated from Outlook.



    John Saunders
    WCF is Web Services. They are not two separate things.
    Use WCF for All New Web Service Development, instead of legacy ASMX or obsolete WSE
    Use File->New Project to create Web Service Projects

    Friday, May 1, 2015 6:17 PM
  • Hi,

    I'm glad it works.

    Dave,

    Could you please have a try and see if it also works for you? Please let us know if you would like further assistance.

    Regards,

    Ethan Hua

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Monday, May 4, 2015 2:28 AM
    Moderator
  • I've been following this thread because I have the exact same issue on my machine. I've tried this workaround , but, unfortunately, it did not work.

    I still have the outlook.exe process eating away at the memory and occupying one of the CPUs.

    Monday, May 4, 2015 3:45 PM
  • Yes, but do you have the .etl files being created at 50 MB and such. I would call the creation of these files the characteristic of this bug, not the use of CPU time and memory.

    In fact, I did not notice high memory usage on my machine. I noticed the high disk I/O.


    John Saunders
    WCF is Web Services. They are not two separate things.
    Use WCF for All New Web Service Development, instead of legacy ASMX or obsolete WSE
    Use File->New Project to create Web Service Projects

    Monday, May 4, 2015 8:43 PM
  • Actually, I now notice high memory usage in Outlook.exe, and about 12% CPU, which is, strangely, about 1/8 of my eight cores. However, it is not using all the CPU of any one core.

    Still, I'm hardly using Outlook at all, yet I saw it get up to 1.4 GB of commit, as per Resource Monitor. It is currently up to 791 MB Commit, 757 MB Private, 841 MB Working Set, 82 MB shareable.


    John Saunders
    WCF is Web Services. They are not two separate things.
    Use WCF for All New Web Service Development, instead of legacy ASMX or obsolete WSE
    Use File->New Project to create Web Service Projects

    Tuesday, May 5, 2015 12:58 AM
  • I started noticing the heavy disk use about a week ago. Upon investigating I noticed that Outlook.exe was taking up almost all of the memory available which cause the heavy disk use (paging out). After that I restarted Outlook and, after a short while, that behavior came back. The symptoms are:

    1. around 25% CPU for the Outlook.exe process;

    2. Incremental occupation of memory (Private working set) with no apparent limit (I have no time to test whether or not a limit will be reached);

    3. The Outlook.exe process is writing to a .ETL file, but there is only one of these files present at any given time;

    4. because of the lack of free memory the system begins paging which renders my machine virtually useless;

    Have made several attempts to isolate/mitigate the problem (disabled the add-ins, repaired the installation). Nothing seems to work.

    Tuesday, May 5, 2015 8:25 AM
  • Hi,

    In order to avoid confusion and keep track of troubleshooting steps, we usually troubleshoot one specific issue per thread in order to find a resolution efficiently.

    Concerning the specific Outlook performance issue, I would suggest we start a new thread for it.

    Thanks for your understanding.

    Regards,

    Ethan Hua

    Forum Support


    Come back and mark the replies as answers if they help and unmark them if they provide no help.

    If you have any feedback on our support, please click here

    Wednesday, May 6, 2015 9:08 AM
    Moderator
  • Was this ever resolved, or a new thread created somewhere? I am experiencing the same issue as above.

    Excessive .etl files being generated, Outlook.exe using 12~13% CPU, incrementally leaking memory at about 2MB/sec, which takes the process up to about 1~1.1GB of commit, which then causes Outlook to freeze, crash, followed by an unsuccessful attempt to restart.

    Adding Disabletelemetry registry key as mentioned above had no effect. Curious as to root cause/fix and/or status of any ongoing investigations above.

    Wednesday, May 20, 2015 10:57 PM
  • Hi

    I have exactly the same issue, can you help me to solve it please , I tried to make the DisableTelemetry  Registry key but it didn't stop making the 50Mb Otetedata files and this takes %100 of my CPU and memory.

    I appreciate if you help me solve this issue.

    Friday, May 22, 2015 2:39 AM
  • This Workaround worked for me.  Be sure that you are using the right datatypes when creating the key.  I did a DWORD Decimal.  Set it to 1 and restarted.   No more files being created.  

    

    • Proposed as answer by Anakyst Monday, August 24, 2015 4:41 PM
    Wednesday, June 3, 2015 5:39 PM
  • Hi,

    Been following this thread for having a similar problem. The trouble was created somewhere back a month ago, by a regular Windows Update.

    What I found was that Office (2013) Click-to Run Service causes the trouble (I have Office 2010 on my computer, but OneNote 2013 came installed with my Windows 8.1).

    If I manually stop and restart this service the problem goes. However, it returns after turning on the computer or restarting the system.

    Deleting cache files from C:\Users\[username]\AppData\Local\Microsoft\Office\15.0\OfficeFileCache did help for a while, however today, four new updates came (KB2881553; KB2976978; KB2881553 and KB3050267) and this workaround doesn't seem to work any more (stopping and restarting Click-toRun Service still works, though).

    Hope this helps in finding a solution.


    Thursday, June 4, 2015 1:53 PM
  • We are still having this issue and it's having a noticeable IO impact on our Citrix servers.

    I created the DWORD reg entries to ensure logging was disabled and telemetry was disabled, however when I start Outlook after making the changes it resets the 'HKEY_CURRENT_USER\Software\Microsoft\Office\Common\ClientTelemetry\DisableTelemetry' entry back to 0.

    Outlook version is 15.0.4727.1000 MSO 15.0.4727.1001 32 bit

    Wednesday, July 1, 2015 9:45 AM
  • Have a try setting permission on the key, denying set value  right.

    Thierry

    Thursday, July 2, 2015 12:26 PM
  • Please include me in this issue.  Outlook Logging is disabled.  DisableTelemetry REG_DWORD (1) did not fix.

    Any update here or any other threads with possible fixes?

    Wednesday, July 8, 2015 8:01 PM
  • I have the same problem but broken down the problem so that only files with 0 byte in size get created by changing those registry keys:

    [HKEY_CURRENT_USER\Software\Microsoft\Office\Common\ClientTelemetry]
    "DisableTelemetry"=dword:00000001
    "VerboseLogging"=dword:00000000
    
    [HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common]
    "QMEnable"=dword:00000000
    
    [HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Common\Feedback]
    "Enabled"=dword:00000000
    
    [HKCU\Software\Microsoft\Office\15.0\Outlook\Options\Calendar]
    "EnableCalendarLogging"=dword:00000000
    
    [HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Tracing]
    "NoAutoStart"=dword:00000001
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Tracing\SCM\Regular]
    "TracingDisabled"=dword:00000001

    Don't ask me which key exactly is responsible for the change in file size. :D

    Also: WHAT THE ?#!* IS MICROSOFT USING FOR THIS FORUM? The Forum software is ashaming for a company like Microsoft. Billions of Dollars but they are not able to get a forum running that works in Internet Explorer with hardend settings? come on ^^
    And also the usability is so god damn sh!tty it's amazing...


    • Edited by Velocet Thursday, July 9, 2015 6:30 PM $VERSION to 15.0
    Thursday, July 9, 2015 6:22 PM
  • This registry hack did not work for me and outlook - with logging disabled, continues to write OTeleData at around 15,000-300,000 bytes per sec.

    I need to stop this!

    Tuesday, July 28, 2015 3:58 AM
  • Question: our Office365 ProPlus products are all 64-bit so I used a 64-bit reg dword... was this correct?
    OTeleData
    Tuesday, July 28, 2015 5:13 AM
  • We have the same issue here. All the Office apps are generating the .etl files there (Excel, winWord, Outlook, etc).

    Setting DisableTelemetry to 1 has no effect - it is immediately reset to 0 by some process.

    Tuesday, August 4, 2015 5:58 AM
  • This Workaround worked for me.  Be sure that you are using the right datatypes when creating the key.  I did a DWORD Decimal.  Set it to 1 and restarted.   No more files being created.  

    

    This..... We appreciate lucidity and precision. Thank you.

    In addition I am unable to quote your entire reply [specifically the screenshot] because MS needs to verify my account?!?! What a further amount of totally unnecessary time wasting.

    I wish the current crop of millenial programmers had more grey hair! Robust updates are becoming further between.

    Monday, August 24, 2015 4:46 PM
  • Hello!

    Many of our customers use Office 2013 on terminal servers and local PCs - all with this very annoying .etl logging problem described above.

    We see a massive impact on the disk performance in Windows Resource Monitor  - especially on terminal servers with multiple Outlook instances open.

    I tried to fix this with the registry keys described above - without success.

    As you can imagine - reinstallation of every Office 2013 instance is not an option for us.

    Is there any Hotfix available to fix this?
    Office is a core product from microsoft - so I can't understand how something important like this isn't solved yet.

    I hope for a answer very soon.

    Thanks.

    Monday, September 7, 2015 12:11 PM
  • I'm another one with the same problem. None of the fixes have had any effect.
    Friday, September 18, 2015 9:19 AM
  • Hello Mr. Hua!

    Any chance to get a reply or a solution from Microsoft?

    Many people have a big performance problem because of Office 2013 and the not activated - but running error logging!

    Please solve this issue!

    Thanks

    Friday, September 18, 2015 2:38 PM
  • Add another to the list.  Logging not on, DisableTelemetry gets set back to 0 immediately upon restarting Outlook.

    Tuesday, September 22, 2015 12:15 AM
  • Disable Data Logging (Telemetry)

    1. Go to "\AppData\Local\Microsoft\Office\".

    2. Open Properties for the "OTele" folder.

    3. Under the Security tab, edit the permissions:
       Deny all for SYSTEM.
       Deny Write for Administrator.

    4. Apply changes and restart. 
    Sunday, October 4, 2015 3:14 AM
  • Yep one of my customers got the same problem. None of the above "fixes" work
    Thursday, October 8, 2015 11:32 PM
  • with my system all of the .etl files are in the appdata\local\microsoft\office folder. the otele folder is empty. so changing permissions is not a possible solution.

    writing all of this "data" must be microsoft's approach to wearing out all of the SSDs and making windows systems even slower...

    Sunday, October 11, 2015 2:04 PM
  • Running Office 2013 apps (Office 365 Home Premium subscription), I was getting OTeleData*.etl files created regularly in the AppData\Local\Microsoft\Office directory.

    12 days ago, I updated to the Office 2016 apps. No more OTeleData*.etl files are being created.

    I am aware that this thread relates to Office 365 ProPlus, but I thought the feedback might be of some use.



    Friday, October 16, 2015 12:59 PM
  • This issue is still unresolved.

    Outlook version 15.0.4779.1002
    Enable trouble shooting logging was never enabled
    We added the Registry Key HKEY_CURRENT_USER\Software\Microsoft\Office\Common\ClientTelemetry\DisableTelemetry with value REG_DWORD (1) as suggested, but when we start Outlook, this value gets changed to (0)

    The .etl files keep getting created in AppData\Local\Microsoft\Office with high disk IO acitvity as observed through the resource monitor

    The only thing that seems to have changed after adding the registry key is that Outlook now removes the .etl files on exit.

    Wednesday, December 23, 2015 9:59 AM
  • I confirm this issue in Outlook version 15.0.4779.1001 several months are over and still no solution !


    Monday, December 28, 2015 4:13 PM
  • I opened a case at O365 support and got a bad response : Telemetry has been added and can't be removed, it's by design

    To avoid this files and I/Os you will have to migrate to Office 2016 !!!

    I can't upgrade to Office 2016 lot's of plugin's aren't tested and validated for Office 2016 !!!

    The only solution the support could give me was to disable the Antivirus and/or Antimalware scanning of this files !!!

    This is a shame for Microsoft, such a poor support, I didn't ask for un upgarde of Office which includes telemetry ! and I think MICROSOFT HAS TO RELEASE A NEW VERSION WITHOUT TELEMETRY OR WHICH MAKE IT POSSIBLE TO DISABLE TELEMETRY WITH A REG KEY !!!

    • Proposed as answer by SYGMA Network Thursday, December 31, 2015 2:00 PM
    Wednesday, December 30, 2015 1:39 PM
  • Hi,

    This subject can't be marked as answered !

    Disabling Telemetry isn't working anymore, please provide a solution ASAP !

    • Proposed as answer by Raphael GEYER Monday, January 4, 2016 8:11 AM
    Monday, January 4, 2016 8:08 AM
  • Hi Raphael,

    Could you please try following steps and let me know the result, thank you.

    • HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Outlook\Options\Mail

    -       New a DWORD (32-bit) Value EnableLogging ->type  0 under Value data, and then click OK.

    • HKEY_CURRENT_USER\Software\Microsoft\Office\Common\ClientTelemetry

    -       New a DWORD (32-bit) Value DisableTelemetry” -> type 1 under Value data, and then click OK.

    • HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\OSM

    -       New a DWORD (32-bit) Value "Enablelogging" -> type  0 under Value data, and then click OK.

    -       New a DWORD (32-bit) Value "EnableUpload" -> type  0 under Value data, and then click OK.

     

                   Note: After modifying above keys, the first load of Outlook will be very slow.

    Tuesday, January 5, 2016 6:40 AM
    Moderator
  • Hi Chloe,

    Thanks for your help, but I have deployed a GPO with your 4 keys ( used EnableLogging with third key instead of Enablelogging ) but the files are still used and accessed ...

    Do you have any other solution ?

    Tuesday, January 5, 2016 7:39 AM
  • Based on our test, though the files are still generating but it reduced the impact of the hard drive performance. Could you confirm?
    Tuesday, January 5, 2016 8:25 AM
    Moderator
  • I can't confirm, I don't have enought metrics.

    But based on ressource monitor I can't see any différence.

    Tuesday, January 5, 2016 8:56 AM
  • Emm, I'm still researching.

    It is a very long thread, so forgive me if I asked the questions that has been asked already. Have you disabled the logging of Outlook before modifying those registry entries?

    Tuesday, January 5, 2016 9:51 AM
    Moderator
  • Yes logging is disabled.

    The Office 365 support pretend that Telemetry can't be disabled anymore because it's "by design" and that the only solution is upgrading to Office 2016 !!! (not everybody has time and the possibility to do that or will do that just because à buggy office version has been released)

    Tuesday, January 5, 2016 9:17 PM
  • Understood. I have been and am still checking, but didn't get any avail yet. Will keep you posted. Thank you.
    Wednesday, January 6, 2016 2:36 AM
    Moderator
  • One more thing I want to check with you, is "Turn on the Office Feedback Tool(Send a Smile) so that I can send feedback to help improve Office" enabled?
    Thursday, January 7, 2016 3:03 AM
    Moderator
  • Sorry for the delay, NO this option isn't checked and is greyed.

    Tuesday, January 12, 2016 10:09 AM
  • I set the registry keys on our terminalserver - no change - outlook is still logging.
    The Office Feedback option is also greyed out and disabled.

    There is still a massive performance impact - and the server is running on SSD!

    Any other solution?

    Thursday, January 14, 2016 10:30 AM
  • Arggg, SSD was my last solution, @D0m1n1k2015 do you have a real performance impact also with SSD's ?

    It's unbelievable that such a BUG is still not corrected after month by Microsoft, as said before it's a shame not to have more respect for customers.

    Thursday, January 14, 2016 3:37 PM
  • The Performance is far better on SSD storage but on the terminalserver i always see in the resource monitor 3-5 oteledata.etl tasks per user.

    Imagine 10 people working with office on one server - performance is gone...
    I also don't unterstand why microsoft has no solution yet - it seems to be a apple like killer update to force migration to office 2016 - very bad customer support.

    I really want to post a screenshot of my resource monitor but still not verified - thanks again microsoft.

    greetings!

    Friday, January 15, 2016 9:28 AM
  • I'm running into the same issue, any resolution yet apart from changing the disk? I have tried all the work around above and didn't work.

    Wednesday, January 27, 2016 3:02 AM
  • Microsoft is playing dead, month are over and nothing is changing... pay for using our service but don't ask too much support... the answer giving to me was it's by design it can't be changed you will have to upgrade to Office 2016 which corrects the problem !

    I can't accept such an answer but I can't do anything ...it's a shame ...

    • Proposed as answer by nidentify Wednesday, February 3, 2016 5:20 AM
    Monday, February 1, 2016 2:59 PM
  • I encountered the same performance issue by .etl-files in the office folder mentioned in the first post of this thread. Watching the performance monitor I suspected CSISYNCCLIENT.EXE to be using these files. In another discussion on this .exe-file it was also related to a loss of performance. This was not truely solved, but I tried the proposed renaming into "CSISYNCCLIENTa.exe" to prevent the file from being started.

    I experienced a significant performance boost without any problems occuring so far in other tasks or programs. etl-files were not created since the renaming. The performance monitor shows no more overflowing blocking action on the hard drive. 

    CSISYNCCLIENT.EXE is found in C:\Program Files\Microsoft Office 15\root\vfs\ProgramFilesCommonX64\Microsoft Shared\OFFICE15 in my case, but simply search for it in explorer as I found two instances in seperate locations.

    I hope this also works for someone else...

    Monday, February 8, 2016 7:34 AM
  • We are encountering the same issue with fully up-to-date RDS2012 and Office2013. I tried all the suggestions above like registry keys, disable mail logging, renaming the EXE (it's created again, so renaming won't make sense)

    Has any one mentioned to solve or locate this issue already?

    • Proposed as answer by Olivier Rihoux Thursday, February 18, 2016 10:25 AM
    • Unproposed as answer by Olivier Rihoux Thursday, February 18, 2016 10:25 AM
    • Proposed as answer by Olivier Rihoux Thursday, February 18, 2016 10:25 AM
    • Unproposed as answer by Olivier Rihoux Thursday, February 18, 2016 10:26 AM
    Tuesday, February 16, 2016 11:54 AM
  • I encountered the same problem of bad performances in Word just after having installed Visio.

    When installing Visio, one of the item proposed in Office Tools is : Office Telemetry which is installed by default.

    I tried all solutions suggested hereabove without any success.

    Now, i made again full install of Office and Visio without Office telemetry and everything worksd fine.

    So, perhaps making just a reinstall/repair of Visio without Telemetry could be enoug to solve the problem ?

    Good Luck

    Thursday, February 18, 2016 10:30 AM
  • Same issue here with a customers Azure Server 2012 R2 RDS Server running Office 2013 Standard 32bit (15.0.4771.1001).

    Thursday, February 25, 2016 2:58 PM
  • I encountered the same problem of bad performances in Word just after having installed Visio.

    When installing Visio, one of the item proposed in Office Tools is : Office Telemetry which is installed by default.

    I tried all solutions suggested hereabove without any success.

    Now, i made again full install of Office and Visio without Office telemetry and everything worksd fine.

    So, perhaps making just a reinstall/repair of Visio without Telemetry could be enoug to solve the problem ?

    Good Luck

    I have Office Pro Plus 2013 on my desktop and just removed Office Telemety. As soon as I launch any Office application an .etl file is created.

    Thursday, February 25, 2016 3:20 PM
  • I have done some testing and the DisableTelemetry reg key works on my desktop with Windows 8.1 / Office 2013 Pro Plus installed. If i create the key and launch Outlook no ETL files are created, delete the key and launch and instantly .elt file created.

    However the same key doesn't work on the 2012 R2 RDS server. I have rolled out the key via GPO and also loaded a user reg hive to confirm it exists in the correct place but Outlook seems to ignore it. Any ideas?

    Thursday, February 25, 2016 5:02 PM
  • My fix to this issue was to deny write (to my user) for the directory where the .etl files are written.
    Sunday, March 6, 2016 6:48 PM
  • Which now seems to NOT be a fix, as the files ARRE back.
    Tuesday, April 12, 2016 10:13 PM
  • Months are over and still no solution, thank's Microsoft your are so professional...
    Wednesday, July 6, 2016 7:29 AM
  • Deleted
    Tuesday, August 2, 2016 9:54 PM
  • Hi,

    we also are facing this issue on several computers.

    On mine it takes up to 57 minutes to start Outlook and another 57 minutes to shut down outlook.

    This cannot be a wanted behavior in the eyes of microsoft.

    RegKeys are set, Outlook 2013 and Skype for Business 2015 logging is disabled , Windows 7 rebooted.

    Nevertheless files are kept being created.

    This is so frustrating...

    regards

    Uli


    Friday, August 26, 2016 3:58 PM
  • Any update?
    Friday, November 4, 2016 3:37 PM
  • Any update on this, it is an old post and it is still happening.  Need a fix ASAP

    James - Right Size Solutions

    Wednesday, December 14, 2016 3:41 PM
  • Hi,

    somewhere here is the right answer, i also have win 2012 r2 remote desktop, so, after creating registry "hack" for user, you must login as administrator before user launch outlook and set permision on that key only for read. To do this run regedt32, navigate to HKEY_USERS\ find right user key, then key \ClientTelemetry, disable permissions inheritance and now you can set for that user read only. Restart server.

    Tom

    Monday, December 19, 2016 8:38 PM
  • I realize this is an old post, but if anyone is still trying to figure this one out I believe I have found the solution. 

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Office\Common\ClientTelemetry]
    "DisableTelemetry"=dword:00027100

    You may have noticed if you set this value to 1, as recommended everywhere, it is reverted to 0 on Outlook launch. This doesn't occur with the above value and the .etl files are not created. 

    From here, I just created a GPO to enforce the above key for all users




    Friday, July 6, 2018 8:02 AM
  • thanks.

    perfect tips!

    Friday, September 7, 2018 8:43 AM