none
Windows Time Service error 1290 RRS feed

  • Question

  • I have been having problems with the time service on my windows 2008 server from day one.  Now I am getting:

    System error 1290 has occurred.

    The service start failed since one or more services in the same process have an incompatible service SID type setting. A service with restricted service SID type can only coexist in the same process with other services with a restricted SID type. If the service SID type for this service was just configured, the hosting process must be restarted in order to start this service.

    This occured after I changed the service to Local System instead of Local Service.  It complained that it wasn't allowed to run as Local System.  So I unregistered the dll and registered.  The setting was restored to Local Service, but now I am getting this error message and am hesitant to just blindly reboot.  I have looked for other articles on this and they claim to adjust the tapisrv image path from tapisrv to NetworkService.  If I was on a client machine I would do it, but this is the Operation Master server for everything.

    I tried to restart most services, but it still didn't help.

    Thank you for any assistance you can offer.

    Thursday, December 16, 2010 3:46 PM

Answers

  • Hi,

    Windows Time service is running in a shared service process, known as svchost. There is a group of services sharing the same SvcHost process as the Windows Time service and the services must run under the same credential -- Local Service, by default. As a result, the service may not be able to start after you change the logon credential.

    In this case, please ensure that all services in the same service group as Windows Time service are running under the same credential. The following is the list of the services for your reference:

    lltdsvc
    NSI
    SSDPSRV
    upnphost
    SCardSvr
    w32time
    EventSystem
    RemoteRegistry
    WinHttpAutoProxySvc
    lanmanworkstation
    TBS
    SLUINotify
    THREADORDER
    fdrespub
    SstpSvc
    netprofm
    fdphost
    WebClient

    Hope it helps.
     


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, December 17, 2010 6:13 AM
    Moderator

All replies

  • Hi,

    Windows Time service is running in a shared service process, known as svchost. There is a group of services sharing the same SvcHost process as the Windows Time service and the services must run under the same credential -- Local Service, by default. As a result, the service may not be able to start after you change the logon credential.

    In this case, please ensure that all services in the same service group as Windows Time service are running under the same credential. The following is the list of the services for your reference:

    lltdsvc
    NSI
    SSDPSRV
    upnphost
    SCardSvr
    w32time
    EventSystem
    RemoteRegistry
    WinHttpAutoProxySvc
    lanmanworkstation
    TBS
    SLUINotify
    THREADORDER
    fdrespub
    SstpSvc
    netprofm
    fdphost
    WebClient

    Hope it helps.
     


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, December 17, 2010 6:13 AM
    Moderator
  • Hi,

    How's everything going? Please let me know if you need further assistance.

    Thanks.


    This posting is provided "AS IS" with no warranties, and confers no rights. Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, December 27, 2010 5:08 AM
    Moderator
  • I am having the same problem.  I carefully went through the whole list of processes above, and

    all of them are set to run as Local Service.  However, not all of them are running.  I am not sure if that is a problem.

    Any further help would be appreciated.

    Regards,

    Harold Naparst


    Harold Naparst
    Thursday, March 10, 2011 8:49 AM
  • I also am having the same problem on three brand new Dell desktops running Windows 7 Pro. I've been struggling for weeks with this and Dell have not been able to help. Can you assist?

    Cheers,

    Greg.

    Saturday, November 26, 2011 12:09 AM
  • Troubleshooting an unrelated issue, I think I've finally found the solution to this error (sometimes, rebooting also fixes this specific error). See the underlined command below, and mind the required space between = and own. The command puts the w32time service in it's own svchost process, so it doesn't have to share the process with other services which may have been configured with an service SID type incompatible with w32time's.

    Running the following from an elevated command prompt seems to be a pretty surefire way to fix your Windows Time service.

    pushd %SystemRoot%\system32
    .\net stop w32time
    .\w32tm /unregister
    .\w32tm /register
    .\sc config w32time type= own
    .\net start w32time
    .\w32tm /config /update /manualpeerlist:"0.pool.ntp.org,1.pool.ntp.org,2.pool.ntp.org,3.pool.ntp.org",0x8 /syncfromflags:MANUAL /reliable:yes
    .\w32tm /resync
    popd
    • Proposed as answer by VBdP Thursday, November 1, 2012 1:42 PM
    Thursday, November 1, 2012 1:42 PM
  • I was battling with this for some time. I found VBdP's solution allowed the Windows-Time service to start, but following that, any w32tm /query or w32tm /resync commands would return "Access Denied', regardless of CMD elevation and various local/domain administrator account used. I even ran CMD as the SYSTEM, Scheduled Tasks, etc., and I still got Access Denied.

    The only solution I found for the Access Denied issue was to replace the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\w32time key with one from another machine, followed by a restart. I've tested this on half-a-dozen machines and the results are always the same.

    The other solution, which I found here, worked in all cases and (I found) was a little faster. 

    The strange thing about this solution is that the image path (%SystemRoot%\System32\svchost.exe -k NetworkService) is already in place, but re-applying it and then restarting the machine definitely works. 

    Thanks to all for your knowledge and sharing. 

    1. Click Start, type regedit in the Start Search box, and then click regedit.exe in the Programs list. 
      If you are prompted for an administrator password or for a confirmation, type your password, or click Continue.
    2. Locate the following registry subkey, and then click it:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TapiSrv
    3. In the details pane, right-click ImagePath, and then click Modify.
    4. In the Value data box, type the following registry value, and then click OK:
      %SystemRoot%\System32\svchost.exe -k NetworkService
    5. Exit Registry Editor, and then restart the computer.
    Thursday, October 24, 2013 1:07 AM
  • To Fix “System error 1290 has occurred.” error on Windows, please type in this to your command prompt:

    sc config w32time type= own

    I have same issue and this command worked.

    Good Luck!

    --- Network Security Administrator

    • Proposed as answer by Lansend Tuesday, April 18, 2017 9:49 PM
    Monday, November 18, 2013 6:44 PM
  • Had a problem with syncronising with windows time in an upgrade of Win10. Tried many different ideas. What really solved the problem was the "own" command, and the next line using a manualpeerlist etc.....

    A VERY annoying problem solved.

    Thanks,

    Saturday, August 8, 2015 11:24 AM
  • sc config w32time type= own

    This worked perfectly for me.  Thanks ICHIBOI!

    • Edited by gravlaxy Thursday, February 4, 2016 10:45 PM
    Thursday, February 4, 2016 10:44 PM
  • This did it for me.  Very helpful.
    Tuesday, January 24, 2017 4:13 PM
  • ICHIBOI solution worked for me . Thank you

    sc config w32time type= own

    • Edited by Lansend Tuesday, April 18, 2017 9:50 PM
    Tuesday, April 18, 2017 9:49 PM
  • Thanks a Mill ICHIBOI

    Issue solved!!!

    Wednesday, August 16, 2017 9:05 AM
  • Thank you so much .It worked for me
    Thursday, April 5, 2018 12:24 PM
  • Thank you so much, ICHIBOI!

    Too bad the moderator claimed the kudo's for himself...

    Sunday, April 8, 2018 10:48 PM
  • This worked for me! THANK YOU!!! I tried every solution I could find on the internet for 2 days, and got "access denied" and error messages. I never had to type a command with "own" in it, so I never would have found this on my own. I'm a novice compared to you guys.

    ikonoklast61

    Monday, June 25, 2018 12:06 AM