none
Folders Not Showing In Internet Explorer 10 Protected Mode RRS feed

  • Question

  • Ok, this question has been asked around many corners of the Internet and these forums and I haven't found a "real" answer so I'm asking it again and hopefully seeking a final resolution to the problem.

    Symptoms

    • When "Protected Mode" is turned On, users are unable to view some folders in the file upload dialog that they can normally view (e.g. under Documents, Pictures, etc.).
    • When viewing the same folders in Explorer running as the same user as the Internet Explorer instance, the missing folders are viewable.
    • Launching Internet Explorer "as an administrator" allows the user to view the missing folders (but this is not recommended due to security concerns).

    Workarounds

    So far, the workaround that I found was to either run some crazy tool from BleepingComputer called Unhide that resets everything on your system -- this is the sledge hammer-to-thumbtack approach.  Another one was to go into Organize > Folder and search options > View and uncheck the hide options and select the show radio option.  The last one was to search for the folder in the file upload dialog, right-click the folder, and uncheck Hidden.

    None of these, IMHO, are valid solutions to the real problem which is that something is special about this folder that is causing IE in Protected Mode to treat the file as Hidden.

    Thoughts

    The last "workaround" seems to indicate that the "hidden" file attribute is set for the file, but this doesn't appear to be true if you view the file outside of Protected Mode security.  If you right-click the folder within Explorer or you run ATTRIB, the file attributes appear normal.

    What I'm thinking is that there is an extended attribute associated with this file that is not normally viewable in the file properties dialog.  Similar to the "temporary" file flag that gets set with some files that causes DFSR to not replicate them.  However, when I look at the File Attributes with fsutil, both folders (one that is shown and one that isn't shown under Protected Mode) are 0x10 (which is simply DIRECTORY).  I also verified the same with PowerShell looking at the Attributes property of the directory (System.IO.FileAttributes object): the value__ is 16 which is 0x10 (DIRECTORY).

    So, it seems that the process of displaying folders (and possibly files) in either Protected Mode or the common dialog for file selection uses something other than the file attributes when determining what is displayed and not displayed.

    Any help with this is greatly appreciated.

    System info:

    • Internet Explorer 10.0.9200.16635; Update Versions: 10.0.7 (KB2846071)
    • Windows 7 Enterprise SP1 (6.1.7601) 64-bit
    • 4 GB RAM
    • Intel Core2 Duo T8100
    Monday, July 29, 2013 10:15 PM

All replies

  • Libraries are different from folders(directories). Please detail your reproduction steps with the folder names and whether they are shared on the local network or local machine.

    IE has a security zone setting for "Include local path in file uploads'... by default only the intranet zone is enabled. the 'File upload' controls in web pages can specify the file extensions that are displayed in the common dialog... You may be using a third-party 'file upload' control in your web pages. type *.* in the file upload 'File selection' dialog to display all files.

    Regards.


    Rob^_^

    Monday, July 29, 2013 10:31 PM
  • All files are on the local system.  No network drives.

    The folders that are visible and missing are in the user's Documents folder.

    Renaming the folder shows the folder.  Naming it back to the original name hides it again.

    Your thought on the control being used was my first thought as well, so I went to a site that used the generic/built-in Browse control which calls the common file selector dialog.

    This issue holds true when viewing the Documents library or the "My Documents" folder directly.

    • Edited by HossyMatch Monday, July 29, 2013 10:59 PM added info
    Monday, July 29, 2013 10:51 PM
  • Hi,

    can you provide a screen shot please....

    see also http://dev.w3.org/html5/markup/input.file.html

    <input type="file" id="filUpload" accept="image/jpeg"/>


    Rob^_^

    Tuesday, July 30, 2013 2:46 AM
  • Hi,

    From your post, I know that you cannot see some folders in user Document in file upload dialog when running IE in protected mode. But you can see these folders in IE instant? and IE run as administrator.  

    First, please help to clarify following questions:

    1. Which site did you want to upload files and see this issue? Would you please try whether this issue still persists in SkyDrive?

    Upload photos and files

    http://windows.microsoft.com/en-IN/skydrive/add-photos-files-faq

    2. Would you please let your friends try what you did to upload files on their own PCs to check the results? And also, can you see the missing folders when you try to upload files on another computer?

    3. Did this issue happened after some changes were made on your computer, like installing updates for IE or some add-ons?

    4. Please help to post the screenshot for your problematic file upload dialog.

    By the way, I have tried to upload files from documents onto several website by using IE in protected mode, IE instance, and IE run as administrator, there is no difference among these file upload dialogs.

    In order to avoid 3rd part add-ons preventing,  I suggest we try to disable all 3rd part add-on to check the issue:

    Manage add-ons in Internet Explorer

    http://windows.microsoft.com/en-IN/internet-explorer/manage-add-ons#ie=ie-10

    Please also test this issue under new user account:

    Test in New user account:

    Create a user account

    http://windows.microsoft.com/en-in/windows/create-user-account#create-user-account=windows-7

    Please take time to perform above troubleshooting steps and let me know the results.

    Hope these could be helpful and look forward to your response.


    Best Regards, StarSprite


    • Edited by StarSprite Thursday, August 1, 2013 1:14 AM format
    • Marked as answer by Cloud_TSModerator Monday, August 5, 2013 2:05 PM
    • Unmarked as answer by HossyMatch Wednesday, August 7, 2013 4:54 PM
    Thursday, August 1, 2013 1:11 AM
  • What security suites do you have installed along with any prior installed ones ?
    Thursday, August 1, 2013 3:08 PM
  • Hi Rob,

    I don't know if a screenshot is absolutely necessary.  Just imagine you have a folder with 4 items in it and under IE with Protected Mode you only see 3 of them. :-)

    The same holds true whether I'm using a flash module for upload or a standard INPUT file tag.


    • Edited by HossyMatch Wednesday, August 7, 2013 4:59 PM spelling
    Wednesday, August 7, 2013 4:54 PM
  • Hi StarSprite,

    Thanks for your detailed reply.  This is not unique to SkyDrive and wasn't the first couple places I noticed this.

    I have tried disabling all add-ons for IE and the problem persists.

    I'm interested to know why you want to test a new user account since this issue is specific to IE.  What is it you think is corrupt and how would I go about fixing/resetting it?  I believe that testing with a new user account would defeat the problem because no folders exist for the new user and the new user wouldn't be able to access the first user's folders.  Even granting permissions could present potential issues that would corrupt the test results.

    Wednesday, August 7, 2013 4:57 PM
  • I have MS Security Essentials installed.  Nothing prior to that.
    Wednesday, August 7, 2013 4:58 PM
  • 1. http://www.w3schools.com/tags/tryit.asp?filename=tryhtml_input_accept

    2. I tried another PC and didn't have an issue, but I also don't have UAC enabled.  I can see if I can get some more tests, but it's difficult to test because I have to manually count how many files/folders and compare that to the directory outside IE.

    Keep in mind that the folder is still accessible under IE Protected Mode if typed in manually, it's just hidden from view.

    3. Not sure, unfortunately.  It's my mom's computer and she doesn't do much of this type of thing.

    4. There is a folder in the "My Pictures" folder that starts with Lo.  While I am showing you the Library Pictures here, the same shows for viewing My Pictures directly.

    Upload Dialog

    Wednesday, August 7, 2013 7:14 PM
  • Click on the 2 Locations link,

    Remove Both,

    Then right click the Libraries listing and Restore default libraries.

    Wednesday, August 7, 2013 10:27 PM