locked
Can't connect Outlook 2016 to Exchange 2016 RRS feed

  • Question

  • Dear experts,

    This is getting pretty frustrating. I'm testing Exchange 2016  but can't get Outlook 2016 to connect to it. Setup as follows:

    Exchange Server 2016 - installed on Windows 2012 R2

    Outlook 2016 - installed on Windows 10

    Already configured internal & external url to points to single url: mail.abc.com.my

    Testing is done in private network without internet connection.

    Check autodiscover seems to be working. opening the web https://mail.abc.com.my/autodiscover/autodiscover.xml shows a website with ErrorCode 600 and Invalid Request which is correct

    Check dns seems to be ok. Able to resolve the hostname for the AD, Exchange 2016, Win10, mail.abc.com.my.

    Already added CNAME and MX for mail.abc.com.my 

    Problem is when add new account in Outlook 2016, it hit an error when Logging on to the mail server with error message "The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action"

    Can someone help me on this issues?


    • Edited by ks638 Wednesday, March 9, 2016 8:17 AM
    Wednesday, March 9, 2016 8:14 AM

Answers

All replies

  • As I have written is this thread, I am also facing this issue you have, so i reinstalled the whole domain in my lab, all worked, but know, suddenly, it stopped again:

    https://social.technet.microsoft.com/Forums/office/en-US/63807548-292a-45ad-aa46-cef48e5ac1a9/outlook-2016-connect-to-exchange-2016-failed-via-mapi-over-https-autodiscovery?forum=Exch2016CM

    help help help!

    Wednesday, March 9, 2016 7:58 PM
  • Hi Ks638,

    Please use the Microsoft Remote Connectivity Analyzer to run outlook connectivity tests and check if any errors.

    Moreover, I also recommend you refer to the following article and check if any helps:

    Outlook connection issues with Exchange mailboxes because of the RPC encryption requirement

    Outlook: Unable to perform a Check Name or connect to an Exchange mailbox

    Best regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Niko Cheng
    TechNet Community Support

    • Marked as answer by Niko.Cheng Thursday, March 17, 2016 10:47 AM
    Thursday, March 10, 2016 8:04 AM
  • Hi ks638,

    I had the same issue, Outlook was prompting users for username and password when I moved a mailbox from Exchange 2010 to the new exchange 2016 server. The fix for me was to edit the authentication settings for the mapi virtual directory in the Exchange Admin center. I enabled Windows Authentication -NTLM, Negotiate and Basic. Outlook clients could then connect and I could proceed with the migration. Hope that helps someone.

    • Proposed as answer by Steamerson Thursday, December 15, 2016 4:07 AM
    Thursday, December 1, 2016 6:00 AM
  • Hi ks638,

    I had the same issue, Outlook was prompting users for username and password when I moved a mailbox from Exchange 2010 to the new exchange 2016 server. The fix for me was to edit the authentication settings for the mapi virtual directory in the Exchange Admin center. I enabled Windows Authentication -NTLM, Negotiate and Basic. Outlook clients could then connect and I could proceed with the migration. Hope that helps someone.

    Dude... you just solved the issue I have been fighting for a week. BRAVO!
    Thursday, December 15, 2016 4:08 AM
  • Hi ks638,

    I had the same issue, Outlook was prompting users for username and password when I moved a mailbox from Exchange 2010 to the new exchange 2016 server. The fix for me was to edit the authentication settings for the mapi virtual directory in the Exchange Admin center. I enabled Windows Authentication -NTLM, Negotiate and Basic. Outlook clients could then connect and I could proceed with the migration. Hope that helps someone.


    Best answer ever , you saved my day , after 6 hours searching , thanks
    Wednesday, February 22, 2017 7:29 PM
  • Hi ks638,

    I had the same issue, Outlook was prompting users for username and password when I moved a mailbox from Exchange 2010 to the new exchange 2016 server. The fix for me was to edit the authentication settings for the mapi virtual directory in the Exchange Admin center. I enabled Windows Authentication -NTLM, Negotiate and Basic. Outlook clients could then connect and I could proceed with the migration. Hope that helps someone.


    Mate fixed it for me too  :-) I got this issue after applying a wildcard certificate, everything worked external but nothing internal worked.  interesting outlook 2010 worked inside and external but 2016 outlook stopped completely.   Thanks for posting!!!
    Thursday, July 6, 2017 12:20 PM
  • Hi ks638,

    I had the same issue, Outlook was prompting users for username and password when I moved a mailbox from Exchange 2010 to the new exchange 2016 server. The fix for me was to edit the authentication settings for the mapi virtual directory in the Exchange Admin center. I enabled Windows Authentication -NTLM, Negotiate and Basic. Outlook clients could then connect and I could proceed with the migration. Hope that helps someone.

    Hi.

    I have the same problem but i do not have a MAPI virtual directory, i have Autodiscover, ECP, EWS, EAS, OAB, OWA and Powershell.

    Am i looking in the wrong place?

    I run Exchange 2016 and Outlook 2016.


    • Edited by Peter Glas Monday, August 21, 2017 6:29 AM
    Monday, August 21, 2017 6:22 AM
  • Hi ks638,

    I had the same issue, Outlook was prompting users for username and password when I moved a mailbox from Exchange 2010 to the new exchange 2016 server. The fix for me was to edit the authentication settings for the mapi virtual directory in the Exchange Admin center. I enabled Windows Authentication -NTLM, Negotiate and Basic. Outlook clients could then connect and I could proceed with the migration. Hope that helps someone.

    Thank you, thank you, thank you!!!!!! Steamerson. I spent a week trying to resolve this after migrating from Exchange 2013 to 2016 which worked fine until I decommissioned the Exchange 2013 server. Huge oversight by Microsoft here with nothing about it in the documentation or Exchange Server Deployment Assistant.
    Wednesday, October 18, 2017 12:41 AM
  • Dude.  You are a life saver!  Anyone know why it needs basic auth to begin with?
    Tuesday, December 5, 2017 7:17 PM
  • Hi ks638,

    I had the same issue, Outlook was prompting users for username and password when I moved a mailbox from Exchange 2010 to the new exchange 2016 server. The fix for me was to edit the authentication settings for the mapi virtual directory in the Exchange Admin center. I enabled Windows Authentication -NTLM, Negotiate and Basic. Outlook clients could then connect and I could proceed with the migration. Hope that helps someone.

    Thanks man! Solved one of my issues as well. I am now left with the same error that pops up when users are having their mailbox still on exchange 2010 (and the mail front end on exchange 2016). Any ideas on that one!?

    Thanks, Ronald


    BR, Ronald

    Sunday, January 7, 2018 1:21 PM
  • Sadly the remote connectivity tool does not work at all. It fails to verification thing in all different browsers I have tried.
    Monday, December 10, 2018 9:00 AM