connection problem on VPN due to RAS/VPN policy/ Error 812 RRS feed

  • Question

  • hi

    We are on microsoft azure and this problem came up. IT was working fine yesterday

    The connection was prevented because of a policy configured on your RAS/VPN server. Specifically, the authentication method used by the server to verify your username and password may not match the authentication method configured in your connection profile. Please contact the Administrator of the RAS server and notify them of this error. (Error 812) For customized troubleshooting information for this connection, click Help.

    Wednesday, August 8, 2018 12:40 PM

All replies

  • We also use the Windows Azure Virtual Network VPN and get the same issue spontaneously starting from a couple hours ago. We noticed it affects Windows 8.1 and server 2012 machines but windows 10 users can still connect. Possibly related to some change MS made, and tested only on their latest OS offering?

    - Pete

    Wednesday, August 8, 2018 2:00 PM
  • Any progress on this?  I've come up with the same error.  Been messing with it all day.  Doesn't affect Win10, but does affect older OSes (Win 7 and 8).
    Thursday, August 9, 2018 3:39 AM
  • Hi,

    Thanks for your question.

    Generally, error 812 may occur when VPN client couldn't match NPS policies or the user account isn't allowed to connect, or the authenticate method used on client is not same with it configured on server.

    On clients, we could only check if the user account is correct, if the authenticate method is the same with server, if the related certificate is installed.

    Best regards,


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, August 9, 2018 6:10 AM
  • Hello.. 

    about Error 812 connecting vpn to Azure on win7

    This problem may also generate error 0x80090331

    solved by following instruction in link:


    In short:

    Open a command prompt with elevated priveleges by right-clicking on Command Prompt and selecting Run as administrator.
    Run the following commands in the command prompt:

    reg add HKLM\SYSTEM\CurrentControlSet\Services\RasMan\PPP\EAP\13 /v TlsVersion /t REG_DWORD /d 0xfc0
    reg add "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp" /v DefaultSecureProtocols /t REG_DWORD /d 0xaa0
    if %PROCESSOR_ARCHITECTURE% EQU AMD64 reg add "HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp" /v DefaultSecureProtocols /t REG_DWORD /d 0xaa0

    Install the following updates: (if needed)


    Reboot the computer.

    Connect to the VPN.

    Best Regards.


    • Proposed as answer by PeterAllebone Thursday, August 9, 2018 1:01 PM
    Thursday, August 9, 2018 6:44 AM
  • Thanks Johan, your solution fixes the issue.
    Thursday, August 9, 2018 1:01 PM
  • Hi,

    Was your issue resolved?

    If you resolved it using our solution, please "mark it as answer" to help other community members find the helpful reply quickly.

    If you resolve it using your own solution, please share your experience and solution here. It will be very beneficial for other community members who have similar questions.

    If no, please reply and tell us the current situation in order to provide further help.

    Best Regards,


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, August 13, 2018 9:21 AM
  • I 'd the same error.

    This was perfect for me ! thanks Johan !

    Tuesday, August 28, 2018 12:27 PM
  •  i did the same, but issue still not resloved. run TLS script in cmd, installed aboves updates but haveing same error.

    Can i edit VPN client settings there is no option in windows 7

    Thursday, September 6, 2018 3:43 PM
  • Thank you for this, the solution worked as expected.
    Tuesday, July 16, 2019 3:26 PM