none
Java not working in Internet Explorer

    Question

  • I normally use another browser (Google Chrome) but need to use Internet Explorer for a particular online banking service. This service requires a Java applet.

    I have the current Java environment (as at 21.3.12), SE 6 Update 31.

    Java works in Chrome but does not work in IE8 or IE9.

    I have un-installed and re-installed Java several times, tried going back to IE8, turned off ActiveX filtering, confirmed Java scripting is on, checked add-ins are managed correctly and so on and so on, without success. Given Java works it is not a Java issue but must be an IE issue.

    Are there any additional steps or diagnostics I can run to try to identify the problem as I need this to be resolved for the purposes of running my business.

    Many thanks!

    Wednesday, March 21, 2012 12:19 PM

Answers

  • Please go here as Java 7 I know works too which OS do You have if You have 64 bit make sure 64 bit Java and I would reccommend IE 9 it works good even the beta if it is still beta. Here is Java 7 :

    http://java.com/en/download/faq/java7.xml

    Should solve prob but check 32 or 64 please.

    Later

    CatBurlgerV8


    Thank You Very Much Very Sincerely CatBurglerV8

    • Marked as answer by AJCottrell Wednesday, March 28, 2012 12:32 PM
    Saturday, March 24, 2012 5:01 AM

All replies

  • Hi,

    Can you please try launching IE with Protected Mode disabled.


    Juke Chou

    TechNet Community Support

    Friday, March 23, 2012 7:12 AM
    Moderator
  • Please goto : http://www.java.com/en/about/ and download New Java as I remember span of life for Java 6 it is now Java 1.7 update 4 or better the internals are now better and faster it seems I have not had much time but EOL of Java 6 is here or soon. Get New JRE (Java Runtime Enviroment) JRE 7.

    Good Day


    Thank You Very Much Very Sincerely CatBurglerV8

    Saturday, March 24, 2012 1:57 AM
  • If only for kicks...

    IE9: ALT+T+O | Advanced | Do not save encrypted pages to disk <=try unchecking/disabling this option

    cf. http://support.microsoft.com/kb/2549423


    ~Robear Dyer (PA Bear) ~ MS MVP (IE, Mail, Security, Windows & Update Services) since 2002 ~ Disclaimer: MS MVPs neither represent nor work for Microsoft

    Saturday, March 24, 2012 2:32 AM
  • Please go here as Java 7 I know works too which OS do You have if You have 64 bit make sure 64 bit Java and I would reccommend IE 9 it works good even the beta if it is still beta. Here is Java 7 :

    http://java.com/en/download/faq/java7.xml

    Should solve prob but check 32 or 64 please.

    Later

    CatBurlgerV8


    Thank You Very Much Very Sincerely CatBurglerV8

    • Marked as answer by AJCottrell Wednesday, March 28, 2012 12:32 PM
    Saturday, March 24, 2012 5:01 AM
  • Just found out might have a virus in Java 6 cache go here and use remove older versions of Java , Might help, here is URL:

    http://java.com/en/download/help/cache_virus.xml

    Just suggest remove old Java replace with Java 7

    these locations are not yet just standard but I know works well.

    Hope Helps and Solves

    CatBurglerV8


    Thank You Very Much Very Sincerely CatBurglerV8

    Saturday, March 24, 2012 5:08 AM
  • Hi - protected mode was already off for trusted sites (where I have defined the site I need to access) but I tried this for the Internet Zone and there is no difference. Thanks for the suggestion though!
    • Edited by AJCottrell Wednesday, March 28, 2012 11:55 AM
    Wednesday, March 28, 2012 11:38 AM
  • Hi - 'do not save encrypted pages' is already disabled. Thanks!
    • Edited by AJCottrell Wednesday, March 28, 2012 11:55 AM
    Wednesday, March 28, 2012 11:41 AM
  • The cache removal made no difference.
    Wednesday, March 28, 2012 11:43 AM
  • Please go here as Java 7 I know works too which OS do You have if You have 64 bit make sure 64 bit Java and I would reccommend IE 9 it works good even the beta if it is still beta. Here is Java 7 :

    http://java.com/en/download/faq/java7.xml

    Should solve prob but check 32 or 64 please.

    Later

    CatBurlgerV8


    Thank You Very Much Very Sincerely CatBurglerV8

    Java 6 also is supposed to work! I have both 32 and 64 bit versions on my machine and IE9 refuses to work with either of them. For clarity, this was working fine until a few weeks ago, so the cause for it to stop working is something of a mystery.
    Wednesday, March 28, 2012 11:56 AM
  • Please go here as Java 7 I know works too which OS do You have if You have 64 bit make sure 64 bit Java and I would reccommend IE 9 it works good even the beta if it is still beta. Here is Java 7 :

    http://java.com/en/download/faq/java7.xml

    Should solve prob but check 32 or 64 please.

    Later

    CatBurlgerV8


    Thank You Very Much Very Sincerely CatBurglerV8

    Java v7 solved the issue - though I had to download JavaRa to kill the v6 installation. Thanks!
    Wednesday, March 28, 2012 12:33 PM
  • Is Java Version 7 Update 5 (or higher) installed now or...?
    Wednesday, March 28, 2012 7:19 PM
  • Hi guys.

    I'm having an issue like this and none of the solutions above helped me.

    I'm trying to open a specific web page that is not working with Java only on Internet Explorer (7, 8 nor 9). If I try to open in Google Chrome or Firefox it goes fine.

    I've tried various versions of Java and all my tries were done both on Windows XP Professional and Windows 7 Professional.

    The weird thing is that when I test it through Java webpage or some other page, it goes fine. It is not working only for this specific webpage.

    This is the webpage: http://iweb03ds.magnaclosures.com/stconf.nsf/meeting/mid3FC5EBB1D59C830685257A2900420436

    It is a meeting webpage for our company to present their work to our clients and suppliers. I've also followed their own step-by-step advises, but no good either.

    Could anyone help me on that?

    Tuesday, June 26, 2012 3:30 PM
  • For me it was Active Filtering was enabled. Deselect it with Alt+T.

    http://windows.microsoft.com/en-us/internet-explorer/use-activex-filtering#ie=ie-10-win-7

    Turn off ActiveX Filtering for individual sites

    1. Open Internet Explorer.

    2. Go to the site you want to allow ActiveX controls to run on.

    3. Click the Filter button in the Address bar, and then click Turn off ActiveX Filtering.

    • Edited by wkbia11 Sunday, January 19, 2014 6:22 PM
    Sunday, January 19, 2014 6:13 PM
  • just dial 1-855-233-7309 (toll free) technical support number for Java not working in Internet Explorer..
    Wednesday, June 18, 2014 10:40 AM