none
Windows Update issue "Windows 7" error "...because updates on this computer are controlled" RRS feed

  • Question

  • I'm trying under "Windows Update" to click on "check for updates" however when I do that I get message

    "windows update cannot currently check for updates, because updates on this computer are controlled by your system administrator"

    I am the admin on the PC however this PC points to a In-office "WSUS server" to normally get its update

    Is there a work around to this that I could add to my local group policy or registry?

    I have been under Group Policy Object Editor -->Computer Configuration --> Administrative Templates --> Windows Components --> Windows Update but seen nothing that would allow to override this error

    Any suggestion(s) would be most appreciated

    JMurphNE





    • Edited by JMurphNE Monday, February 1, 2016 6:04 PM
    Monday, February 1, 2016 6:03 PM

All replies

  • Hi,

    I quite understand your issue. It is the domain policy that make you PC check for updates via WSUS. If you do not want to check for updates via WSUS, you need to let the client quite the domain, then follow the steps below to change it.

    1. Type "regedit" in search box and enter.

    2. Locate to the registry path of "HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate".

    3. Delete the "WindowsUpdate" key and reboot the PC.

    If you want to edit the domain policy to disable WSUS, please locate to "Group Policy Object Editor", navigate to the path of "Computer configuration" > "Administrate Templates" > "Windows Components" > "Windows Update". Then click "Specify Intranet Microsoft update service location" and choose "Disable".

    Hope it will be helpful to you.

    Best Regards,

    Simon


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, February 2, 2016 6:29 AM
    Moderator
  • Simon

    Thanks for the suggestions

    I have tried both and neither one resolved the issue

    Thanks again

    Tuesday, February 2, 2016 6:53 PM
  • Hi,

    Thank you for your reply.

    Could you please tell me whether you edit the domain policy or the local policy. Based on my research, the "Specify Intranet Microsoft update service location" policy exits in both local and domain policy. For editing domain policy, you need to the domain administrator permission.

    Wish you have a nice day.

    Best Regards,

    Simon


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, February 3, 2016 1:04 AM
    Moderator
  • I type into MY Pc gpedit.msc so therefore it must be a "Local Policy"
    Wednesday, February 3, 2016 3:32 PM
  • Hi,

    If you are in the domain, you also need to contact your domain administrator to check if it exits domain policy.

    Wish you have a nice day.

    Best Regards,

    Simon 


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, February 4, 2016 1:28 AM
    Moderator