none
uncheck mark of on fast network use http first RRS feed

  • Question

  • hi all ,

    Is there a way to force clients back to using rpc to connect to 2010 servers?

    I used  Set-OutlookProvider EXPR -OutlookProviderFlags:ServerExclusiveConnect to force https, bbecause the security team block rpc and I didn't find a way to prove that , then after one month I surprised that when people try to provide username and password the outlook don't accept it  so I  reverted with Set-OutlookProvider EXPR -OutlookProviderFlags:none

    But the clients are still trying to use https and I have to go to every client to uncheck the "use http first " what can I do  so that he can access exchange using rpc

    Wednesday, November 27, 2019 7:04 AM

Answers

  • Hi om zeyad,

    I recommend you to run the command below to revert the settings and see if the issue pesists.

    Set-OutlookProvider EXCH -OutlookProviderFlags:None

    Set-OutlookProvider EXPR -OutlookProviderFlags:None

    By the way, you can also use Group policy to modify the client settings, refer to this article and change some of the steps if you want to force user using RPC to connect Exchange: https://www.ntweekly.com/2018/01/25/configure-outlook-anywhere-outlook-2016-using-group-policy/
    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    Eric Yin


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Marked as answer by om zeyad Thursday, December 5, 2019 12:34 PM
    Thursday, November 28, 2019 9:00 AM

All replies

  • Hi om zeyad,

    I recommend you to run the command below to revert the settings and see if the issue pesists.

    Set-OutlookProvider EXCH -OutlookProviderFlags:None

    Set-OutlookProvider EXPR -OutlookProviderFlags:None

    By the way, you can also use Group policy to modify the client settings, refer to this article and change some of the steps if you want to force user using RPC to connect Exchange: https://www.ntweekly.com/2018/01/25/configure-outlook-anywhere-outlook-2016-using-group-policy/
    Please Note: Since the web site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.

    Regards,

    Eric Yin


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    • Marked as answer by om zeyad Thursday, December 5, 2019 12:34 PM
    Thursday, November 28, 2019 9:00 AM
  • Dear Eric,

    first I appreciate your kind support.

    kindly be noted that I issued the command that you mentioned before I write the post ,but as I mentioned the check mark of "in fast network use http first " is still there and need to be moved manually ,issuing this command "Set-OutlookProvider EXPR -OutlookProviderFlags:None " only permit to uncneck the

    mark on "in fast network use http " manually so it won't be forced by exchange anymore

    as you see below

    [PS] C:\scripts>Get-OutlookProvider | fl


    RunspaceId           : 7a554962-dc0e-4b1d-9b73-d9f34a702496
    CertPrincipalName    :
    Server               :
    TTL                  : 1
    OutlookProviderFlags : None
    AdminDisplayName     :
    ExchangeVersion      : 0.1 (8.0.535.0)
    Name                 : EXCH
    DistinguishedName    : CN=EXCH,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=First Organization,CN=Microsoft Exchange,
                           CN=Services,CN=Configuration,DC=mydomain,DC=local
    Identity             : EXCH
    Guid                 : 12d6af27-73a2-43ab-9dcf-dcf4091ec5b3
    ObjectCategory       : mydomain.local/Configuration/Schema/ms-Exch-Auto-Discover-Config
    ObjectClass          : {top, msExchAutoDiscoverConfig}
    WhenChanged          : 9/22/2011 2:29:04 PM
    WhenCreated          : 9/18/2011 1:39:00 PM
    WhenChangedUTC       : 9/22/2011 12:29:04 PM
    WhenCreatedUTC       : 9/18/2011 11:39:00 AM
    OrganizationId       :
    OriginatingServer    : ADC.mydomain.local
    IsValid              : True

    RunspaceId           : 7a554962-dc0e-4b1d-9b73-d9f34a702496
    CertPrincipalName    :
    Server               :
    TTL                  : 1
    OutlookProviderFlags : None
    AdminDisplayName     :
    ExchangeVersion      : 0.1 (8.0.535.0)
    Name                 : EXPR
    DistinguishedName    : CN=EXPR,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=First Organization,CN=Microsoft Exchange,
                           CN=Services,CN=Configuration,DC=mydomain,DC=local
    Identity             : EXPR
    Guid                 : 05109b75-4999-4249-b31e-78eecc41a60f
    ObjectCategory       : mydomain.local/Configuration/Schema/ms-Exch-Auto-Discover-Config
    ObjectClass          : {top, msExchAutoDiscoverConfig}
    WhenChanged          : 11/17/2019 6:59:09 AM
    WhenCreated          : 9/18/2011 1:39:00 PM
    WhenChangedUTC       : 11/17/2019 4:59:09 AM
    WhenCreatedUTC       : 9/18/2011 11:39:00 AM
    OrganizationId       :
    OriginatingServer    : ADC.mydomain.local
    IsValid              : True

    RunspaceId           : 7a554962-dc0e-4b1d-9b73-d9f34a702496
    CertPrincipalName    :
    Server               :
    TTL                  : 1
    OutlookProviderFlags : None
    AdminDisplayName     :
    ExchangeVersion      : 0.1 (8.0.535.0)
    Name                 : WEB
    DistinguishedName    : CN=WEB,CN=Outlook,CN=AutoDiscover,CN=Client Access,CN=First Organization,CN=Microsoft Exchange,C
                           N=Services,CN=Configuration,DC=mydomain,DC=local
    Identity             : WEB
    Guid                 : 26a55a51-72d7-4173-a290-ae2f49ca5d89
    ObjectCategory       : mydomain.local/Configuration/Schema/ms-Exch-Auto-Discover-Config
    ObjectClass          : {top, msExchAutoDiscoverConfig}
    WhenChanged          : 9/22/2011 2:29:04 PM
    WhenCreated          : 9/18/2011 1:39:01 PM
    WhenChangedUTC       : 9/22/2011 12:29:04 PM
    WhenCreatedUTC       : 9/18/2011 11:39:01 AM
    OrganizationId       :
    OriginatingServer    : ADC.mydomain.local
    IsValid              : True

    regarding the group policy

    the option of RPC/http connection flag is not existed in outlook 2010 gropu policy administrative template

    but available in outlook 2016 administrative template and most of our users use outlook 2010.

    so it's difficult to go to every user and uncheck this option "on fast network use http first "

    so any ideas

    I will try to issue the command again but after working hours

    thanks


    • Edited by om zeyad Thursday, November 28, 2019 12:36 PM
    Thursday, November 28, 2019 10:57 AM
  • Thursday, November 28, 2019 12:51 PM
  • Hi om zeyad,

    Thanks for reply.

    Feel free and post your result back please.

    Regards,

    Eric Yin


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Friday, November 29, 2019 9:33 AM
  • Hi, I'm here to confirm with you if your issue has been resolved. If the problem is successfully solved, you can share your solution and mark them or the helpful reply as answer, this will make answer searching in the forum easier and be beneficial to other community members as well.

    Regards,

    Eric Yin


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Wednesday, December 4, 2019 10:19 AM
  • thanks
    Thursday, December 5, 2019 12:34 PM
  • I’m pleased to know that the information is helpful to you.
     
    Here I will provide a brief summary of this post so that other forum members could easily find useful information here:
    [Previous Versions of Exchange > Exchange Server 2010|uncheck mark of on fast network use http first — Summary]
     
     
    Issue Symptom:use Set-OutlookProvider EXPR to force https but not work

    (Possible) Cause:The command is not suitable for this scenario
        
     
    Solution:follow the steps in the link to use GPO to force https
     
    Reference Links:https://www.ntweekly.com/2018/01/25/configure-outlook-anywhere-outlook-2016-using-group-policy/
     
    Friday, December 6, 2019 1:36 AM